Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

INTERVLAN Routing

I have Layer2 cisco WS-C2924-XL swicth and 2620 router

I want to enable intervlan routing between two vlan

Sample1- 10.1.254.0/24

sample2-10.1.253.0/24

Swicth1#vlan database

Swicth1(vlan)#vlan 2 name sample1

Swicth1(vlan)#vlan 3 name sample2

Swicth1(config)#int fa0/1

Swicth1(config-if)#swicthport access vlan 2

Swicth1(Config-if)#no shut

Swicth1(config)#int fa0/2

Swicth1(config-if)#swicthport access vlan 3

Swicth1(Config-if)#no shut

Swicth1(config)# int fa0/24

Swicth1(config-if)#duplex full

Swicth1(config-if)#speed 100

Swicth1(config-if)#switchport trunk encapsulation dot1q

Swicth1(config-if)#switchport mode trunk

Router1(config)#int fa0/1

Router1(config-if)#no ip address

Router1(config-if)#duplex full

Router1(config-if)#speed 100

Router1(config)#int fa0/1.1

router1(config-subif)#Ip address 10.1.254.1 255.255.255.0

router1(config-subif)#encapsulation dot1q

Router1(config)#int fa0/1.2

router1(config-subif)#Ip address 10.1.253.1 255.255.255.0

router1(config-subif)#encapsulation dot1q

is there any thing else i have to configure in swicth and router to enable intervlan routing.

Kindly help me.

Thanks

ranga

11 REPLIES
Silver

Re: INTERVLAN Routing

Yes, define the routing protocol, since without routing protocol you can't communicate between the two VLAN.

VLAN on swithces are only L2..

You can use EIGRP, OSPF or what you want...

bye

FCS

Please rate me if Ihelped.

Re: INTERVLAN Routing

hi,

i am not agree with farkascsqy... i dont think so for intervlan routing you need to have the routing protocols... as layer2 switch is not having capability to make communication between two different vlan... thats why we select the layer 3 device which is router... now router will make communication between two different vlans... as you create the subinterfaces on the same physical interface of the same router so they are directly connected... so you dont need to have the routing protocol for intervlan routing... ya you can publish your different vlan network into routing protocol so that other host on your network can reachable to that hosts...

one time just fire command shut and then no shut on the main physical interface...

hope this will clear your idea

rate this post if it helps

regards

Devang

Silver

Re: INTERVLAN Routing

Devang, you are right, the two VLAN are connected interface....

To reach this VLANs from remotly routing protocol is required

Bye

FCS

Please rate me if I helped.

Blue

Re: INTERVLAN Routing

i would still disagree.

a routing protocol is not required.

if you need to access the defined subnets "remotely" (from subnets not directly connected to that router) you could easily use static routes.

Silver

Re: INTERVLAN Routing

static route or dynamic routing protocol is requiered to access VLANS from remotely.

In this case totally dependent what kind of routing protocol is used (static or dynamic)...... on of them are needed..

To use static routes are required more administrative work, of course if this is a small network even test environment you can use static routes, but usually in life if we can we prefer dynamic routing protocol.

I hope Greg agree with me...

Bye

FCS

Please rate me if I helped!

Blue

Re: INTERVLAN Routing

i agree with your final statement, i just did not agree that 'a routing protocol is required'.

thank you for your clarification.

as network designers and admins, yes we want the most effective means of administering and dynamic protocols are very effective at their tasks in todays networks.

by no means should a routing protocol be overlooked or ignored in almost any environment. (especially in multi-router environments)

New Member

Re: INTERVLAN Routing

Hi all,

Kindly tell me whether the configuration what i have written is correct so that sample1 vlan can communicate with sample2.

I do not what to do in the router.

Kindly help me.

Thanks

Ranga

New Member

Re: INTERVLAN Routing

Ranga,

The configuration you have should work, You do not need a routing protocol as the interfaces are on the same router it already knows how to reach the subnets allocated to each interface.

HTH

Neil

Re: INTERVLAN Routing

ranga... your configuration will work perfectly...

make sure your fastethernet is up...

rate all the posts, if it helps

regards

Devang

New Member

Re: INTERVLAN Routing

the vital bit of information missing is the vlan number on the end of your encapsulation command

ie "encapsulation dot1q"

should be "encapsulation dot1q 1"

for fa0/0.1

and "encapsulation dot1q 2"

for fa0/0.2

Router1(config)#int fa0/1.1

router1(config-subif)#Ip address 10.1.254.1 255.255.255.0

--->router1(config-subif)#encapsulation dot1q 1

Router1(config)#int fa0/1.2

router1(config-subif)#Ip address 10.1.253.1 255.255.255.0

-->router1(config-subif)#encapsulation dot1q 2

Bronze

Re: INTERVLAN Routing

Yes, It is clear that you need to define a vlan number after you issued encapsulation dot1q "VLAN-ID". I think, afterthat everything will be fine.

Dynamic routing protocol IS NOT REQUIRED.

Thanks

Abd Alqader

178
Views
8
Helpful
11
Replies