Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Ipconflict with NAT

Design

Pc1vlan1-->

SW ----> Ruter --->> ruter

Pc1vlan2-->

pc1vlan1 ip 10.102.79.5/20 GW 10.102.79.254

pc1vlan2 ip 10.152.79.4/20 GW 10.102.79.254

with the below mentioned configuration, vlan1 workstation and router keep on poping up ip conflict error message. there is only single workstation in each vlan

the configuration of the as follow

!

interface FastEthernet0/0

ip address 10.248.1.1 255.255.255.252

ip nat outside

ip virtual-reassembly

duplex auto

speed auto

!

interface FastEthernet0/0.1

!

interface FastEthernet0/1

no ip address

ip nat inside

ip virtual-reassembly

duplex auto

speed auto

!

interface FastEthernet0/1.1

encapsulation dot1Q 1 native

ip address 10.102.79.254 255.255.240.0 secondary

ip address 172.18.1.254 255.255.255.0

no snmp trap link-status

!

interface FastEthernet0/1.2

encapsulation dot1Q 2

ip address 10.152.79.254 255.255.240.0 secondary

ip address 172.20.1.254 255.255.255.0

no snmp trap link-status

!

interface Content-Engine1/0

no ip address

shutdown

!

router ospf 1

log-adjacency-changes

network 10.248.1.1 0.0.0.0 area 0

network 172.18.1.254 0.0.0.0 area 0

network 172.20.1.254 0.0.0.0 area 0

!

ip classless

!

no ip http server

no ip http secure-server

ip nat inside source static network 10.102.79.0 172.18.1.0 /24

ip nat inside source static network 10.152.79.0 172.20.1.0 /24

!

I want achieve the two subnets/vlan 10.102.79.0/20 and 10.152.79.0/20 has to be nated with 172.18.1.0/24 and 172.20.1.0/24 address.. Please guide me where I am missing...

1 REPLY

Re: Ipconflict with NAT

You should not use the secondary adresses. This problem can be solved using nat pools and route maps. Please consult the link below for more info on NAT:

http://www.cisco.com/en/US/tech/tk648/tk361/tk438/tsd_technology_support_sub-protocol_home.html

Regards,

Leo

112
Views
0
Helpful
1
Replies