Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

load balancing

If I have 2 routers, both with connections out the building to the same place, How would I load balance these ? my clients all use the same router for there default gateway !! can someone tell me how to do this using eigrp and also statics ?

thanks

7 REPLIES

Re: load balancing

Hi Carl,

You can go for MHSRP for your clients load balancing on 2 different routers.

Now once dine with MHSRP your clients are already load balancing and reaching respective routers you can simply have 1 static or defaut route on your routers to pint the traffic out.

HTH

Ankur

New Member

Re: load balancing

thanks Ankur, can you tell me what mhsrp is, i have used hsrp but not hsrp ? can you possibly give me a quick example config ? ie what routes are pointing where ?

Re: load balancing

Hi Carl,

MHSRP is mulitple groups in HSRP. You can loadbalance on same subnet also. Like if you have clients in subnet 192.168.10.x/24 subnet and virtual gateway for them is 192.168.10.1 you can split few your clients pointing to another virtual gateway like 192.168.10.2 in other hsrp group.

Suppose you have 100 clients all pointing to single gateway which is 192.168.10.1 now what you can do is configure 2 groups in HSRP and make one group active on one router and standby on second router and second group active on second router and standby on first router.

Your 50 clients can have one gateway which points to active first router and 50 other clients will point to second gateway which is active on second router.

In this way your network load from clients will split on 2 routers.

Check this link for exact configuration and setup

http://www.cisco.com/en/US/products/hw/switches/ps5023/products_configuration_guide_chapter09186a00805556b6.html#wp1061629

I will appreciate if you take sometime to rate the post.

HTH

Ankur

New Member

Re: load balancing

Hi Ankur, have I got to set 2 different gateways on my clients or do I put them all on the same gateway and the routers do the work ?

thanks

Re: load balancing

Hi Carl,

What I mean is configure few clients with gateway configured in HSRP group one and few clients with different gateway but in same subnet configured in another hsrp group .

If you read the link which I posted in my previous post you will see how you can conifure HSRP with 2 groups having your clients loadbalancing on same subnet.

HTH

Ankur

Re: load balancing

Hi Carl,

Let me try to explain you in detail with sample configurayion

Router A Configuration

RouterA# configure terminal

RouterA(config)# interface fa0/0

RouterA(config-if)# ip address 192.168.10.1 255.255.255.0

RouterA(config-if)# standby 1 ip 192.168.10.3

RouterA(config-if)# standby 1 priority 110

RouterA(config-if)# standby 1 preempt

RouterA(config-if)# standby 2 ip 192.168.10.4

RouterA(config-if)# standby 2 preempt

RouterA(config-if)# end

Router B Configuration

RouterB# configure terminal

RouterB(config)# interface fa0/0

RouterB(config-if)# ip address 192.168.10.2 255.255.255.0

RouterB(config-if)# standby 1 ip 192.168.10.3

RouterB(config-if)# standby 1 preempt

RouterB(config-if)# standby 2 ip 192.168.10.4

RouterB(config-if)# standby 2 priority 110

RouterB(config-if)# standby 2 preempt

RouterB(config-if)# end

What I am trying to explain is 192.168.10.3 is active on router A and 192.168.10.4 is active on router B.

So what you can do is for suppose you have 100 clients , assign 50 clients gateway address as 192.168.10.3 and rest 50 clients gateway address as 192.168.10.4 in this way clients having gateway address as 192.168.10.3 will hit router A and rest of the clients having gateway 192.168.10.4 will hit router B and in this way you can achieve load balancing in same subnet.

Also if Router A or B goes down other router will take care of rest of all the clients so you will achieve redundancy as well as load balancing.

HTH, if yes please rate all post.

Ankur

New Member

Re: load balancing

If your requirement is to use the same IP address for the default gateway, you could use GLBP (Gateway Load Balancing Protocol). Check out the link:

http://www.cisco.com/en/US/products/sw/iosswrel/ps1839/products_white_paper09186a00801541c8.shtml

Eugene

148
Views
8
Helpful
7
Replies
CreatePlease to create content