Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

My switch is not asking for enable password

My switch is not asking for enable password

Here is my switch config:

 

line con 0
line vty 0 4
 access-class 101 in
 exec-timeout 5 0
 transport preferred ssh
 transport input ssh
 transport output none
line vty 5 15
 access-class 101 in
 exec-timeout 5 0
 transport preferred ssh
 transport input ssh
 transport output none

 

Thanks in advance for all your answers

1 ACCEPTED SOLUTION

Accepted Solutions
New Member

If the issue is that you are

If the issue is that you are wanting the switch to prompt you for a password when you attempt to enter privileged exec mode, you have to set one in your initial configuration.

To set an enable password, you have two options:

  1. Switch>enable

      Switch#config t

      Switch(config)#enable password <password>

                     or

                              enable secret <password>

I would recommend you follow that with the " Switch(config)#service password-encryption" command. This will encrypt all of you plain-text passwords that you set.

Thanks,

Ray

7 REPLIES
New Member

If you want to authenticate

If you want to authenticate to the local user accounts add this to line vty 0 4 and line vty 5 15:

 

login local

 

 

New Member

I'm using tacacs+ aaa model

Thank you for your answer, what about if I'm using tacacs+ aaa model

New Member

You would configure AAA

You would configure AAA authentication login group:

aaa authentication login TACACS_AUTH group tacacs+ local

 

Then apply it to the vty lines:

line vty 0 15

login authentication TACACS_AUTH

 

New Member

Thank you again for your

Thank you again for your response, Could I use both under the vty lines?

 

line vty 0 15

login local

login authentication TACACS_AUTH

New Member

No. What I would do is within

No. What I would do is within the AAA authentication configuration is add local after tacacs+. In the event that your device can no longer reach the TACACS server it will use local authentication.

New Member

If the issue is that you are

If the issue is that you are wanting the switch to prompt you for a password when you attempt to enter privileged exec mode, you have to set one in your initial configuration.

To set an enable password, you have two options:

  1. Switch>enable

      Switch#config t

      Switch(config)#enable password <password>

                     or

                              enable secret <password>

I would recommend you follow that with the " Switch(config)#service password-encryption" command. This will encrypt all of you plain-text passwords that you set.

Thanks,

Ray

New Member

It appears that you are

It appears that you are attempting to set up ssh access. In case you have not already done this, you will additionally need to create at least one user for ssh by using this command:

"Switch(config)# username <user> secret <password>"

 

"secret" or "password" can be used, but "secret" will encrypt the password.

1168
Views
0
Helpful
7
Replies
CreatePlease to create content