Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Network design questions

Hi All,

I'm working on a new network design for my company. We're expanding and opening some more offices and satalite sites. We're a UK based company but opening some US sites.

We have a main UK office (Office A on the diagram) a call centre (Office B) and then two buildings on another site (Office C). The USA offices will be very small and only require a couple of computers, hence the small IP allocation. I have marked the IP addresses of the links on the diagram, I intend to use 3560 switches for all the switches marked and all links will be layer 3 to route multiple VLANs from each site to each site (where permitted).

My question is this: How do I achieve this in the switches? I'm thinking that OSPF is the way forward, is this right? I want to do as little configuration on the switches as possible to allow for dynamic updates of the network (i.e. I don't want to add static routes for everything).

If this is the case, where do I begin with OSPF? I have never set it up before.

If OSPF is the wrong thing to use, then what would you recommend?

Thanks for any help..

Regards

Andrew,.

7 REPLIES
New Member

Network design questions

Good Evening

What is the means of connection between Office A and Office B/C. Also, how are the satelites connected with the main office - is it a broadband connection  - or is it a 100mb line etc?

Regards

New Member

Network design questions

Hi Imran,

The links are as follows:

A-B = 75mbps Wireless

A-C = 1Gbps Fibre

B-C = 100Mbps LAN Extension

C/A-C/B = Cat5e cable (i.e. 1GBps)

C-USA/A = 100MBps LAN Extension

USA/A-USA/B = 100MBps LAN Extension

USA/A-USA/C = 100MBps LAN Extension

USA/A-USA/D = 100MBps LAN Extension

Does this help?

Regards

Andrew

Re: Network design questions

If all networking equipment is cisco, the recommendation for a routing protocol is eigrp. You could configure as simply as adding:

Router eigrp 100

Network 172.16.0.0 0.15.255.255

No auto-summary

Sent from Cisco Technical Support iPad App

New Member

Re: Network design questions

Thanks, I'll look into that.

But just for the sake of completeness in my knowledge, is what I'm trying to do with ospf achievable? And if so, where have I gone wrong? According to Wikipedia ospf is a loopless protocol suggesting this should never happen in the first place.

Sent from Cisco Technical Support iPhone App

New Member

Re: Network design questions

Hi Imran,

The config is as below. I'm currently doing with with a test setup of 3x3560 switches with A connected to B connected to C connected to A.

Switch A:

no aaa new-model

ip subnet-zero

ip routing

!

!

no file verify auto

spanning-tree mode pvst

spanning-tree extend system-id

!

vlan internal allocation policy ascending

!

!

interface Loopback0

ip address 172.31.255.1 255.255.255.0

!

interface FastEthernet0/1

switchport access vlan 2

switchport mode access

!

interface FastEthernet0/2

!

.......

interface FastEthernet0/47

no switchport

ip address 172.31.254.9 255.255.255.252

!

interface FastEthernet0/48

no switchport

ip address 172.31.254.1 255.255.255.252

!

!

interface Vlan1

ip address 10.20.1.1 255.255.255.0

!

interface Vlan2

ip address 172.1.0.1 255.255.255.0

!

router ospf 1

log-adjacency-changes

network 172.1.0.0 0.0.0.255 area 0

network 172.31.254.1 0.0.0.0 area 0

network 172.31.254.9 0.0.0.0 area 0

!

ip default-gateway 10.20.1.10

ip classless

ip http server

ip http secure-server

!

ip ospf name-lookup

!

snmp-server community public RO

!

control-plane

!

!

Switch B:

no aaa new-model

ip subnet-zero

ip routing

!

!

!

!

no file verify auto

spanning-tree mode pvst

spanning-tree extend system-id

!

vlan internal allocation policy ascending

!

!

interface Loopback0

ip address 172.31.255.3 255.255.255.0

!

interface FastEthernet0/1

switchport access vlan 2

!

interface FastEthernet0/2

!

!

interface FastEthernet0/47

no switchport

ip address 172.31.254.2 255.255.255.252

!

interface FastEthernet0/48

no switchport

ip address 172.31.254.5 255.255.255.252

!

interface GigabitEthernet0/1

!

interface GigabitEthernet0/2

!

interface GigabitEthernet0/3

!

interface GigabitEthernet0/4

!

interface Vlan1

ip address 10.20.1.3 255.255.255.0

!

interface Vlan2

ip address 172.3.0.1 255.255.255.0

!

router ospf 1

log-adjacency-changes

network 172.3.0.0 0.0.0.255 area 0

network 172.31.254.2 0.0.0.0 area 0

network 172.31.254.5 0.0.0.0 area 0

!

ip default-gateway 10.20.1.10

ip classless

ip http server

ip http secure-server

!

!

Switch C:

no aaa new-model

ip subnet-zero

ip routing

!

!

no file verify auto

spanning-tree mode pvst

spanning-tree extend system-id

!

vlan internal allocation policy ascending

!

!

interface Loopback0

ip address 172.31.255.2 255.255.255.255

!

interface FastEthernet0/1

!

interface FastEthernet0/2

!

interface FastEthernet0/3

!

interface FastEthernet0/46

!

interface FastEthernet0/47

no switchport

ip address 172.31.254.10 255.255.255.252

!

interface FastEthernet0/48

no switchport

ip address 172.31.254.6 255.255.255.252

!

interface Vlan1

ip address 10.20.1.2 255.255.255.0

!

interface Vlan2

ip address 172.2.0.1 255.255.255.0

!

router ospf 1

log-adjacency-changes

network 172.2.0.0 0.0.0.255 area 0

network 172.31.254.6 0.0.0.0 area 0

network 172.31.254.10 0.0.0.0 area 0

!

ip default-gateway 10.20.1.254

ip classless

ip http server

ip http secure-server

!

New Member

Re: Network design questions

Apart from the incorrect subnets on the loop back interfaces can anyone see why I'm getting a loop?

Thanks

Sent from Cisco Technical Support iPad App

New Member

Re: Network design questions

Sorry, I've cross posted this in the LAN forum.

Sent from Cisco Technical Support iPad App

1813
Views
0
Helpful
7
Replies