Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

NM-16ESW module (newbie)

Cisco 2651XM router with

wic-1adsl card

just fitted an NM-16ESW module

as a newbie I'm embarrassed to say I don't know how to connect this module to my network. I had an external hub (connecting several PC's) that went into port f0/0 but I'd like to transfer all those wires into the the NM-16ESW module but none of the PC's will connect to the internet.

The CLI shows the module as f1/0to16 and SDM shows all 16 sockets as 'up'. Do I plug the cable from f0/0/ into the switch? or is the connection internet? I can't find a quick-connect guide anywhere. Thanks for any pointers.

7 REPLIES

Re: NM-16ESW module (newbie)

Please take the opportunity to read the document at the following link, it discuss the EthernetSwitch Module in greath length including configuration:-

http://www.cisco.com/en/US/docs/ios/12_4/interface/configuration/guide/h1636nm.html

Refer to the section How to Configure the EtherSwitch Network Module.

Hope this helps..

Rgds

Allan.

Community Member

Re: NM-16ESW module (newbie)

thanks, I saw that document before posting but it's massive and it put me off. I was hoping there might be a friendlier quick-guide somewhere.

Re: NM-16ESW module (newbie)

I can appreiciate that, configuring the module is similar to that of configuring a Cisco Access switch with inter-vlan routing.

However, if you are not familiar with this, then this too will prove difficult to comprehend.

I assume the IP address are static or sourced from the gateway already using DHCP?

If you are using DHCP then I suspect that your fasthernet interface has IP address on the same LAN, therefore this IP address would require configuring as your L3 vlan interface.

Pls post the configuration?

Here are some quick guide example steps..

Configure your user vlan and vtp mode.:-

vlan database

vtp transparent

vlan 100 name Data-VLAN

Configure your L2 Interfaces:-

interface fastethernet ?/?

switchport

switchport mode access

switchport access vlan 100

speed ?

duplex ?

no shut

exit

Configure you L3 Vlan interface:-

interface vlan 100 (address of your fa0/0?)

ip address xxx.xxx.xxx.xxx 255.255.255.0

no shut

exit

This L3 VLAN address should be the default gateway of your client PC's

Rgds

Allan.

Community Member

Re: NM-16ESW module (newbie)

thanks for your response, attached here is my running config.

To explain the config:

at the moment I have one LAN on f0/0 on 172.16.1.xx and another LAN on f0/1 on 192.168.1.xx, both surf the net through the adsl wic card. All my attached pc's have static addresses.

I just don't know where to start to make this switch work. Should the switch be assigned it's own ip address? thanks for any pointers.

Re: NM-16ESW module (newbie)

Here is a sample configuration to help get you started. Remember to make sure you have a copy of the configuration before you make any changes.

As a backout plan, do not commit the changes to startup unless you happy everything is working. This way you can reload the router and the changes in running-config will be lost.

vlan database

vtp transparent

vlan 172 name VLAN172

vlan 192 name VLAN192

exit

!

Configure your L2 Interfaces for either VLAN172 or VLAN192 or depending on which subnet there static IP address is.

For example I have chosen 172 for 172.16.1.x and 192 for 192.168.1.x. Configure the speed and duplex as appropriate.

L2 Interface assigned to VLAN172:-

interface fastethernet 1/0

switchport

switchport mode access

switchport access vlan 172

speed 100

duplex Full

no shut

exit

OR

L2 Interface assigned to VLAN192:-

interface fastethernet 1/0

switchport

switchport mode access

switchport access vlan 192

speed 100

duplex Full

no shut

exit

Configure you L3 Vlan interfaces for VLAN172 and VLAN192. You will have to shut both your fastethernet interfaces before you can assign the same ip address to the L3 SVI:-

interface vlan 172 (address of your fa0/0)

description $FW_INSIDE$

ip address 172.16.1.30 255.255.0.0

ip access-group 102 in

ip nat inside

no shut

exit

!

interface vlan 192 (address of your fa0/1)

description $FW_INSIDE$

ip address 192.168.1.100 255.255.255.0

ip access-group 103 in

ip nat inside

no shut

exit

Hope this helps..

Allan.

Community Member

Re: NM-16ESW module (newbie)

this config helped get me started, thanks very much Allan. Once I got the jist of it I began to understand how these modules work and I've now got all my machines piped through the switch. I'm impressed with the control you get with these switches.

I also twigged that I don't need the f0/0 and f0/1 ports now so I've turned them off and I've configured different switch sockets to work on different virtual lans. Thanks again.

Re: NM-16ESW module (newbie)

Don't mention it, glad to be of help and to hear that it is all up and working..

All the best.

Allan.

2826
Views
10
Helpful
7
Replies
CreatePlease to create content