Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

PIX 501 PPPoE problems.

I have a Zoom adsl modem setup to accept PPPoE connections. We have verified this with two other, non-cisco devices, and it works.

I have configured the outside interface to connect via PPPoE to the router from within the PDM.

I have set this up with the known correct username and password, and with PAP authentication.

I have captured a debug with the following commands "debug pppoe packet", "debug pppoe error" and "debug pppoe event" and have attached it as file pppoedebug.txt.

"show ip address outside pppoe" gives:

PPPoE session has not been established yet.

I have also attached a running config of the PIX.

If anyone could take a quick look and see if my PIX config appears fine i'd much appreciate it.

I am very new to working with PIX, i'm used to working with IOS.

Thanks for your help.

David

5 REPLIES
New Member

Re: PIX 501 PPPoE problems.

I'm thinking that you still need a default route. You do have a static route like so: "route outside 192.168.101.0 255.255.255.0 10.0.0.2 1", but what about all other traffic?

You need a default route I believe.

I believe you could accomplish this by editing your outside interface statement to the following:

ip address outside pppoe setroute

New Member

Re: PIX 501 PPPoE problems.

I read that the PPPoE wouldnt connect with "setroute" if there was already a default route in place.

So to make it easier i have not been using that option. I have tried it with and without, its not a routing problem, its that the PPPoE connection wont work and wont give me an IP etc.

New Member

Re: PIX 501 PPPoE problems.

I'm not sure if there is an OS bug with PPPOE in version 6.3 but some seem to think there is.

http://tinyurl.com/y945hg

Your config doesn't appear to be off however once you do get authenticated and IP information you won't be able to get very far without the default route info.

New Member

Re: PIX 501 PPPoE problems.

I've upgraded to version 6.3(5) as opposed to 6.3(3) but i still get the same error. You say there might be a bug in 6.3 so me going to 6.3(5) wouldnt have made a difference anyways?

Due to the PIX 501 having Total Memory (16mb) and flash (8mb) I cant upgrade to 7.x. And i really wouldnt want to downgrade to 6.2, but i guess that's worth a try, to see if it really is an firmware fault.

Is there anything else you fine people could suggest?

Thanks for your help.

David.

New Member

Re: PIX 501 PPPoE problems.

6.2(4) doesnt work either. As far as i could tell through CLI. The PDM wouldnt work with versions less than 6.3.

466
Views
6
Helpful
5
Replies
CreatePlease login to create content