Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

port forwarding

Hi

I have a little problem. I can't seem to get my gameserver working ( call of duty) at least not on my cisco router

The server shows on the server list on the internet. But users who try to connect just get an awaiting connection and then time out.

Neither can I connect through the internet to my PC via PCAnyware.. I can connect through my LAN without any problems.

My FTP server ( or me )is having the same problem. no connection.

When I replace my cisco router with my zyxel ( that came from my ISP) there are no problems connecting to my gameserver or to my PC via PCAnyware. ( FTP still doesn't work)

I list my config below.

My router : cisco 877

Please help... Thanks...

!

hostname router

!

logging buffered 51200 warnings

enable secret 5

!

no aaa new-model

!

resource policy

!

ip cef

!

!

no ip dhcp use vrf connected

ip dhcp excluded-address 10.xx.xx.xx 10.xx.xx.xx

ip dhcp excluded-address 10.xx.xx.xx 10.xx.xx.xx

!

ip dhcp pool DHCP

network 10.xx.xx.xx 255.255.255.0

default-router 10.xx.xx.xx

dns-server 212.xx.xx.xx 212.xx.xx.xx

!

interface ATM0

no ip address

no atm ilmi-keepalive

pvc 0/35

encapsulation aal5mux ppp dialer

dialer pool-member 1

!

bundle-enable

dsl operating-mode ansi-dmt

hold-queue 224 in

!

interface FastEthernet0

no cdp enable

spanning-tree portfast

!

interface FastEthernet1

no cdp enable

spanning-tree portfast

!

interface FastEthernet2

no cdp enable

spanning-tree portfast

!

interface FastEthernet3

no cdp enable

spanning-tree portfast

!

interface Vlan1

ip address 10.xx.xx.1 255.255.255.0

ip nat inside

no ip virtual-reassembly

!

interface Dialer0

ip address negotiated

ip access-group 121 in

ip nat outside

ip virtual-reassembly

encapsulation ppp

dialer pool 1

dialer-group 1

no cdp enable

ppp authentication chap callin optional

ppp chap hostname

ppp chap password 7

!

ip route 0.0.0.0 0.0.0.0 Dialer0 permanent

!

!

no ip http server

no ip http secure-server

ip nat inside source list 40 interface Dialer0 overload

ip nat inside source static udp 10.xx.xx.10 5632 interface Dialer0 5632

ip nat inside source static tcp 10.xx.xx.10 5632 interface Dialer0 5632

ip nat inside source static udp 10.xx.xx.10 5631 interface Dialer0 5631

ip nat inside source static tcp 10.xx.xx.10 5631 interface Dialer0 5631

ip nat inside source static udp 10.xx.xx.10 28960 interface Dialer0 28960

ip nat inside source static tcp 10.xx.xx.10 28960 interface Dialer0 28960

ip nat inside source static udp 10.xx.xx.10 20510 interface Dialer0 20510

ip nat inside source static udp 10.xx.xx.10 20500 interface Dialer0 20500

ip nat inside source static tcp 10.xx.xx.10 21 interface Dialer0 21

ip nat inside source static tcp 10.xx.xx.10 20 interface Dialer0 20

!

access-list 10 permit 10.xx.xx.0 0.0.0.255

access-list 10 permit 10.xx.xx.0 0.0.0.255

access-list 40 permit 10.xx.xx.0 0.0.0.255

access-list 121 permit udp any any eq bootpc

access-list 121 permit icmp any any echo

access-list 121 permit icmp any any echo-reply

access-list 121 permit icmp any any unreachable

access-list 121 permit udp any eq isakmp any eq isakmp

access-list 121 permit esp any any

access-list 121 permit gre any any

access-list 121 permit tcp any any eq ftp

access-list 121 permit tcp any any eq ftp-data

access-list 121 permit tcp any any eq 5631

access-list 121 permit udp any any eq 5631

access-list 121 permit tcp any any eq 5632

access-list 121 permit udp any any eq 5632

access-list 121 permit tcp any any eq 28960

access-list 121 permit udp any any eq 28960

access-list 121 permit udp any any eq 20510

access-list 121 permit udp any any eq 22500

access-list 121 permit ip any any

dialer-list 1 protocol ip permit

no cdp run

!

!

!

!

control-plane

!

!

line con 0

no modem enable

line aux 0

line vty 0 4

access-class 10 in

password

login

!

scheduler max-task-time 5000

end

1 REPLY
Silver

Re: port forwarding

Make sure Server is configured for Static IP Nat.Try to remove the access list and reconfigure it again.If that doesnt work try upgrading IOS version.

226
Views
0
Helpful
1
Replies