Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Problems upgrading Flash in a 2610 Router

Hi,

I am trying to upgrade the flash in a 2610 from 8meg to 16meg (only one flash slot).

After putting the new flash simm in & booting up, I get to the rommon prompt & although I can do the tftpdnld command & get the OS to transfer from my tftp server, I then get error messages on the 2610 & it seems to start deleting itself.

The constant message I get is:

get_man_dev: Unknown device - probably NOT formatted.

Does this mean that the new flash may be faulty?

I tried confreg 0x2101 to get to the router (boot)> command but this does not work either & I still get the the rommon prompt.

What is the best way to upgrade the flash in a 2610, bearing in mind it only has one slot?

thanks

Simon

1 REPLY
Cisco Employee

Re: Problems upgrading Flash in a 2610 Router

The error message (get_man_dev) is saying that it can't recognize the flash chip inside the router,

and it assumes that it's not formatted properly.

The first thing I would do look at is the internal flash simms.

I would remove and re-install all of the

flash and DRAM chips in the box to make sure they are seated properly.

Perhaps even remove all the cards in the slots so the router can boot up with nothing interrupting it.

If after you do this and still no go, it looks like it might be a hardware failure

143
Views
0
Helpful
1
Replies
CreatePlease to create content