Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Problems with PAT

Hello,

I am a newbie to managing Cisco equipment and I have run into a problem. I need to set up PAT for a small office with only 1 public IP address. I have not had any luck despite using multiple articles, and chapters in CISCO books.

The router is an 870 series with a switch attached to the fastethernet0 port. I am attaching my current configuration, so could someone please look over it and tell me what I am doing wrong,

Thanks.

1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Re: Problems with PAT

Here is what you need to get this working. First I don't understand why you are trying to bridge on the FastEthernet4 interface. Here is what you should do to get this working:

1. Under FastEthernet4 remove the bridge-group

!

interface FastEthernet4

ip address 38.100.xx.xx 255.255.255.248

ip nat outside

ip virtual-reassembly

duplex auto

speed auto

no bridge-group 2

!

2. Get rid of the BVI interface. This is only necessary when bridging between the Wireless interface and a vlan for the wireless clients. Its not necessary here.

!

no interface BVI2

3. This needs to be removed and you need to add FastEthernet4 to it.

ip nat inside source list 1 interface FastEthernet4 overload

!

4. Modify the ACL, this is redundant and the last line covers it all.

no access-list 1

access-list 1 permit 192.168.0.0 0.0.0.255

You have to hook the WAN connection to Fa4 for this to work. I assume you know that. You also do not have DHCP so you have to statically assign the DNS and IP addresses.

HTH

Anthony

3 REPLIES
Silver

Re: Problems with PAT

Try this link for a very simple explanation:

http://www.cisco.com/en/US/tech/tk648/tk361/technologies_tech_note09186a0080094e77.shtml

Looking over your configuration, are the IP addresses on the FE4 and BVI2 the same or different? I usually use the BVI interface to bridge my wireless traffic to my internal network.

HTH

Steve

New Member

Re: Problems with PAT

Thanks for your reply. I set up BVI2 so that I could bridge it after getting the wired network to work. Fastethernet4 is the same IP, but I created it when I got frustrated with BVI2 not working with PAT. Will having them both set at the same IP cause problems if I am not using fastethernet 4 for anything?

Thanks

Jason

Cisco Employee

Re: Problems with PAT

Here is what you need to get this working. First I don't understand why you are trying to bridge on the FastEthernet4 interface. Here is what you should do to get this working:

1. Under FastEthernet4 remove the bridge-group

!

interface FastEthernet4

ip address 38.100.xx.xx 255.255.255.248

ip nat outside

ip virtual-reassembly

duplex auto

speed auto

no bridge-group 2

!

2. Get rid of the BVI interface. This is only necessary when bridging between the Wireless interface and a vlan for the wireless clients. Its not necessary here.

!

no interface BVI2

3. This needs to be removed and you need to add FastEthernet4 to it.

ip nat inside source list 1 interface FastEthernet4 overload

!

4. Modify the ACL, this is redundant and the last line covers it all.

no access-list 1

access-list 1 permit 192.168.0.0 0.0.0.255

You have to hook the WAN connection to Fa4 for this to work. I assume you know that. You also do not have DHCP so you have to statically assign the DNS and IP addresses.

HTH

Anthony

114
Views
0
Helpful
3
Replies
CreatePlease login to create content