Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

"configure replace" command failure

Hello everybody,

In order to change large portions of my running-config without restarting my router, I tried to perform the command "configure replace nvram:my-special-conf"

It worked well with a Cisco 3845 router - IOS image: c3845-advipservicesk9-mz.124-15.T.bin

But it didn't with two of 7206 VXR routers with their respective images:

- Cisco 7206 VXR - IOS image: c7200p-spservicesk9-mz.124-4.XD7.bin

- Cisco 7206 VXR - IOS image: c7200-k91p-mz.122-25.S14.bin

Here is the output :

Router7200#config replace nvram:special-config

This will apply all necessary additions and deletions

to replace the current running configuration with the

contents of the specified configuration file, which is

assumed to be a complete configuration, not a partial

configuration. Enter Y if you are sure you want to proceed. ? [no]: Y

Error: could not write to output buffer incremental-temp.cfg

Rollback aborted after 1 passes

Router7200#

I neither found something about this error in the configuration guide (http://www.cisco.com/en/US/docs/ios/12_3t/12_3t7/feature/guide/gtrollbk.html), nor in google.

Did anyone know what is the problem and how to solve it ?

Thanks.

3 REPLIES

Re: "configure replace" command failure

I have never used or even ever seen this command (but love learning new stuff!), I searched the web and found this:

http://www.nil.si/ipcorner/ConfigReplacement/

When faced with IOS configuration that cannot be changed (for example, the IP Service Level Agreement - SLA - configuration in Table 3), configuration rollback fares a lot better. It aborts the rollback process after five passes and gives you the list of commands it has attempted to execute in the last pass (Listing 6). You can then use the command list to fix the remaining configuration changes manually.

You can also go to page 91 of:

http://www.cisco.com/en/US/prod/collateral/iosswrel/ps6537/ps6555/prod_presentation0900aecd805456f7.pdf

HTH,

Jimmy

I searched Google for:

"rollback aborted" cisco

Hall of Fame Super Gold

Re: "configure replace" command failure

Nice topic. +5 Jimmy

New Member

Re: "configure replace" command failure

Thank you Jimmy for your response.

Unfortunately it's not a problem of "unremovable IOS commands" like SLA: the sole difference between my running-conf and special-conf is "shutdown" and "rate-limit" interface-mode commands used to change commited access rate (a configured bandwidth) of an interface.

Besides, these changes worked well on my 3845 router.

I continue to investigate.

Thanks,

Chemsi

1364
Views
5
Helpful
3
Replies