Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

repair cisco 2600 router

cisco 2651XM router - mainboard numbers SN: FOC 09023HY2 and 73-7756-06 B0.

I have this router with a fault, no traffic will flow in or out of either ethernet ports 0/0 or 0/1.

The console port works fine and I've uploaded IOS c2600-ipbasek9-mz.124-17.bin to the router using xmodem. The router appears to boot up fine and goes through all the usual motions but I can never get any traffic action from the two onboard ethernet ports. From another PC I can't ping the ip address of the ports, and from the router I can't ping anything and I've tried both connection to a hub and crossover cable straight to another PC. I've taken great pains to ensure there's nothing wrong with the cables and anything outside the router. I've watched the port action in wireshark during a ping from the router and it just shows protocol 0x1806 (unknown). Also when I was trying to restore the router using tftp from rommon I got the same thing in wireshark.

What I've tried so far:

1) changed power supply with good one

2) changed both roms U24 and U25 with know good ones.

3) changed all memory sticks with tested good ones.

4) renewed all 5 capacitors C13 C14 C15 C16 C17.

I saw a couple of crystal oscillators on the maionboard labelled 16.934 and 3.686 but I haven't renewed those yet.

However if I fit a 16 port switch module (NM-16ESW) that works fine, traffic flows normally through it. I'm scratching my head whether this would be a hardware fault or a software based fault and I'd appreciate opionions about what could be wrong. I would like to fix this router if possible.

2 REPLIES
New Member

repair cisco 2600 router

Hi Tony,

The Ports are linking up (light) or not?

If not can be the transceiver but because the problem is in two ports is easier that the problem

resides either on the oscillator or the driver chip.

Regards,

Bronze

Re: repair cisco 2600 router

The question About lights need to be answerd first,
After that check (and post) output from "show running-config interface fa0/0"
Check speed and duplex are set correctly and port is not " shutdown"

Sent from Cisco Technical Support iPad App

626
Views
0
Helpful
2
Replies
CreatePlease to create content