Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

Router not issuing IP's

Hello all,

Newbie here and have been working on configuring a router and not having any luck getting ip's from it.

Any help will greatly be appreciated....

Current configuration : 3990 bytes

!

! Last configuration change at 01:06:48 PCTime Thu Aug 29 2013

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname St.Patricks

!

boot-start-marker

boot-end-marker

!

logging message-counter syslog

enable secret 5 $1$lvNA$wGnkzv7kjLmif0RNDxf2g0

!

no aaa new-model

clock timezone PCTime -6

clock summer-time PCTime date Apr 6 2003 2:00 Oct 26 2003 2:00

!

crypto pki trustpoint TP-self-signed-3607837666

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-3607837666

revocation-check none

rsakeypair TP-self-signed-3607837666

!

!

crypto pki certificate chain TP-self-signed-3607837666

certificate self-signed 01

  30820243 308201AC A0030201 02020101 300D0609 2A864886 F70D0101 04050030

  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274

  69666963 6174652D 33363037 38333736 3636301E 170D3133 30383239 30363232

  34395A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649

  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D33 36303738

  33373636 3630819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281

  8100E525 0425ECCD 2F904636 B21AF280 AD7993E4 8F79564C 6203B366 E769FAF5

  62DACE0A 40CFD386 0F5BD78F FE7C6A7C EACC4A3C 3F84A48C AC7D3280 9FF029BE

  D5BA4E83 00F7BD4B 11984721 76F5CCDF D03E6CD7 84195C8F 73D770C8 99734F0D

  4F583941 0BE9FD8D 87F3D876 FFDB0588 2BECA057 79DA62D2 AC47D3ED 6AE5C7F4

  B3AB0203 010001A3 6B306930 0F060355 1D130101 FF040530 030101FF 30160603

  551D1104 0F300D82 0B53742E 50617472 69636B73 301F0603 551D2304 18301680

  146385C7 4B02E815 B28909F2 2A604395 37FB3F60 21301D06 03551D0E 04160414

  6385C74B 02E815B2 8909F22A 60439537 FB3F6021 300D0609 2A864886 F70D0101

  04050003 81810067 7A20CF98 7D7FAC17 A5B73A4A 00BEAE11 3BFFF9BC 1A74E61A

  E7DC833C FDBA0BB8 A0F74011 C3B1F3AA 0CF39238 66A9AF5F EB62E3C3 D92A4289

  E6000537 D253E03F A1B95F7C A545EC84 14724057 E72DAEE2 568A7B40 174FEB03

  1373CFAE 4BEC84B1 794E3E1B D56E2DDC DD2B1162 7B0A782C A4D2391E 83DA63D6

  4CD7029D B9F668

        quit

dot11 syslog

ip source-route

!

!

ip dhcp excluded-address 10.10.10.1 10.10.10.99

!

ip dhcp pool DHCP_POOL

   import all

   network 10.10.10.0 255.255.255.0

   dns-server 208.67.222.123 208.67.220.123

   default-router 10.10.10.1

   domain-name St.Patricks

!

!

ip cef

no ip domain lookup

no ipv6 cef

!

multilink bundle-name authenticated

!

!

!

username patrick privilege 15 secret 5 $1$MLJt$jLLnyQkm61ukzlwxHB/7f0

!

!

!

archive

log config

  hidekeys

!

!

!

!

!

interface FastEthernet0

description WAN

ip address dhcp

ip nat outside

ip virtual-reassembly

duplex auto

speed auto

!

interface FastEthernet1

no ip address

shutdown

duplex auto

speed auto

!

interface FastEthernet2

!

interface FastEthernet3

!

interface FastEthernet4

!

interface FastEthernet5

!

interface FastEthernet6

!

interface FastEthernet7

!

interface FastEthernet8

!

interface FastEthernet9

!

interface Dot11Radio0

no ip address

shutdown

speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0

station-role root

!

interface Dot11Radio1

no ip address

shutdown

speed basic-6.0 9.0 basic-12.0 18.0 basic-24.0 36.0 48.0 54.0

station-role root

!

interface Vlan1

no ip address

!

interface Async1

no ip address

encapsulation slip

!

ip forward-protocol nd

ip http server

ip http authentication local

ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

!

!

!

!

!

!

!

!

!

control-plane

!

banner motd ^C

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

YOU ARE NO AUTHORIZED -------- SEE ADMINISTRATOR

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

^C

alias exec s show ip int br

alias exec sr show run

!

line con 0

exec-timeout 0 0

logging synchronous

line 1

modem InOut

stopbits 1

speed 115200

flowcontrol hardware

line aux 0

line vty 0 4

login

transport input telnet ssh

!

end

Thanks!

1 ACCEPTED SOLUTION

Accepted Solutions
VIP Purple

Re: Router not issuing IP's

The router doesn't have an IP configured on an interface. Assuming that you want to use the switchports for your PCs, you have to configure the following:

interface vlan 1

  ip address 10.10.10.1 255.255.255.0

But for communication to the internet you need also NAT and (if available) a firewall-config.

-- 
Don't stop after you've improved your network! Improve the world by lending money to the working poor:
http://www.kiva.org/invitedby/karsteni

2 REPLIES
VIP Purple

Re: Router not issuing IP's

The router doesn't have an IP configured on an interface. Assuming that you want to use the switchports for your PCs, you have to configure the following:

interface vlan 1

  ip address 10.10.10.1 255.255.255.0

But for communication to the internet you need also NAT and (if available) a firewall-config.

-- 
Don't stop after you've improved your network! Improve the world by lending money to the working poor:
http://www.kiva.org/invitedby/karsteni

Community Member

Re: Router not issuing IP's

That was what I was missing. That worked. Thanks!

399
Views
0
Helpful
2
Replies
CreatePlease to create content