Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Separating a test network w/ 1720 router

I've got what may seem like an obvious problem, but I'm trying to create a test network separate from my production environment. I have a spare 1720 router with a WIC-1DSU-T1 card. I have configured the FE0 interface for the new test network, and the S0 interface for the production network. I'm having trouble getting the serial interface to work. It is in alarm state. Is that because I need "something" on the other end to attach S0 to? Currently, it's just attached to a switch in the production environment. Any help is appreciated.

10 REPLIES

Re: Separating a test network w/ 1720 router

Hi,

What kind of switches is it attached to, and please do post your configuration.

BR,

Mohammed Mahmoud.

Bronze

Re: Separating a test network w/ 1720 router

Hi,

What type of port are you using at the switch ?

Use a wic-1T on your 1720 instead.

BR,

Bjornarsb

New Member

Re: Separating a test network w/ 1720 router

You cannot attach a switch to the WIC-1SU-T1 interface. You would have to attach it to a serial interface on another router using a T1 crossover (cross 1,2 to 4,5)

HTH,

Paul

New Member

Re: Separating a test network w/ 1720 router

Thank you all for your responses. The problem is that I have only one router, not two. Is there any configuration I could do with the existing router to separate the networks using only that one router? I do happen to have a WIC-1T if that helps.

My router config follows:

version 12.2

no parser cache

no service single-slot-reload-enable

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname IT_Test_Router

!

logging rate-limit console 10 except errors

enable secret xxx

!

memory-size iomem 20

ip subnet-zero

ip name-server 192.168.20.44

!

no ip dhcp-client network-discovery

!

!

!

interface FastEthernet0

speed auto

full-duplex

!

interface Serial0

ip address 192.168.20.253 255.255.255.0

encapsulation ppp

!

ip classless

ip route 0.0.0.0 0.0.0.0 192.168.20.7

ip route 10.30.30.0 255.255.255.0 FastEthernet0

no ip http server

!

!

line con 0

line aux 0

line vty 0 4

!

no scheduler allocate

end

New Member

Re: Separating a test network w/ 1720 router

Tha router wn't help you without another ethernet interface, unles I am misunderstanding what you are trying to do.

What kind of switch(es) do you have? Are any layer 3? Alternately, you could create a seperate VLAN on your existing switch for your test network, trunk your uplink to the router and create subinterfaces on the FE port of the router that the switch is uplinked to, depending on your goal. Can you maybe post a diagram of what you are trying to accomplish?

Paul

New Member

Re: Separating a test network w/ 1720 router

I have attached a very simple diagram of what I'm trying to do.

Yes, we have some layer 3 switches and layer 2 switches. I'm basically just trying to figure out how I can use the router to separate out the test network. My PIX firewall doesn't have any extra ports, or else I'd just hang it off of that.

It might come down to me just having to purchase another router, which I'm okay with, I just thought I should be able to do this with just one router.

Re: Separating a test network w/ 1720 router

Though you don't have a second interface to physically separate the two networks you may be able to logically separate the networks using router-on-a-stick feature. Configure two VLANs on the switch, set the switchport connected to the router as a trunk and on the router configure dot1q/isl sub-interface(s) to route traffic for the two VLANs. On your switch assign the ports to which the production or test PCs connected to the appropriate VLANs.

Here's a couple of links that can help you with the configuration.

http://www.cisco.com/univercd/cc/td/doc/product/software/ios120/120newft/120t/120t1/8021q.pdf

http://www.cisco.com/en/US/products/sw/iosswrel/ps1830/products_feature_guide09186a008008742b.html

Use the Cisco Feature Navigator tool see if your router and the IOS support router-on-a-stick feature.

http://tools.cisco.com/ITDIT/CFN/jsp/index.jsp

HTH

Sundar

New Member

Re: Separating a test network w/ 1720 router

Thank you Sundar and Pstebner1. I will try this configuration and see if it works. Wish me luck!

New Member

Re: Separating a test network w/ 1720 router

My understanding is that the 1720 does not support trunking. I believe you would need a 1721 for that.

New Member

Re: Separating a test network w/ 1720 router

Ryan-

Good catch. The 1720 does not support sub-interfaces, so therefore no trunks.

Paul

238
Views
0
Helpful
10
Replies