Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Setting Up Etherchannel

Here is the situation 1 server, 2 nics and 2 3500XL series switxhes. I would like to set up an etherchannel for the server. I have read on cisco's web site that etherchannel cannot be set uo on 2 switches using a gigastack. Is it still possibe to set this up on these switches or do i need to go to 3550 switches.

2 ACCEPTED SOLUTIONS

Accepted Solutions
Cisco Employee

Re: Setting Up Etherchannel

You can connect them to different switches on each stack, but it would not be an etherchannel, you'd have one active, and one standby connection. You'd also want to ensure that the PC does not bridge between the two links, or you'd wind up with a layer 2 loop. This applies whether you have 3500xl switches or 3550s.

The only platform that supports etherchannel across multiple switches in a stack is the 3750 series.

HTH,

Bobby

*Please rate helpful posts.

Cisco Employee

Re: Setting Up Etherchannel

That is correct.

HTH,

Bobby

9 REPLIES
Cisco Employee

Re: Setting Up Etherchannel

Do your NICs support teaming? If so, then simply configure the NICs as a team, and configure the 3500xl ports as an etherchannel as documented here:

http://www.cisco.com/en/US/products/hw/switches/ps637/products_configuration_guide_chapter09186a00800d9d3d.html#xtocid15

Keep in mind thata the 3500xl switches do not support 802.3ad, so you must disable negotiation on your NICs.

HTH,

Bobby

*Please rate helpful posts.

Community Member

Re: Setting Up Etherchannel

will this method still work on 2 3500xl switches? Yes the nics do support teaming but I would rather a switch solution. I do have 2 3550 series switches that can be swapped out to support if that is the only option for this set up if neccessary.

Cisco Employee

Re: Setting Up Etherchannel

You can connect them to different switches on each stack, but it would not be an etherchannel, you'd have one active, and one standby connection. You'd also want to ensure that the PC does not bridge between the two links, or you'd wind up with a layer 2 loop. This applies whether you have 3500xl switches or 3550s.

The only platform that supports etherchannel across multiple switches in a stack is the 3750 series.

HTH,

Bobby

*Please rate helpful posts.

Community Member

Re: Setting Up Etherchannel

Thanks for your prompt reply. So in this set up load balancing is not an option just port redundancy.

Cisco Employee

Re: Setting Up Etherchannel

That is correct.

HTH,

Bobby

Community Member

Re: Setting Up Etherchannel

My case is related so pls. allow me to join. I configured two ports in a L2-etherchannel. Both ports are up-up but I donot know why status 'I' is shown for both ports involved.

to0#show etherchannel summary

Flags: D - down P - in port-channel

I - stand-alone s - suspended

H - Hot-standby (LACP only)

R - Layer3 S - Layer2

U - in use f - failed to allocate aggregator

Number of channel-groups in use: 6

Number of aggregators: 6

Group Port-channel Protocol Ports

------+-------------+-----------+------------------

..

5 Po5(SD) PAgP Gi6/5(I) Gi7/5(I)

..

also: in the following, whats the meaning of 'Port state = Up Sngl-port-Bndl Mstr Not-in-Bndl' ??

to0#sho etherchannel 5 det

Group state = L2

Ports: 2 Maxports = 8

Port-channels: 1 Max Port-channels = 1

Protocol: PAgP

Ports in the group:

-------------------

Port: Gi6/5

------------

Port state = Up Sngl-port-Bndl Mstr Not-in-Bndl

Channel group = 5 Mode = Desirable-Sl Gcchange = 0

Port-channel = null GC = 0x00050001 Pseudo port-channel = Po5

Port index = 0 Load = 0x00 Protocol = PAgP

Flags: S - Device is sending Slow hello. C - Device is in Consistent state.

A - Device is in Auto mode. P - Device learns on physical port.

d - PAgP is down.

Timers: H - Hello timer is running. Q - Quit timer is running.

S - Switching timer is running. I - Interface timer is running.

Local information:

Hello Partner PAgP Learning Group

Port Flags State Timers Interval Count Priority Method Ifindex

Gi6/5 U4/S4 30s 0 128 Any 0

Age of the port in the current state: 13d:12h:46m:50s

Port: Gi7/5

------------

Port state = Up Sngl-port-Bndl Mstr Not-in-Bndl

Channel group = 5 Mode = Desirable-Sl Gcchange = 0

Port-channel = null GC = 0x00050001 Pseudo port-channel = Po5

Port index = 0 Load = 0x00 Protocol = PAgP

Flags: S - Device is sending Slow hello. C - Device is in Consistent state.

A - Device is in Auto mode. P - Device learns on physical port.

d - PAgP is down.

Timers: H - Hello timer is running. Q - Quit timer is running.

S - Switching timer is running. I - Interface timer is running.

Local information:

Hello Partner PAgP Learning Group

Port Flags State Timers Interval Count Priority Method Ifindex

Gi7/5 U4/S4 30s 0 128 Any 0

Age of the port in the current state: 13d:12h:51m:39s

Port-channels in the group:

----------------------

Port-channel: Po5

------------

Age of the Port-channel = 37d:21h:02m:23s

Logical slot/port = 14/4 Number of ports = 0

GC = 0x00000000 HotStandBy port = null

Port state = Port-channel Ag-Not-Inuse

Protocol = PAgP

Re: Setting Up Etherchannel

Hello,

can you post the configs of the channel from both sides ?

Regards,

GNT

Community Member

Re: Setting Up Etherchannel

The etherchannel is for connecting one server. Server NICs are 'team'ed.

Here is the config of ports in the etherchannel:

interface GigabitEthernet6/5

description TOR DC& FP

no ip address

switchport

switchport access vlan 22

switchport mode access

spanning-tree portfast

channel-group 5 mode desirable

.....

interface GigabitEthernet7/5

description TORB DC& FP

no ip address

switchport

switchport access vlan 22

switchport mode access

spanning-tree portfast

channel-group 5 mode desirable

thanks for your help,

Cisco Employee

Re: Setting Up Etherchannel

Ah, I believe I see the problem. Since you are creating an etherchannel from the switch to a server with NIC teaming, using mode "desirable" will not work. "desirable" mode negotiates the channel with the channel partner using PAgP, which is a cisco proprietary protocol. Since the Server NIC does not understand the PAgP frames, the channel is not properly negotiated.

There are two ways around this. The preferred way is if the server and the switch (depending on your platform and IOS version) supports 802.3ad, you can use channel-group mode mode active, which is the IEEE equivalent of mode 'desirable.'

Secondly, if one or both of the devices do not support 802.3ad, then you can use channel group mode on, on the switch, which will disable negotiation of the channel and forces the LAN ports to channel unconditionally.

HTH,

Bobby

*Please rate helpful posts.

575
Views
0
Helpful
9
Replies
CreatePlease to create content