Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Settings lost after reboot (1841)

After learning the basics of this router over the past few days I can't get the actual setup/settings to remain saved after the router has been shut down for a day or two (still learning and experimenting).

Having set it up the way I want it, both through console and SDM I either save the config through SDM or "wr me" through the console and the settings are saved without any issues.

However, whenever I've turned it off and then on again I get the "Would you like to enter initial configration dialog? [yes/no]". I've always chosen "no". I get the message that the router has undergone a cold start and my interfaces are set in a administratively down state.

Doing a "show running-setup" reveals all of my settings have been reset.

What am I doing wrong?

1 ACCEPTED SOLUTION

Accepted Solutions
New Member

Re: Settings lost after reboot (1841)

This is your problem... "Configuration register is 0x2142" This tells the router to bypass the startup config.

To fix go into config mode and enter "conf reg 2102" do a "wr mem" then reload

6 REPLIES
New Member

Re: Settings lost after reboot (1841)

Your config register is probably set to bypass the startup config. Do a "sh ver" and post the output.

New Member

Re: Settings lost after reboot (1841)

Router>sh ver

Cisco IOS Software, 1841 Sofware (C1841-IPBASE-M), Version 12.4(7d), RELEASE SOFTWARE (fc2)

ROM: System Bootstrap, Version 12.4(13r)T, RELEASE SOFTWARE (fc1)

Router uptime is 34 minutes

System return to ROM by power-on

System image file is "flash:c1841-ipbase-mz.124-7d.bin"

Cisco 1841 (revision 7.0) with 114688/16374K bytes of memory.

Processor board ID FCZ1251943K

2 FastEthernet interfaces

1 Channelized (E1 or T1)/PRI port

DRAM configuration is 64 bits wide with parity disabled.

191K bytes of NVRAM

31360K bytes of ATA CompactFlash (Read/Write)

Configuration register is 0x2142

Router>

New Member

Re: Settings lost after reboot (1841)

This is your problem... "Configuration register is 0x2142" This tells the router to bypass the startup config.

To fix go into config mode and enter "conf reg 2102" do a "wr mem" then reload

New Member

Re: Settings lost after reboot (1841)

Thank you very much route2null.

It's rather hard to know these things since they really aren't that well documented.

Thanks again.

Hall of Fame Super Blue

Re: Settings lost after reboot (1841)

Craig

Just for future reference you may want to have a look at this link which goes into detail on all the configuration register values and what they mean -

http://www.cisco.com/en/US/products/hw/routers/ps133/products_tech_note09186a008022493f.shtml

Jon

New Member

Re: Settings lost after reboot (1841)

Thanks Jon, bookmarked.

3202
Views
5
Helpful
6
Replies
CreatePlease to create content