Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

switch port problem

m facing problem in my cisco 2950/60 switches that some of the ports are not stable i.e. they keep on frequently changing its states. can anyone help me to find the cause and solution of this problem. log server messages are :

09-17-2007 09:16:41 Local7.Notice x.104.y.96 232: 1d19h: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/12, changed state to up

09-17-2007 09:16:34 Local7.Notice x.104.y.96 231: 1d19h: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/12, changed state to down

09-17-2007 09:12:44 Local7.Notice x.103.y.253 12329: Sep 17 09:13:09: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/1, changed state to up

09-17-2007 09:12:44 Local7.Error x.103.y.253 12328: Sep 17 09:13:08: %LINK-3-UPDOWN: Interface GigabitEthernet0/1, changed state to up

09-17-2007 09:12:42 Local7.Notice x.103.y.253 12327: Sep 17 09:13:07: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/16, changed state to up

09-17-2007 09:12:42 Local7.Error x.103.y.253 12326: Sep 17 09:13:06: %LINK-3-UPDOWN: Interface GigabitEthernet0/16, changed state to up

09-17-2007 09:12:36 Local7.Notice x.103.y.253 12325: Sep 17 09:13:01: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/20, changed state to up

09-17-2007 09:12:36 Local7.Error x.103.y.253 12324: Sep 17 09:13:00: %LINK-3-UPDOWN: Interface GigabitEthernet0/20, changed state to up

09-17-2007 09:12:22 Local7.Notice x.103.y.253 12323: Sep 17 09:12:46: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/10, changed state to up

09-17-2007 09:12:22 Local7.Error x.103.y.253 12322: Sep 17 09:12:45: %LINK-3-UPDOWN: Interface GigabitEthernet0/10, changed state to up

09-17-2007 09:12:05 Local7.Notice x.103.y.253 12321: Sep 17 09:12:29: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/18, changed state to up

09-17-2007 09:12:04 Local7.Error x.103.y.253 12320: Sep 17 09:12:28: %LINK-3-UPDOWN: Interface GigabitEthernet0/18, changed state to up

09-17-2007 09:09:10 Local7.Notice x.103.y.245 5490: 5w6d: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/17, changed state to up

09-17-2007 09:09:08 Local7.Notice x.103.y.245 5489: 5w6d: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/17, changed state to down

09-17-2007 09:08:57 Local7.Notice x.103.y.245 5488: 5w6d: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/17, changed state to up

09-17-2007 09:08:55 Local7.Notice x.103.y.245 5487: 5w6d: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/17, changed state to down

09-17-2007 09:08:47 Local7.Notice x.103.y.249 36281: 036282: Sep 17 09:08:28: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/12, changed state to up

09-17-2007 09:08:45 Local7.Notice x.103.y.249 36280: 036281: Sep 17 09:08:26: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/12, changed state to down

09-17-2007 09:08:43 Local7.Notice x.103.y.249 36279: 036280: Sep 17 09:08:24: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/6, changed state to up

09-17-2007 09:08:41 Local7.Notice x.103.y.249 36278: 036279: Sep 17 09:08:22: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/6, changed state to down

4 REPLIES

Re: switch port problem

Does this happen throughout the day? If not, it looks quite normal to me. I see the same pattern for the switchport connected to my own PC every day when I switch it on. During the night, the PC is on standby and so the switchport is up. When I switch the PC on, the switchport bounces twice during the boot process.

The only interface that seems to be a bit strange is F0/12, because that bounced 8 minutes after it came on line. Did someone re-boot their machine twice?

Kevin Dorrell

Luxembourg

New Member

Re: switch port problem

thanx Kevin for prompt reply. yes the pattern mostly same but there r also many ports which may not appear in attached log messages, they changed their state almost 10-15 times a day. my concern is that is there any effect of PVST which m running ??? also there r some error msg, i need ur comment on that as well??? any way to find cause?? if there is any? thanx

Re: switch port problem

As long as you have portfast configured on your edge (access) ports, there will be no Spanning-Tree TCNs (Topology Change Notifications).

I would ignore the ports that are just bouncing a couple of times when the user switches the PC on in the morning - that can be regarded as normal. Concentrate on those ports that "change their state almost 10-15 times a day". Pick one out of the syslog and go and visit the user - are they having problems with their PC hanging perhaps, and do they solve the problem by re-booting?

Can you post the error messages (rather than the port up/down messages) and we can see if we can debug them?

Kevin Dorrell

Luxembourg

Re: switch port problem

Kevin is right - portfast effectively lets a users do what they want without any adverse effect on the network (as long as they don't set XP to bridge). It may be a user having problems, or could there be few desks that some users drop in on to pick up email and then go?

214
Views
0
Helpful
4
Replies