Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Switchport VLAN

Hi,

I have just created some switchport vlans to segment my user, server etc....

Please what do I need to do for my user vlan to communicate with my server vlan?

Thanks all

5 REPLIES
Super Bronze

Re: Switchport VLAN

Assuming you've also assigned differnt IP networks to your VLAN segments, you'll need to route between them. If all the VLANs come together on the same router or L3 switch, on Cisco equipement, you'll likely only need to enable IP routing io the network device. Additionally, either the router or L3 switch will need to proxy other networks, or each host will need the router's or L3 switch's interface address defined as a gateway address.

Additonally, if more than one router or L3 switch is involved, you either either need to define static routes on them or use a dynamic routing protocol (e.g. RIP, EIGRP, OSPF, etc.)

Community Member

Re: Switchport VLAN

Hi

First you have to do your vlans on a L3 switch or router.this is becasue you have to have SVI interfaces.

#interface vlan 10

#ip addr x.x.x.x y.y.y.y

so by doing these commnad you makes SVI for you vlan.

no if you are on router you are done if you are in L3 switch , you need just to provide

#ip routing commnad on switch.

now you are done.

Rate if helps.

Community Member

Re: Switchport VLAN

Thanks you all for your time and solutions.

What I have on my router is shown below. I just need a command that will allow traffic from one vlan to another.

Cheers!

interface FastEthernet0/2/0

switchport access vlan 2

!

interface FastEthernet0/2/1

switchport access vlan 3

!

interface FastEthernet0/2/2

switchport access vlan 4

!

interface FastEthernet0/2/3

switchport access vlan 5

!

!

interface Vlan2

description USER VLAN

ip address 192.168.1.1 255.255.255.0

ip nat inside

ip virtual-reassembly

!

interface Vlan3

description SERVER VLAN

ip address 192.168.3.1 255.255.255.0

ip nat inside

ip virtual-reassembly

!

interface Vlan4

description TRAINING VLAN

ip address 192.168.4.1 255.255.255.0

ip nat inside

ip virtual-reassembly

!

interface Vlan5

description DMZ VLAN

ip address 192.168.5.1 255.255.255.0

ip nat inside

ip virtual-reassembly

!

Hall of Fame Super Blue

Re: Switchport VLAN

What device are you configuring this on ?

If it is a L3 switch then it should work fine as is. Have you enabled "ip routing" ? - please post output of "sh ip route"

A client in vlan 2 will need it's default-gateway set to 192.168.1.1.

A client in vlan 3 will need it's default-gateway set to 192.168.3.1

etc...

Jon

Community Member

Re: Switchport VLAN

Dear

According that you are in your router

there is no need for any further configuration.

343
Views
0
Helpful
5
Replies
CreatePlease to create content