Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Troubles extending LAN over Cisco 2621

Hi folks,

i'm trying to do something that i'm guessing should be quite simple. i'm setting up a small LAN inside a LAN. the equipment is this;

Cisco WS-C2912-XL (vlan 1 ip address 10.0.0.9) -> Cisco 2621 -> Host

Below is the running configuration i've set up on the 2621. i usually connect my host (laptop) to the 2912 and all is good in the world. there's something i'm sure quite small and obvious that i'm missing out to enable the router to bridge between the two. with this setup i'm able to receive an ip address from dhcp, and the router can ping the gateway router to the internet 10.0.0.1 but i'm unable to get internet access or access to my network.

i've not configured any access lists as this part has been enough of a stumbling block already, hence the fairly base configuration. if anyone can tell me what the problem might be it would be greatly appreciated.

thanks,

nick

nick#sh run

Building configuration...

Current configuration : 827 bytes

!

version 12.2

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname nick

!

enable secret xxx

!

ip subnet-zero

!

!

ip domain-name nsw.bigpond.net.au

ip name-server 61.x.x.14

ip name-server 61.x.x.15

ip dhcp excluded-address 10.10.0.10

!

ip dhcp pool nick

network 10.10.0.0 255.255.255.0

domain-name nsw.bigpond.net.au

dns-server 61.x.x.14 61.9.192.15

default-router 10.10.0.10

lease 7

!

!

!

!

interface FastEthernet0/0

ip address 10.0.0.10 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet0/1

ip address 10.10.0.10 255.255.255.0

ip helper-address 10.0.0.1

duplex auto

speed auto

!

router rip

network 10.0.0.0

!

ip classless

ip http server

ip pim bidir-enable

!

!

line con 0

line aux 0

line vty 0 4

password password

login

line vty 5 15

password password

login

!

no scheduler allocate

end

nick#

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Troubles extending LAN over Cisco 2621

More questions:

1. which subnet is not able to get to the Internet?

2. can the hosts not able to get to the internet able to ping the gateway to the Internet?

3. I do not see any NAT and you are using private IP addresses, I assume the NATing is going on somewhere else, so make sure the device doing the NATing is NATing for that subnet.

4. make sure the gateway have a route back to the subnet not able to get to the Internet.

Pleaes rate helpful posts.

4 REPLIES

Re: Troubles extending LAN over Cisco 2621

More questions:

1. which subnet is not able to get to the Internet?

2. can the hosts not able to get to the internet able to ping the gateway to the Internet?

3. I do not see any NAT and you are using private IP addresses, I assume the NATing is going on somewhere else, so make sure the device doing the NATing is NATing for that subnet.

4. make sure the gateway have a route back to the subnet not able to get to the Internet.

Pleaes rate helpful posts.

New Member

Re: Troubles extending LAN over Cisco 2621

1. it was the 10.10.0.0 subnet unable to get access, the host (10.10.0.1 by dhcp) could ping the gateway to the internet (10.0.0.1, which handles the NAT).

It's a Netgear router that is the internet gateway, i was unable to figure out how to affect the NAT on that, but when i added the route to the affected subnet it got me up and running.

Thank you very much bosalaza, that's the fix, cheers for the knowledge,

Nick

New Member

Re: Troubles extending LAN over Cisco 2621

Add the configuration line

ip route 0.0.0.0 0.0.0.0 10.0.0.1

to your cisco router so it knows where to send routes not on your 10.10.0.0 255.255.255.0 subnet.

Then go onto your Netgear router and enter a static route for 10.10.0.0 255.255.255.0 and tell it the next hop is 10.0.0.10.

That should do it. Go ahead and doublecheck to make sure the mask on the netgear box for 10.0.0.0 is 255.255.255.0 as well.

Those two routing entries assure each router knows how to get to the other. If the netgear supports RIP version 2 then you can turn it on both routers instead of the static routes. RIPv1 won't do it because it doesn't support classless subnets.

New Member

Re: Troubles extending LAN over Cisco 2621

use static routes. i have doubt hv u configured dns anywhere in network.

144
Views
0
Helpful
4
Replies
CreatePlease login to create content