Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

trunk or not trunk

Suppose switch-B is connected to a port (say, 1/2) of switch-A where vlans are configured. If I want to make all ports on switch-B access to, say, vlan2, can I just configure the port 1/2 on switch-A like this:

Interface GigabitEthernet1/2

switchport access vlan 2

and leave switch-B without any vlan configuration.

Does this work?

Thanks,

2 REPLIES
Hall of Fame Super Blue

Re: trunk or not trunk

Hi

You don't need to trunk between the 2 switches. You just allocate all ports into vlan 2. Vlan 2 must exist on the switch though.

HTH

Jon

New Member

Re: trunk or not trunk

First of all you have to create vlans on switch-B as well.

To use VTP you need to establish a trunk between the switches since DTP doesn't work with access ports.

In this trunk, on switch-A side, there's written what are the VLANs allowed (suppose you want to use dot1q)

So:

!

interface GigabitEthernet1/2

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 2

no shut

!

the same configuration has to be configured on switch-B side as well.

You can now configure all the access ports you need on switch-B like this:

!

interface FastEthernet0/1

switchport

switchport access vlan 2

no shut

!

This apply only if you want to span VLANs across multiple switches. If this VLAN apply only for devices that belong on the same switch you don't need to trunk, just create it and configure access ports.

Please rate if apply.

Ciao,

Ric

115
Views
0
Helpful
2
Replies
CreatePlease to create content