Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Two outside IP's to two inside IP's

Hello,

I am new in Cisco configuration. I have Cisco 871 router. Now I have one outside IP and one inside IP. The ISP gave one more outside IP. I want to do that second outside IP mapped to unused ethernet port.

Everyone's tags (4)
7 REPLIES

Re: Two outside IP's to two inside IP's

Are both outside IPs routed to the outside interface? Are you trying to map the 2nd IP to another inside IP? Just configure "ip nat inside source static <2nd_outside_IP>". Sorry if this doesn't answer your question.

Regards,

Roman

Re: Two outside IP's to two inside IP's

you mean both the outside ip are in different subnet or in the same subnet.If different subnet just enter into serial or ethernet interface and type ip address "ip address" mask.

Regards

Ganesh.H

New Member

Re: Two outside IP's to two inside IP's

i have no luck with NAT.

Both outside IP's are in one subnet. Can you tell all steps how to do it?

Hall of Fame Super Blue

Re: Two outside IP's to two inside IP's

jokubaszilenas wrote:

i have no luck with NAT.

Both outside IP's are in one subnet. Can you tell all steps how to do it?

An example might help.

inside interface of router =  fa0/0  192.168.5.1

outside interface of router = fa0/1

new public ip address = 195.17.17.10

lets say you want to present an internal 192.168.5.10 address as the new public IP address -

config would be as follows

int fa0/0

ip nat inside

ip fa0/1

ip nat outside

ip nat inside source static 192.168.5.10 195.17.17.10

Jon

New Member

Re: Two outside IP's to two inside IP's

I changed my configuration with this and no luck:

interface Vlan2
ip address 192.168.2.1 255.255.255.0
ip nat inside
ip virtual-reassembly

interface FastEthernet2
switchport access vlan 2

ip nat inside source static 192.168.2.1 *.*.134.20

my router configuration is:

Building configuration...

!
!
!
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
switchport access vlan 2
!
interface FastEthernet3
!
interface FastEthernet4
description $FW_OUTSIDE$$ETH-WAN$$ES_WAN$
ip address *.*.134.14 255.255.255.252
no ip redirects
no ip unreachables
no ip proxy-arp
ip nat outside
ip virtual-reassembly
ip route-cache flow
duplex auto
speed auto
!
interface Vlan1
description $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$$ES_LAN$$FW_INSIDE$
ip address 192.168.1.1 255.255.255.0
no ip redirects
no ip unreachables
no ip proxy-arp
ip nat inside
ip virtual-reassembly
ip route-cache flow
ip tcp adjust-mss 1452
!
interface Vlan2
ip address 192.168.2.1 255.255.255.0
ip nat inside
ip virtual-reassembly
ip http server
ip http authentication local
ip http secure-server
ip http timeout-policy idle 600 life 86400 requests 10000
ip nat inside source list 100 interface FastEthernet4 overload
ip nat inside source static 192.168.2.1 213.197.134.20
end

Re: Two outside IP's to two inside IP's

can ping somthing in the internet

using ping x.x.x.x source vlan 2

then do show ip nat translation and see if the translation happning or not

if not post the debug ip nat detail   here

Re: Two outside IP's to two inside IP's

ok hope this link will help you to configure Natting in your environment !!

http://www.cisco.com/en/US/tech/tk648/tk361/technologies_tech_note09186a0080094e77.shtml

Regards

Ganesh.H

2339
Views
0
Helpful
7
Replies