Cisco Support Community
Showing results for 
Search instead for 
Did you mean: 

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Using a Catalyst 2950 on a domain

Hello, I'm a Cisco newbie (I was CCNA Cert. a long, long time ago), and have what is probably a simple question, but:

I have a Catalyst 2950T-24 switch (12.1(6)EA2c IOS) that I would like to hook up to our network here. We've already got a windows domain set up (lets call it TRAINING), and it's going to be on a network with the following information:



DNS primary/secondary:

It's going to be hooked up to the network through Gigabit 0/1, and the computers in the room are going to be hooked up to the fast ethernet ports (0/1-24).

I already have the basic configuration done (enable secret, hostname, line vty, line con, clock timezone, etc)

What commands would I use to get this thing working so I can get our comps on the network?

Thanks in advance,

MTSN Duncan R. Green, USN

Hall of Fame Super Silver

Re: Using a Catalyst 2950 on a domain


Configuring the 2950 and connecting it to the network can be fairly simple. There are a couple of things that we do not know yet which impact the configuration.

Probably the most important thing we need to know is whether your network is using VLANs and if so what VLANs. It would also be desirable to have an IP address for the management interface for the switch.

In the most simple case there is just a single VLAN in this switch. In that case you would configure all the ports as access ports and on the ports where end stations will connect you want to enable portfast. The gig0/1 would also probably be an access port in this situation - though depending on how its upstream neighbor is configured it might need to be a trunk port.

If there are to be multiple VLANs then you need to decide which switch ports belong to which VLANs and to configure the various fastethernet interfaces into the correct VLANs. And for multiple VLANs you would need to configure the uplink gig0/1 as a trunk port.

You have not mentioned setting up a default gateway on the switch. This would aid in accessing the management interface of the switch, though whether the switch has a default gateway or not does not impact the end stations connected to the switch.



New Member

Re: Using a Catalyst 2950 on a domain

Thanks for the quick reply, Rick:

There's going to be only one vlan on the 2950 I'm setting up.

I just found out by tracing the wall jack that the 2950 I'm trying to set up will be connecting to a catalyst 2948G-L3 switch that is split into two VLANs.

Basically what I want here is for the switch to be/act like a hub - low maintainence, just to pass through all the information sent to and from it. If the swtich needs to have it's own ip address, we'll give it

Hall of Fame Super Silver

Re: Using a Catalyst 2950 on a domain


It is pretty easy to set up the 2950 to operate as a single VLAN. It is advisable to make its VLAN the same as the VLAN where it connects to the 2948G. (strictly speaking it does not matter what VLAN you call it as long as it is the only VLAN - but I have seen things set up that do not match and was ok when set up but then something changed and the mismatch becomes an issue).

I would advocate that the switch should have an IP address. It is not "required" to have an IP address (it will receive and forward layer 2 frames just fine without an IP address). But for management purposes I find it very useful to be able to telnet to it or to receive syslog from it. And configuring VTY lines makes no sense if the switch has no IP address.

It does not matter whether the 2948G has two VLANs as long as you want the new 2950 to participate in only one of them. If the 2950 is in only a single VLAN then all ports (interfaces) are access ports (including the uplink port) and there is no need for trunking.



New Member

Re: Using a Catalyst 2950 on a domain

So, like I said, consider me a newbie: step-by-step, from a freshly erased nvram, what commands would I go through to get all of ports into one vlan, with the computers plugged into fa 0/1 - 24 and the network plugged into gi 0/1?

I tried myself, but to no avail - the computers talk fine to eachother, but the switch refuses to talk to the network. (I don't even have a link light and I don't see the interface go up in console).

Hall of Fame Super Silver

Re: Using a Catalyst 2950 on a domain


I will try to help you with some commands. But first we need to clarify a couple of things. If you want all ports in a single VLAN that is easy. But we need to understand which VLAN it should be: is it the default VLAN 1 or some other VLAN? Determining that may depend on some aspects of the network that you are connecting to.

I am also concerned about the Gig0/1 interface for uplink not becoming active. Can you post the output of show interface from your switch and also from the switch that it will connect to?



New Member

Re: Using a Catalyst 2950 on a domain

Hey Rick:

Concerning which VLAN: are you asking what I'm trying to set up on the 2950T-24? If so, it doesn't matter to me - whatever gets this thing up and running.

Here's all that I ran on my switch:


service password-encryption

hostname OfficeSwitch

enable secret xxxxxxxxxxx

clock timezone EST -5

int vlan 1

no shutdown

int range fa0/1 - 24

switchport mode access

no shutdown

int range gi0/1 - 2

switchport mode access

no shutdown





the output of show interface gi0/1 after the reload is:

show interface gi0/1

GigabitEthernet0/1 is up, line protocol is down

Hardware is Gigabit Ethernet, address is 0009.b735.9299 (bia 0009.b735.9299)

MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

Keepalive set (10 sec)

Auto-duplex, Auto-speed

input flow-control is off, output flow-control is off

ARP type: ARPA, ARP Timeout 04:00:00

Last input never, output 00:08:41, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue :0/40 (size/max)

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

1 packets input, 64 bytes, 0 no buffer

Received 0 broadcasts, 0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

0 input packets with dribble condition detected

1 packets output, 64 bytes, 0 underruns

0 output errors, 0 collisions, 2 interface resets

0 babbles, 0 late collision, 0 deferred

--More-- 0 lost carrier, 0 no carrier

0 output buffer failures, 0 output buffers swapped out

Unfortunately, I have no access to the 2948G-L3 switch. It's technically owned by another part of our organizaion, locked down with usernames and passwords. They're belligerant about giving access to it.

Hall of Fame Super Silver

Re: Using a Catalyst 2950 on a domain


Ok. thanks for the additional information. I would suggest that you add to the user ports the command: spanning-tree portfast

If interface gig0/1 shows interface up line protocol down then there is an issue there. First can you verify that there is currently something connected there? (can you also ask the folks on the other end of the connection to verify that it is connected on their end)?

If it is connected on both ends but the line protocol is down the next thing I would check is the possibility that the transmit and receive on the fiber are reversed. Can you exchange the connectors on your end and see if that makes any difference?

If it is not transmit/receive reversed then go back to the way it was connected and we will look for something else to be the issue. If there is a mismatch in speed it could cause the line protocol down. Your interface is set to negotiate speed and duplex. I would start by asking the folks on the other end of the connection for information on how they are configured. (if they would send you the output of show interface or details of how their interface to you is configured it would be helpful) If we do not have info from them then we will start to experiment. I would start by configuring speed on the interface. I would start by configuring gig speed and see if the line protocol changes to up. If not I would back the interface down to 100. If that does not work see if you can back it down again.