Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

VLAN translation for VoIP config.

I have an Cisco 1751-v4 as the core router. Also a Cisco Cat 1900 switch with ports 17-24 configured for VLAN membership VLAN 2 (VLAN 1 is data).

My goal is to configure VoIP, but I want the VLAN to be on a 172.x.x.x subnet.

Can I create a second dhcp pool I can include "option 150" for VoIP only?

my next question is I have a fast ethernet interface (LAN) and an ethernet interface (WAN, which interface do I configure the VLAN encapsulation on?

I have included my current config below.

thanks for the help.

11 REPLIES

Re: VLAN translation for VoIP config.

Hello there,

I believe you can configure more than 1 dchp pool for different subnets on your router. It will choose which to use by the interface address of the receiving dhcp client requests.

For the second question, what do you mean by vlan encapsulation?

Vlad

Re: VLAN translation for VoIP config.

Hi Dmanigo,

Yes you have to cofigure different DHCP pool for different subnets because if you try to configure second network command in same pool it will overwrite the old one.

So seperate pool is required for different network or subnet address.

AS far as you are concerned for vlan encapsulation I think you want to have intervlan routing between your vlans on a router am right?

If yes you have to configure "encapsulation dot1q " and you have to configure that on your lan interface which is your fast ethernet interface.

Also remember inter vlan routing is only supported if you are running IP Plus feature IOS on your 1700 or else it will not support the encapsulation command.

HTH, if yes please rate the post.

Ankur

New Member

Re: VLAN translation for VoIP config.

Ankur,

Thank you for replying to my question as you have answered my question (I will rate the post).

I have one more question, how do I create a second DHCP pool for the VoIP phones on the router?

Re: VLAN translation for VoIP config.

Hi Friend,

Thanks for rating the previous post.

You need to configure this for having the second pool

ip dhcp pool VOIP

network x.x.x.x x.x.x.x

domain-name

default-router x.x.x.x

dns-server x.x.x.x x,x,x.x

!

ip dhcp excluded-address

Now because you have already configured the intervlan routing on 1700 router with different encspaulation for voice and data your ip phones and worksations connected to it will get an ip from seperate respective pools.

HTH, if yes please rate the post.

Ankur

New Member

Re: VLAN translation for VoIP config.

Again I have to thank you for helping me out.

I created the second DHCP pool for the the voip phone

but it will not pull an ip address.

Here is the config for the c1751 and c1900sw.

Where or what am I doing incorrectly?

Re: VLAN translation for VoIP config.

Hi Friend,

Your config on router is not correct. You have just defined an interface for data vlan so what will happen is when the broadcast request will come rfom your ip phone the router will think it a request from data vlan.

What you have to do is configure a trunk on port on 1900 switch which connectes to a router.

Configure subinterface on your router with encapsulation command for both the vlans (ip phone and data machine) and then when the DHCp request will come from ip phone it will go from a specific vlan and will hit its subinterface on a router and router will assign an ip from its VOIP DHCP pool.

Check this link to configure subinterfaces on router with encapsulation command

http://www.cisco.com/warp/customer/473/50.shtml#801.1Q

HTH, if yes please rate the post.

Ankur

New Member

Re: VLAN translation for VoIP config.

Ankur,

I am still having issues configuring VLAN's.

During some reading, I understand I should not have to create a trunk as I am only using a single cisco 1900 switch.I should not have to configure VTP on the switch as well for the same purpose.

Here is what I am looking at:

Router#>int fasteth0/0

ip address 192.168.2.1 255.255.255.0

ip helper-address 192.168.2.0

ip nat inside

From what I have read, I need to configure the DHCP DATA pool (192.168.2.0) as vlan1 native. But when I attempt to configure the IP address for the native VLAN1 on fastethernet0/0.1 (subinterface) I recieve IP address overlap with int fasteth0/0 interface error.

Question, can I configure interface fastethernet0/0 without an IP address,but configure the subinterfaces 0/0.1 and 0/0.2 with ip address?

ip dhcp pool Data

network 192.168.2.0 255.255.255.0

domain-name 5thborocs.com

default-router 192.168.2.1

dns-server 63.162.197.69 208.33.149.39

!

ip dhcp pool VoIP

network 192.168.3.0 255.255.255.0

domain-name 5thborocs.com

default-router 192.168.2.1

option 150 ip 192.168.2.1

!

interface FastEthernet0/0

description Cisco 1900sw

ip helper-address 192.168.2.0 (or without a helper address)

ip nat inside

ip virtual-reassembly

speed auto

full-duplex

!

interface FastEthernet0/0.1

description Data

encapsulation dot1Q 1 native

ip address 192.168.2.1 255.255.255.0

ip helper-address 192.168.2.0

!

interface FastEthernet0/0.2

description VoIP

encapsulation dot1Q 2

ip address 192.168.3.1 255.255.255.0

ip helper-address 192.168.3.0

no snmp trap link-status

Purple

Re: VLAN translation for VoIP config.

Hi,

You do need to configure the interface between the switch and the router as a trunk - the reason for this is that you are using the router for inter-vlan routing and as such, you need to carry tagged traffic to your router.

I agree that you do not need VTP in your case - with a single switch, VTP is not really required.

You certainly do not need an IP address on the main Fast0/0 interface. You can safely leave it there without an IP address.

The other thing I noticed that you don't really need is the ip helper-address commands. Since the router is the DHCP server, it will 'see' all DHCP requests directly and does not need to forward them anywhere.

I would configure your router as follows:

interface FastEthernet0/0

description Cisco 1900sw

no ip address

ip nat inside

ip virtual-reassembly

speed auto

full-duplex

!

interface FastEthernet0/0.1

description Data

encapsulation dot1Q 1 native

ip address 192.168.2.1 255.255.255.0

!

interface FastEthernet0/0.2

description VoIP

encapsulation dot1Q 2

ip address 192.168.3.1 255.255.255.0

no snmp trap link-status

Pls do remember to rate posts.

Paresh

Purple

Re: VLAN translation for VoIP config.

Actually, I found another issue with your DHCP pools - you've gotta use a default gateway of 192.168.3.1 for your VoIP pool:

ip dhcp pool Data

network 192.168.2.0 255.255.255.0

domain-name 5thborocs.com

default-router 192.168.2.1

dns-server 63.162.197.69 208.33.149.39

!

ip dhcp pool VoIP

network 192.168.3.0 255.255.255.0

domain-name 5thborocs.com

default-router 192.168.3.1

option 150 ip 192.168.2.1

!

Pls do remember to rate posts.

Paresh

New Member

Re: VLAN translation for VoIP config.

In fact, you can configure your Fa0/0 as a regular interface using the 192.168.2.1 and the subinterface using the 172.x.x.x since this is what you mentioned in your original message.

Look at the example below:

ip dhcp pool VoIP

network 172.16.10.0 255.255.255.0

domain-name 5thborocs.com

default router 172.16.10.1

dns-server "Your DNS"

int fa0/0.1

ip address 172.18.10.1 255.255.255.0

Let me know if it helps

New Member

Re: VLAN translation for VoIP config.

Can anyone explain "Transitional Bridge" ?

When looking at the current vlan in the router I see it only read the default (vlan 1 native) and other suspended vlans (FDDI,Token-Ring).

The switch displays VLAN 1 and VLAN 2 but VLAN 2 has "XB1=0" "XB2=0". Can anyone tell me what "XB" represents and since the setting is at -0-, will this affect VLAN 2 being read by the router?

298
Views
14
Helpful
11
Replies
CreatePlease login to create content