Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

vlan won't come up

I just got handed taking care of our switch's at work and have some questions, i have not worked with switch's that much but i know a little.

i have a 2960 with 3 vlans 1 vlan for the ports 1 for the trunks and 1 for management with an ip. the switch is up and passing traffic but i can't seem to get my management vlan to up up. vtp settings are ok i have done a shutdown and no shut on the vlan still down down. We have 2950's running the same type of config so not sure if this is something new with the 2960 i have attached a config.  thanks for any help

15 REPLIES
New Member

Re: vlan won't come up

Hi,

Hey i have seen your configuration. you are not getting your VLAN 995 (i.e. your management vlan) UP UP, beacause none of your interface belongs to that vlan. All the interface belongs to vlan 78.  To have your vlan in UP UP state you have to have your one port as a member of that vlan.

Try to change one port to vlan 995 and have a check. I hope this will help you out.

Regards,

Hardik

New Member

Re: vlan won't come up

Thanks for the reply i will try that.  But i have 2950's

with this same config all ports say on 78 vlan and my management

vlan of 995 is up up

New Member

Re: vlan won't come up

Hi,

Can you please post your 2950's config too.

Regards,

Hardik

New Member

Re: vlan won't come up

here is a 2950 config that is up and running

New Member

Re: vlan won't come up

one thing i have noticed between the 2960 and the 2950 is if i do a show

int gi0/1 trunk and a int gi0/2

trunk

the 2960 only has vlans 1 and 78

the 2950 shows all of my vlans

New Member

Re: vlan won't come up

Hi,

Your VLAN is the SVI (i.e switched virtual interface).  To have this interface in UP UP state you should have at least one device connected to a Layer 2 interface within the VLAN. i.e your vlan 995. so you can do the same thing as i had suggested before.

If any question, feel free to ask. I will try my best to answew.

Regards,

Hardik

Re: vlan won't come up

Just,

the 2960 only has vlans 1 and 78

the 2950 shows all of my vlans

This WREAKS of a VTP issue.  I know you said the settings look fine, but I think you should give them a second look.

Check the output of a 'show vtp status' command.  Make sure your VTP domain is correct.  Your switch may not be recieving Vlan data from your VTP server if it is set to transparent (likely culprit) or server.  If it is transparent or server, do the following:

conf t

vtp mode client

vtp domain vtpdomainname

vtp password vtppassword (if this applies, do 'show vtp password' on the vtp server to check)

Issues like this will not appear in your config. 

New Member

Re: vlan won't come up

this is VTP issue

please post here : #show vtp status , #show vlan and #show inter trunk

New Member

Re: vlan won't come up

type

vlan xxx when in config mode and replace xxx with the VLANs that you want to see.......VTP also as server or transparent......make life easy - get rip of VTP ntil the fault has gone.......

New Member

Re: vlan won't come up

Put an interface into your management vlan then it will come up you can take the interface back out of it again and it will stay up.

Hope this helps!

New Member

Re: vlan won't come up

when you do

Sho vlan

do the VLANs all get listed ?

Are the vlans allowed to GET to this switch ie. is something like "Switchport trunk allowed vlan all"

on each of the other trunk ports pointing back to this switch ?

New Member

Re: vlan won't come up

Hi,

can you describe why you configured a VLAN for trunking? Or have I understood it wrong way?

The basic problem why the VLAN Interfaces won't come to the up/up state is that the VLan (management) isn't assigned to an access port or isn't allowed on a Trunking port.

Basically the easiest would be to configure: switchport trunk allowed vlan 995 for you management access. Then should become the state up/up.

Regards Martin

New Member

Re: vlan won't come up

Just here,

Have you found a resolution to this issue?  I have the same switches, all trunked behind my 2811 voice gateway and my admin vlan attached to the trunk ports:

!

interface FastEthernet0/24

description EP-2811

switchport trunk native vlan 250

switchport mode trunk

speed 100

duplex full

srr-queue bandwidth share 10 10 60 20

srr-queue bandwidth shape  10  0  0  0

priority-queue out

mls qos trust cos

auto qos voip trust

!

!

interface range g0/1 - 2

switchport trunk native vlan 250

switchport mode trunk

srr-queue bandwidth share 10 10 60 20

srr-queue bandwidth shape  10  0  0  0

queue-set 2

priority-queue out

mls qos trust cos

auto qos voip trust

!

interface Vlan250

description AdminVlan

ip address 10.250.15.12 255.255.255.0

no ip route-cache

no shut

!

Does not allow me to access the switches.  I have followed all the tips in this thread with not luck.  I have even wiped out the configs and reloaded.  I have devices plugged in.  My voice (vlan 5) and data (vlan 10) come up fine.  Just my management vlan 250 does not.  I can even watch the term show vlan250 being set to down status.

Anyone have any other tricks?

Jason

Re: vlan won't come up

You may want to consider NOT using your management vlan as your native vlan.  That's not a good practice.  I would suggest you making your native vlan an unused vlan.  May solve your problem.

Please rate if it helps.

Re: vlan won't come up

Agree with Khaled earlier, this looks like vtp issue

Could you paste us the vtp info.

Cheers

7368
Views
5
Helpful
15
Replies
CreatePlease login to create content