Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

why is trunk not showing vlan membership?

I setup corectly a LACP etherchannel with all VLANS allowed. This interface is called Po10.

Then I set up another one, Po20, consisting of interfaces 33 and 34, but this time restricting VLANs to only VLAN 20 (all config is below).

But when I do a sh int trunk and sh vlan brief, it only shows vlans for Po10. Is this because nothing is connected to the new port-channel, yet?

And what about the "no shut" command. I have not run this command. I thought I had to run this command, since all ports are shut per default in a Cisco switch? The config does not show this for any of my ports (I might have done this for the working port-channel).

Here is the config:

3750G-A#sh run int gi1/0/33

Building configuration...

Current configuration : 228 bytes

!

interface GigabitEthernet1/0/33

description iSCSI LACP interface

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 20

switchport mode trunk

channel-group 20 mode active

spanning-tree portfast trunk

end

3750G-A#sh run int gi1/0/34

Building configuration...

Current configuration : 228 bytes

!

interface GigabitEthernet1/0/34

description iSCSI LACP interface

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 20

switchport mode trunk

channel-group 20 mode active

spanning-tree portfast trunk

end

3750G-A#sh run int po20

Building configuration...

Current configuration : 202 bytes

!

interface Port-channel20

description LACP Port-Channel for VNX iSCSi

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 20

switchport mode trunk

spanning-tree portfast trunk

end

3750G-A#sh int trunk

Port        Mode             Encapsulation  Status        Native vlan

Po10        on               802.1q         trunking      1

Port        Vlans allowed on trunk

Po10        1-4094

Port        Vlans allowed and active in management domain

Po10        1,3,20,30,40,50,60,99

Port        Vlans in spanning tree forwarding state and not pruned

Po10        1,3,20,30,40,50,60,99

3750G-A#sh vlan brief

VLAN Name                             Status    Ports

---- -------------------------------- --------- -------------------------------

1    default                          active    Gi1/0/6, Gi1/0/7, Gi1/0/8

                                                Gi1/0/9, Gi1/0/10, Gi1/0/11

                                                Gi1/0/12, Gi1/0/13, Gi1/0/14

                                                Gi1/0/15, Gi1/0/16, Gi1/0/19

                                                Gi1/0/20, Gi1/0/21, Gi1/0/22

                                                Gi1/0/23, Gi1/0/24, Gi1/0/25

                                                Gi1/0/26, Gi1/0/27, Gi1/0/28

                                                Gi1/0/29, Gi1/0/30, Gi1/0/31

                                                Gi1/0/32, Gi1/0/33, Gi1/0/34

                                                Gi1/0/35, Gi1/0/36, Gi1/0/37

                                                Gi1/0/38, Gi1/0/39, Gi1/0/40

                                                Gi1/0/41, Gi1/0/42, Gi1/0/43

                                                Gi1/0/44, Gi1/0/45, Gi1/0/46

                                                Gi1/0/47, Gi1/0/48, Gi1/0/49

                                                Gi1/0/50, Gi1/0/51, Gi1/0/52

3    Management                       active    Gi1/0/1, Gi1/0/2, Gi1/0/3

                                                Gi1/0/4, Gi1/0/5

20   iscsi-A                          active

30   iscsi-B                          active

40   vMotion                          active

Everyone's tags (4)
1 ACCEPTED SOLUTION

Accepted Solutions
VIP Purple

why is trunk not showing vlan membership?

yes you right, if the ports are not connected then they will show only the default (NATIVE VLAN:).

sh vlan brief will show the vlan is active or not not the port.

Hope this helps.

Regards

Please rate if it helps.

6 REPLIES
VIP Purple

why is trunk not showing vlan membership?

Hi Atle,

No shut command is used to make port avilability to up otherwise port will be in shutdown status.

If you will not connect a device on these ports then it will not show the trunk ports.

run this command: sh int status

and paste the output.

REgards

Please rate if it helps.

New Member

why is trunk not showing vlan membership?

3560-B#sh int status

Port      Name               Status       Vlan       Duplex  Speed Type

Gi0/1     Management interfa notconnect   3            auto   auto 10/100/1000BaseTX

Gi0/2     management vlan 3  notconnect   3            auto   auto 10/100/1000BaseTX

Gi0/3     Mangement switch   notconnect   3            auto   auto 10/100/1000BaseTX

Gi0/4                        notconnect   1            auto   auto 10/100/1000BaseTX

Gi0/5     VNX Management     notconnect   3            auto   auto 10/100/1000BaseTX

Gi0/6                        notconnect   1            auto   auto 10/100/1000BaseTX

Gi0/7                        notconnect   1            auto   auto 10/100/1000BaseTX

Gi0/8                        notconnect   1            auto   auto 10/100/1000BaseTX

Gi0/9                        notconnect   1            auto   auto 10/100/1000BaseTX

Gi0/10                       notconnect   1            auto   auto 10/100/1000BaseTX

Gi0/11                       notconnect   1            auto   auto 10/100/1000BaseTX

Port      Name               Status       Vlan       Duplex  Speed Type

Gi0/12                       notconnect   1            auto   auto 10/100/1000BaseTX

Gi0/13                       notconnect   1            auto   auto 10/100/1000BaseTX

Gi0/14                       notconnect   1            auto   auto 10/100/1000BaseTX

Gi0/15                       notconnect   1            auto   auto 10/100/1000BaseTX

Gi0/16                       notconnect   1            auto   auto 10/100/1000BaseTX

Gi0/17    UCS FI-B uplinks   connected    trunk      a-full a-1000 10/100/1000BaseTX

Gi0/18    UCS FI-B uplinks   connected    trunk      a-full a-1000 10/100/1000BaseTX

Gi0/19                       notconnect   1            auto   auto 10/100/1000BaseTX

Gi0/20                       notconnect   1            auto   auto 10/100/1000BaseTX

Gi0/21                       notconnect   1            auto   auto 10/100/1000BaseTX

Gi0/22                       notconnect   1            auto   auto 10/100/1000BaseTX

Port      Name               Status       Vlan       Duplex  Speed Type

Gi0/23                       notconnect   1            auto   auto 10/100/1000BaseTX

Gi0/24                       notconnect   1            auto   auto 10/100/1000BaseTX

Gi0/25                       notconnect   1            auto   auto 10/100/1000BaseTX

Gi0/26                       notconnect   1            auto   auto 10/100/1000BaseTX

Gi0/27                       notconnect   1            auto   auto 10/100/1000BaseTX

Gi0/28                       notconnect   1            auto   auto 10/100/1000BaseTX

Gi0/29                       notconnect   1            auto   auto 10/100/1000BaseTX

Gi0/30                       notconnect   1            auto   auto 10/100/1000BaseTX

Gi0/31                       notconnect   1            auto   auto 10/100/1000BaseTX

Gi0/32                       notconnect   1            auto   auto 10/100/1000BaseTX

Gi0/33    iSCsi fra VNX      notconnect   1            auto   auto 10/100/1000BaseTX

Port      Name               Status       Vlan       Duplex  Speed Type

Gi0/34    iSCsi fra VNX      notconnect   1            auto   auto 10/100/1000BaseTX

Gi0/35                       notconnect   1            auto   auto 10/100/1000BaseTX

Gi0/36                       notconnect   1            auto   auto 10/100/1000BaseTX

Gi0/37                       notconnect   1            auto   auto 10/100/1000BaseTX

Gi0/38                       notconnect   1            auto   auto 10/100/1000BaseTX

Gi0/39                       notconnect   1            auto   auto 10/100/1000BaseTX

Gi0/40                       notconnect   1            auto   auto 10/100/1000BaseTX

Gi0/41                       notconnect   1            auto   auto 10/100/1000BaseTX

Gi0/42                       notconnect   1            auto   auto 10/100/1000BaseTX

Gi0/43                       notconnect   1            auto   auto 10/100/1000BaseTX

Gi0/44                       notconnect   1            auto   auto 10/100/1000BaseTX

Port      Name               Status       Vlan       Duplex  Speed Type

Gi0/45                       notconnect   1            auto   auto 10/100/1000BaseTX

Gi0/46                       notconnect   1            auto   auto 10/100/1000BaseTX

Gi0/47                       notconnect   1            auto   auto 10/100/1000BaseTX

Gi0/48                       notconnect   1            auto   auto 10/100/1000BaseTX

Gi0/49                       notconnect   1            auto   auto Not Present

Gi0/50                       notconnect   1            auto   auto Not Present

Gi0/51                       notconnect   1            auto   auto Not Present

Gi0/52                       notconnect   1            auto   auto Not Present

Po10      Port-channel for U connected    trunk      a-full a-1000

Po20      iSCSi LACP Port-ch notconnect   unassigned   auto   auto

VIP Purple

why is trunk not showing vlan membership?

yes.. according to your output:

Gi0/33    iSCsi fra VNX      notconnect   1            auto   auto 10/100/1000BaseTX

Gi0/34    iSCsi fra VNX      notconnect   1            auto   auto 10/100/1000BaseTX

both ports are not connected .

Regards

Please rate if it helps.

New Member

why is trunk not showing vlan membership?

ok, so if not connected, the ports do not show up as member of vlans if if they are configured as member of vlans? sh vlan brief only says "active"

VIP Purple

why is trunk not showing vlan membership?

yes you right, if the ports are not connected then they will show only the default (NATIVE VLAN:).

sh vlan brief will show the vlan is active or not not the port.

Hope this helps.

Regards

Please rate if it helps.

Silver

why is trunk not showing vlan membership?

Atle Dale wrote:

ok, so if not connected, the ports do not show up as member of vlans if if they are configured as member of vlans? sh vlan brief only says "active"

Because interfaces g0/33 & g0/34 aren't *in* the VLAN - they're *trunking* the VLAN.

You won;t get anything in the "sh vlan brief" output for vlan 20 unless and until you put an ACCESS port into this VLAN. Trunk ports aren't members of VLAN's, and both the ports you mention as being in the etherchannel are trunks, not access ports.

Cheers.

10095
Views
5
Helpful
6
Replies
CreatePlease login to create content