Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

1042N AP wont connect to 2106 WLC

Hey all,

We recently purchased a bundle of 3 1042N AP's with a 2106 WLC. I am able to get the controller on the network and am able to manage it through the https web gui. I am now trying to add one of the AP's to the controller and am getting an infinite loop on the AP upon bootup. I tried looking up the solution but could not find a good article that pertained to the problem I was having. One thing I did notice is the time on the AP is way offset, but when I do a clock set to change it to the actual date it doesnt stick on the next reload.

Thanks in advance to anyone reading this.

Here is the output:

using ÿÿÿÿ ddr static values from serial eeprom

ddr init done

Running Normal Memtest...

Passed.

IOS Bootloader - Starting system.

FLASH CHIP:  Numonyx P33

Checking for Over Erased blocks

......................................................................................................................................................................................................................................................

Xmodem file system is available.

DDR values used from system serial eeprom.

WRDTR,CLKTR: 0x83000800, 0xc0000000

RQDC, RFDC : 0x80000037, 0x00000190

PCIE0: link is up.

PCIE0: VC0 is active

PCIE1: link is up.

PCIE1: VC0 is active

PCIEx: initialization done

flashfs[0]: 28 files, 8 directories

flashfs[0]: 0 orphaned files, 0 orphaned directories

flashfs[0]: Total bytes: 32385024

flashfs[0]: Bytes used: 7108096

flashfs[0]: Bytes available: 25276928

flashfs[0]: flashfs fsck took 24 seconds.

Reading cookie from system serial eeprom...Done

Base Ethernet MAC address: c4:64:13:11:28:36

Ethernet speed is 100 Mb - FULL duplex

Loading "flash:/c1140-k9w8-mx.124-23c.JA/c1140-k9w8-mx.124-23c.JA"...##########################################################################################################################################################################################################################################################################################################################################################################################################################################

File "flash:/c1140-k9w8-mx.124-23c.JA/c1140-k9w8-mx.124-23c.JA" uncompressed and installed, entry point: 0x4000

executing...

enet halted

              Restricted Rights Legend

Use, duplication, or disclosure by the Government is

subject to restrictions as set forth in subparagraph

(c) of the Commercial Computer Software - Restricted

Rights clause at FAR sec. 52.227-19 and subparagraph

(c) (1) (ii) of the Rights in Technical Data and Computer

Software clause at DFARS sec. 252.227-7013.

           cisco Systems, Inc.

           170 West Tasman Drive

           San Jose, California 95134-1706

Cisco IOS Software, C1040 Software (C1140-K9W8-M), Version 12.4(23c)JA, RELEASE SOFTWARE (fc3)

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 1986-2010 by Cisco Systems, Inc.

Compiled Tue 01-Jun-10 12:29 by prod_rel_team

Proceeding with system init

Proceeding to unmask interrupts

Initializing flashfs...

FLASH CHIP:  Numonyx P33

Checking for Over Erased blocks

......................................................................................................................................................................................................................................................

flashfs[1]: 28 files, 8 directories

flashfs[1]: 0 orphaned files, 0 orphaned directories

flashfs[1]: Total bytes: 32126976

flashfs[1]: Bytes used: 7108096

flashfs[1]: Bytes available: 25018880

flashfs[1]: flashfs fsck took 7 seconds.

flashfs[1]: Initialization complete.

flashfs[2]: 0 files, 1 directories

flashfs[2]: 0 orphaned files, 0 orphaned directories

flashfs[2]: Total bytes: 11999232

flashfs[2]: Bytes used: 1024

flashfs[2]: Bytes available: 11998208

flashfs[2]: flashfs fsck took 1 seconds.

flashfs[2]: Initialization complete....done Initializing flashfs.

Ethernet speed is 100 Mb - FULL duplex

Radio0  present 8363 8000 90020000 0 90030000 B

Radio1  present 8363 8000 98020000 0 98030000 0

This product contains cryptographic features and is subject to United

States and local country laws governing import, export, transfer and

use. Delivery of Cisco cryptographic products does not imply

third-party authority to import, export, distribute or use encryption.

Importers, exporters, distributors and users are responsible for

compliance with U.S. and local country laws. By using this product you

agree to comply with applicable laws and regulations. If you are unable

to comply with U.S. and local laws, return this product immediately.

A summary of U.S. laws governing Cisco cryptographic products may be found at:

http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

If you require further assistance please contact us by sending email to

export@cisco.com.

cisco AIR-LAP1042N-A-K9    (PowerPC405ex) processor (revision B0) with 98294K/32768K bytes of memory.

Processor board ID FTX1551K4A0

PowerPC405ex CPU at 333Mhz, revision number 0x147E

Last reset from power-on

LWAPP image version 7.0.98.0

1 Gigabit Ethernet interface

2 802.11 Radio(s)

32K bytes of flash-simulated non-volatile configuration memory.

Base ethernet MAC Address: C4:64:13:11:28:36

Part Number                          : 73-14034-04

PCA Assembly Number                  : 800-34273-05

PCA Revision Number                  : A0

PCB Serial Number                    : FOC15491WAJ

Top Assembly Part Number             : 800-34285-03

Top Assembly Serial Number           : FTX1551K4A0

Top Revision Number                  : A0

Product/Model Number                 : AIR-LAP1042N-A-K9

% Please define a domain-name first.

Press RETURN to get started!

Translating "CISCO-CAPWAP-CONTROLLER"...domain server (255.255.255.255)

*Mar  1 00:00:09.775: %SOAP_FIPS-2-SELF_TEST_IOS_SUCCESS: IOS crypto FIPS self test passed

*Mar  1 00:00:09.790: *** CRASH_LOG = YES

Security Core found.

Base Ethernet MAC address: C4:64:13:11:28:36

*Mar  1 00:00:11.197: %SOAP_FIPS-2-SELF_TEST_RAD_SUCCESS: RADIO crypto FIPS self test passed on interface Dot11Radio 0

*Mar  1 00:00:11.763: %SOAP_FIPS-2-SELF_TEST_RAD_SUCCESS: RADIO crypto FIPS self test passed on interface Dot11Radio 1

*Mar  1 00:00:11.836: %LWAPP-3-CLIENTEVENTLOG: Read and initialized AP event log (contains, 1024 messages)

*Mar  1 00:00:11.863:  status of voice_diag_test from WLC is false

*Mar  1 00:00:12.890: %LINK-3-UPDOWN: Interface GigabitEthernet0, changed state to up

*Mar  1 00:00:13.961: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0, changed state to up

*Mar  1 00:00:14.020: %SYS-5-RESTART: System restarted --

Cisco IOS Software, C1040 Software (C1140-K9W8-M), Version 12.4(23c)JA, RELEASE SOFTWARE (fc3)

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 1986-2010 by Cisco Systems, Inc.

Compiled Tue 01-Jun-10 12:29 by prod_rel_team

*Mar  1 00:00:14.021: %SNMP-5-COLDSTART: SNMP agent on host APc464.1311.2836 is undergoing a cold start

*Mar  1 00:12:14.082: %LINK-5-CHANGED: Interface Dot11Radio1, changed state to reset

*Mar  1 00:12:14.082: %LINK-5-CHANGED: Interface Dot11Radio0, changed state to reset

*Mar  1 00:12:15.082: %LINEPROTO-5-UPDOWN: Line protocol on Interface Dot11Radio1, changed state to down

*Mar  1 00:12:15.082: %LINEPROTO-5-UPDOWN: Line protocol on Interface Dot11Radio0, changed state to down

*Mar  1 00:12:26.077: %CAPWAP-3-ERRORLOG: Could Not resolve CISCO-CAPWAP-CONTROLLER

*Mar  1 00:12:26.079: %CAPWAP-5-CHANGED: CAPWAP changed state to DISCOVERY

*Mar  1 00:12:26.634: %DOT11-2-TX_PWR_TIMO: Interface Dot11Radio0, Timed out waiting for fw to clear txp_pndg flag

*Mar  1 00:12:27.134: %DOT11-2-TX_PWR_TIMO: Interface Dot11Radio1, Timed out waiting for fw to clear txp_pndg flag

*Mar  1 00:12:27.488: %SSH-5-ENABLED: SSH 2.0 has been enabled

*Mar  1 00:12:32.896:  status of voice_diag_test from WLC is false

*Mar  1 00:13:00.715: %CDP_PD-4-POWER_OK: Full power - HIGH_POWER_CLASSIC_NOT_CONFIGURED inline power source

*Mar  1 00:13:00.751: %LINK-3-UPDOWN: Interface Dot11Radio1, changed state to up

*Mar  1 00:13:00.760: %LINK-3-UPDOWN: Interface Dot11Radio0, changed state to up

*Mar  1 00:13:01.730: %LINEPROTO-5-UPDOWN: Line protocol on Interface Dot11Radio1, changed state to up

*Mar  1 00:13:01.730: %SYS-6-LOGGINGHOST_STARTSTOP: Logging to host 10.10.200.50 started - CLI initiated

*Mar  1 00:13:01.752: %LINEPROTO-5-UPDOWN: Line protocol on Interface Dot11Radio0, changed state to up

*Mar  1 00:16:50.982: %CAPWAP-5-STATIC_TO_DHCP_IP: Could not discover WLC using static IP. Forcing AP to use DHCP.

*Mar  1 00:17:04.004: %CAPWAP-3-ERRORLOG: Not sending discovery request AP does not have an Ip !!

*Mar  1 00:17:14.004: %CAPWAP-3-ERRORLOG: Not sending discovery request AP does not have an Ip !!

*Mar  1 00:17:24.004: %CAPWAP-3-ERRORLOG: Not sending discovery request AP does not have an Ip !!

*Mar  1 00:17:34.004: %CAPWAP-3-ERRORLOG: Not sending discovery request AP does not have an Ip !!

*Mar  1 00:17:44.004: %CAPWAP-3-ERRORLOG: Not sending discovery request AP does not have an Ip !!

Not in Bound state.

*EDIT*

Also I tried setting the capwap IP and everything to force it to find the WLC but it did not solve the problem.

APc464.1311.2836#show capwap ip config

LWAPP Static IP Configuration

IP Address         10.10.20.103

IP netmask         255.255.0.0

Default Gateway    10.10.0.1

Primary Controller 10.10.20.100

1 ACCEPTED SOLUTION

Accepted Solutions

1042N AP wont connect to 2106 WLC

Interesting..your Virtual interface doesn't show an IP address.  Can you set an address on the virtual, reboot and then run the debugs again?

Steve

HTH, Steve ------------------------------------------------------------------------------------------------ Please remember to rate useful posts, and mark questions as answered
10 REPLIES
Cisco Employee

1042N AP wont connect to 2106 WLC

Wats the WLC software version?? guess 1042 needs 7.0.98 and above i am right..

Regards

Surendra

New Member

1042N AP wont connect to 2106 WLC

The WLC Software version is 7.0.98.

Cisco Employee

1042N AP wont connect to 2106 WLC

run the below debug on the WLC and reboot the AP and paste the logs here..

debug capwap events enable

debug capwap errors enable

Regards

Surendra

New Member

1042N AP wont connect to 2106 WLC

On the controller I enabled the two debug commands you mentioned. Rebooted the AP and didnt see anything on the controller come up for debugging. Did this twice to make sure I didnt miss anything. I also did a show logging to make sure debugging output was enabled on the console level and it was.

1042N AP wont connect to 2106 WLC

How are you informing the AP of the WLC managemet address?  DHCP option 43, DNS of cisco-capwap-controller ?

Steve

HTH, Steve ------------------------------------------------------------------------------------------------ Please remember to rate useful posts, and mark questions as answered
New Member

1042N AP wont connect to 2106 WLC

Stephen,

Maybe that is where I am messing up. Its been a few years since I have configured WLC and APs so I may be missing a step.

On the controller tab on the web gui I have a DHCP scope set for the AP's and Enable DHCP proxy is checked. Am I missing something?

As a test I set a static IP on the AP so it could find the controller (see below). Is this not the best way to do things anymore?

LWAPP Static IP Configuration

IP Address         10.10.20.103

IP netmask         255.255.0.0

Default Gateway    10.10.0.1

Primary Controller 10.10.20.100

I also put in a DNS entry of the Primary Controller's IP to cisco-capwap-controller on our internal DNS server. This still didnt solve anything although where on the AP do i set the DNS server for it to look at? I cant enter a global config mode because (from what ive read) its in lightweight mode and thats the correct mode for working with the controller.

1042N AP wont connect to 2106 WLC

For DNS to work, you would need to setup a DHCP scope to give the AP the server address.

As for the 'best' way, I wouldn't go with a static IP, I'd just use a DHCP scope and option 43 much easier to get everything up and running that way.  If the AP can't find the WLC with it's configured static, it will fall back to being DHCP anyway.  And during the first join, you would need to put the commands in with every reboot to be sure they were there, as you can't write to NV.

and on that note, can you post the output of show interface summary, as well as the port(s) the WLC is connected to, and the port the AP is on?

Steve

HTH, Steve ------------------------------------------------------------------------------------------------ Please remember to rate useful posts, and mark questions as answered
New Member

1042N AP wont connect to 2106 WLC

Ah, that makes sense.

Here are the outputs you requested:

(Cisco Controller) >show interface summary

Interface Name                   Port Vlan Id  IP Address      Type    Ap Mgr Guest

-------------------------------- ---- -------- --------------- ------- ------ -----

ap-manager                       1    untagged 10.10.20.101    Static  Yes    No

management                       1    untagged 10.10.20.100    Static  No     No

test                             1    21       10.10.21.2      Dynamic No     No

virtual                          N/A  N/A      0.0.0.0         Static  No     No

Show int on WLC:

(Cisco Controller) >show interface detailed management

Interface Name................................... management

MAC Address...................................... 70:81:05:af:15:e0

IP Address....................................... 10.10.20.100

IP Netmask....................................... 255.255.0.0

IP Gateway....................................... 10.10.0.1

External NAT IP State............................ Disabled

External NAT IP Address.......................... 0.0.0.0

VLAN............................................. untagged

Quarantine-vlan.................................. 0

Physical Port.................................... 1

Primary DHCP Server.............................. 10.10.20.100

Secondary DHCP Server............................ 10.10.10.102

DHCP Option 82................................... Disabled

ACL.............................................. Unconfigured

AP Manager....................................... No

Guest Interface.................................. No

Show int on AP:

GigabitEthernet0 is up, line protocol is up

  Hardware is PowerPC405ex Ethernet, address is c464.1311.2836 (bia c464.1311.2836)

  Internet address is 10.10.20.103/16

  MTU 1500 bytes, BW 100000 Kbit/sec, DLY 100 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation ARPA, loopback not set

  Full-duplex, 100Mb/s, media type is T

  output flow-control is unsupported, input flow-control is unsupported

  ARP type: ARPA, ARP Timeout 04:00:00

  Last input 00:00:45, output 00:00:00, output hang never

  Last clearing of "show interface" counters never

  Input queue: 0/1677/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: fifo

  Output queue: 0/40 (size/max)

  5 minute input rate 0 bits/sec, 0 packets/sec

  5 minute output rate 0 bits/sec, 1 packets/sec

     3 packets input, 885 bytes, 0 no buffer

     Received 3 broadcasts, 0 runts, 0 giants, 0 throttles

     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

     0 watchdog, 0 multicast, 0 pause input

     0 input packets with dribble condition detected

     180 packets output, 15696 bytes, 0 underruns

     0 output errors, 0 collisions, 3 interface resets

     0 unknown protocol drops

     0 babbles, 0 late collision, 0 deferred

     0 lost carrier, 0 no carrier, 0 pause output

     0 output buffer failures, 0 output buffers swapped out

1042N AP wont connect to 2106 WLC

Interesting..your Virtual interface doesn't show an IP address.  Can you set an address on the virtual, reboot and then run the debugs again?

Steve

HTH, Steve ------------------------------------------------------------------------------------------------ Please remember to rate useful posts, and mark questions as answered
New Member

1042N AP wont connect to 2106 WLC

Wow how embarassing. Once I changed the IP on the Virtual Interface the AP connected just fine. The weird thing is I had to set that during the initial setup and put it to 1.1.1.1. Regardless, I put it back and now the AP is showing up in the Wireless tab on the WLC.

Thank you Stephen!

1121
Views
0
Helpful
10
Replies
CreatePlease login to create content