Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

1142N VLAN configuration issue

Hello,

     I have a Cisco 1142N dual-band WAP that is 95% configured.  It currently has 2 SSIDs which are broadcasting and tagging the traffic for the correct VLANs.  I have configured most of the settings from the web interface.  However, when I go to add the Radio1-802.11N to either of the SSIDs, I recieve the following message "VLAN '3' doesn't exist on 'Radio1-802.11N 5GHz' (see Services>VLAN)"  However, when I go to Services>VLAN Both radios are tagged for both VLANs, so my question is are both VLANs tied to both radios?  If not, how can I configure it?  I don't know the console commands would be for those.  Any help would be greatly appriciated.

Adam

ap#show running-config

Building configuration...

Current configuration : 3304 bytes

!

version 12.4

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname ap

!

enable secret

!

no aaa new-model

!

!

dot11 syslog

dot11 vlan-name GuestWireless vlan 3

dot11 vlan-name WGSWhitecaps vlan 1

!

dot11 ssid Whitecaps Guest

   vlan 3

   authentication open

   authentication key-management wpa

   mbssid guest-mode

   wpa-psk ascii 7 0204015A080E0D3441

!

dot11 ssid Whitecaps Owner

   vlan 1

   authentication open

   authentication key-management wpa

   mbssid guest-mode

   wpa-psk ascii 7 08334342050D0C1317

!

!

!

username Cisco password 7 00271A150754

!

!

bridge irb

!

!

interface Dot11Radio0

no ip address

no ip route-cache

!

encryption mode ciphers aes-ccm tkip

!

encryption vlan 1 mode ciphers aes-ccm tkip

!

encryption vlan 3 mode ciphers aes-ccm tkip

!

ssid Whitecaps Guest

!

ssid Whitecaps Owner

!

antenna gain 0

mbssid

speed  basic-1.0 2.0 5.5 11.0 6.0 9.0 12.0 18.0 24.0 36.0 48.0 54.0 m0. m1. m2. m3. m4. m5. m6. m7. m8. m9. m10. m11. m12. m13. m14. m15.

station-role root

!

interface Dot11Radio0.1

encapsulation dot1Q 1 native

no ip route-cache

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

bridge-group 1 spanning-disabled

!

interface Dot11Radio0.3

encapsulation dot1Q 3

no ip route-cache

bridge-group 3

bridge-group 3 subscriber-loop-control

bridge-group 3 block-unknown-source

no bridge-group 3 source-learning

no bridge-group 3 unicast-flooding

bridge-group 3 spanning-disabled

!

interface Dot11Radio1

no ip address

no ip route-cache

!

encryption mode ciphers aes-ccm tkip

!

encryption vlan 1 mode ciphers aes-ccm tkip

!

encryption vlan 3 mode ciphers aes-ccm tkip

antenna gain 0

dfs band 3 block

speed  basic-6.0 9.0 12.0 18.0 24.0 36.0 48.0 54.0 m0. m1. m2. m3. m4. m5. m6. m7. m8. m9. m10. m11. m12. m13. m14. m15.

channel dfs

station-role root

!

interface Dot11Radio1.1

encapsulation dot1Q 1 native

no ip route-cache

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

bridge-group 1 spanning-disabled

!

interface Dot11Radio1.3

encapsulation dot1Q 3

no ip route-cache

bridge-group 3

bridge-group 3 subscriber-loop-control

bridge-group 3 block-unknown-source

no bridge-group 3 source-learning

no bridge-group 3 unicast-flooding

bridge-group 3 spanning-disabled

!

interface GigabitEthernet0

no ip address

no ip route-cache

duplex auto

speed auto

no keepalive

!

interface GigabitEthernet0.1

encapsulation dot1Q 1 native

no ip route-cache

bridge-group 1

no bridge-group 1 source-learning

bridge-group 1 spanning-disabled

!

interface GigabitEthernet0.3

encapsulation dot1Q 3

no ip route-cache

bridge-group 3

no bridge-group 3 source-learning

bridge-group 3 spanning-disabled

!

interface BVI1

ip address 10.10.199.3 255.255.255.0

no ip route-cache

!

ip default-gateway 10.10.199.1

ip http server

no ip http secure-server

ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag

bridge 1 route ip

!

!

!

line con 0

line vty 0 4

login local

!

end

2 REPLIES

Re: 1142N VLAN configuration issue

Adam:
Your WLANs are not configured under the radio 802.11a. (Dot11Radio1). They are only configured under radio 802.11b/g.


The folloing commands appear under interface Dot11Radio0. You need to add them under interface Dot11Radio1 as well:

ssid Whitecaps Guest

!

ssid Whitecaps Owner

HTH

Amjad

Rating useful replies is more useful than saying "Thank you"
Bronze

Re: 1142N VLAN configuration issue

Hi,

The configuration looks to be okay

The only thing is that as mention above, if you want to use the A radio to add the ssid under the interface.

Also i noticed that you have configured to use both encryption ciphers AES and TKIP and this may or may not work if the wireless client supports it or could create connectivity issues and at the end you have wireless clients reporting that they connect and disconnect.

As per the WiFi alliance when working with wpa version 1 we use the cipher of TKIP and when working with WPA version 2 we use the cipher of AES-CCM and due to this all wireless clients are set to comply with the WiFi alliance so the wireless card can do an encryption method at a time either wpav1 + TKIP or wpav2 + AES.

Also make sure that the switch where the ap is connected is configured as a trunk port with the same untagged or natvie vlan the access point has an ip address for.

Sent from Cisco Technical Support iPad App

2063
Views
0
Helpful
2
Replies
CreatePlease to create content