Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

1252 VLAN not working

I have a single AP1252 unit with two SSID's (Private=VLAN1 & Public=VLAN3). The SSID:Private is the native VLAN and works just fine. The SSID:Public has client problems. From the AP, I can ping my VLAN3 gateway on the router. Clients can connect to SSID:Public and in the GUI, it shows the association. But the client can't get an DHCP address from SSID Public. I set a static IP address on the client on VLAN 3, but still can't ping the gateway. I'm not sure where I went wrong.

1 ACCEPTED SOLUTION

Accepted Solutions

Re: 1252 VLAN not working

Your configuration looks perfectly fine. Something is not right on your switch/router/dhcp side.

SWITCH, make sure you are trunking:

interface FastEthernet0/1

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,3

switchport mode trunk

spanning-tree portfast trunk

On router, make sure you got helper pointing to DHCP, or you have a DHCP pool configured for vlan 3.

4 REPLIES

Re: 1252 VLAN not working

autonomous? Can you post your AP config?

Community Member

Re: 1252 VLAN not working

Autonomous=Yes

Config is attatched in txt.

Re: 1252 VLAN not working

Your configuration looks perfectly fine. Something is not right on your switch/router/dhcp side.

SWITCH, make sure you are trunking:

interface FastEthernet0/1

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,3

switchport mode trunk

spanning-tree portfast trunk

On router, make sure you got helper pointing to DHCP, or you have a DHCP pool configured for vlan 3.

Community Member

Re: 1252 VLAN not working

hi roman,

i basically have the same ap config as the one posted but without the gateway ip and is working fine. i've all the ap's on an ap mgmt subnet and separate vlans for the different types of users (employee and guests). just wanna ask, what is purpose of the gateway ip address? what are the consequences if it is and it isn't set?

thanks!

375
Views
0
Helpful
4
Replies
CreatePlease to create content