Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

1841 and hwic 802.11 problem accessing web

Ok guys i need some help. I do not possess the necessary skill yet to troubleshoot this so there it goes..

I am trying to setup a 1841 with adsl and wireless wic for home use. After endless hours (i am currently studying for ccna so i am a newbie)

of reading i managed to create a configuration that seemed to me working but its not. The problem is with the wireless connections.

There seems to be an issue with most of the requests http for example, while other requests work fine. For example via http i can access youtube but

cant access other sites. Like a request timeout. Clients that are connected to the router via ethernet work fine.

Can someone check my configuration and let me know where have i messed it up?

!

! Last configuration change at 12:10:12 Athens Fri Dec 2 2011 by admin

! NVRAM config last updated at 12:09:22 Athens Fri Dec 2 2011 by admin

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname Router

!

boot-start-marker

boot-end-marker

!

no logging buffered

enable secret 5 $1$89xj$p33gqt4Pc6UzSLKK0VR8a.

!

no aaa new-model

!

resource policy

!

clock timezone Athens 2

clock summer-time Athens date Mar 30 2003 3:00 Oct 26 2003 4:00

ip cef

!

!

no ip dhcp use vrf connected

ip dhcp excluded-address 192.168.2.1

ip dhcp excluded-address 192.168.2.254

ip dhcp excluded-address 192.168.1.1

!

ip dhcp pool cisco

   network 192.168.2.0 255.255.255.0

   dns-server 192.168.2.254

   default-router 192.168.2.254

!

ip dhcp pool ps3

   network 192.168.1.0 255.255.255.252

   default-router 192.168.1.1

   dns-server 192.168.1.1

!

ip dhcp pool wireless

   network 192.168.0.0 255.255.255.0

   dns-server 192.168.0.254

   default-router 192.168.0.254

   lease 3

!

!

vpdn enable

!

!

!

!

username admin privilege 15 password 7 15165801542939702B2A

!

!

!

bridge irb

!

!

!

interface FastEthernet0/0

ip address 192.168.2.254 255.255.255.0

ip nat inside

no ip virtual-reassembly

ip tcp adjust-mss 1452

duplex auto

speed auto

!

interface FastEthernet0/1

ip address 192.168.1.1 255.255.255.252

ip nat inside

no ip virtual-reassembly

ip tcp adjust-mss 1452

duplex auto

speed auto

!

interface ATM0/0/0

no ip address

no atm ilmi-keepalive

bundle-enable

dsl operating-mode auto

!

interface ATM0/0/0.1 point-to-point

no ip proxy-arp

no snmp trap link-status

pvc 8/35

  pppoe-client dial-pool-number 1

!

!

interface Dot11Radio0/1/0

no ip address

no ip redirects

ip local-proxy-arp

ip virtual-reassembly

!

encryption vlan 1 mode ciphers tkip

!

ssid Osiris

    vlan 1

    authentication open

    authentication key-management wpa

    guest-mode

    wpa-psk ascii 7 13111F43185D177E3B703B2022720103

!

speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0

station-role root

no cdp enable

!

interface Dot11Radio0/1/0.1

encapsulation dot1Q 1 native

no cdp enable

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 spanning-disabled

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

!

interface Dot11Radio0/1/1

no ip address

shutdown

speed basic-6.0 9.0 basic-12.0 18.0 basic-24.0 36.0 48.0 54.0

station-role root

!

interface Dialer1

description $FW_OUTSIDE$

mtu 1492

ip address negotiated

ip nat outside

ip virtual-reassembly

encapsulation ppp

dialer pool 1

ppp authentication chap pap callin

ppp chap hostname kkouts

ppp chap password 7 000816010B095B5656

ppp pap sent-username kkouts password 7 10420C1E0A45425B55

ppp ipcp dns request

!

interface BVI1

ip address 192.168.0.254 255.255.255.0

ip nat inside

ip virtual-reassembly

!

ip route 0.0.0.0 0.0.0.0 Dialer1

!

!

ip http server

ip http authentication local

no ip http secure-server

ip dns server

ip nat inside source list 1 interface Dialer1 overload

ip nat inside source static udp 192.168.2.4 60000 interface Dialer1 60000

ip nat inside source static tcp 192.168.2.4 60000 interface Dialer1 60000

!

access-list 1 permit 192.168.0.0 0.0.255.255

dialer-list 1 protocol ip permit

no cdp run

!

!

!

!

control-plane

!

bridge 1 protocol ieee

bridge 1 route ip

!

line con 0

exec-timeout 0 0

password 7 00071A150754

logging synchronous

line aux 0

line vty 0 4

password 7 141341065C07387F2731

login local

!

scheduler allocate 20000 1000

end

2 REPLIES
New Member

1841 and hwic 802.11 problem accessing web

Also the output from wireshark returns a lot of

"Duplicate to the ACK.."  messages.

New Member

1841 and hwic 802.11 problem accessing web

Ok here is an update. As you can see the MTU is set to 1492 for the Adsl Interface.

After manually setting the mtu size in my macbooks wireless card it started to work fine.

Now here is the question. Shouldnt the cisco wireless interface have a setting that would automatically

do that for the clients? Macbook has an auto MTU size which works fine with the Ethernet interfaces of the router.

Is there a way to set the MTU for the cisco wireless?

261
Views
0
Helpful
2
Replies
CreatePlease to create content