Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

1941W bridge issues

I'm trying to setup a (what I think to be) simple wireless network using a Cisco 1941W integrated services router. Currently running this on a test environment behind a little Linksys router/modem combo (at 192.168.0.1). I would like to use the 2.4ghz radio as a root access point for clients to gain access to both the wired network (currently at 192.168.2.0) and the external network (currently at 192.168.0.1). Wireless clients are set to 192.168.1.X.

I can ping external IPs from the router (ie google.com), ping all the interfaces on the AP (BVI interface and clients). From the AP I can ping all the interfaces on the router, I can't however leave the router at all (ie ping 192.168.0.1, google). Been playing with this for a while so there might be some extras in my config but:

Router Config:

!

! Last configuration change at 22:59:21 UTC Thu Aug 5 2010

!

version 15.0

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname YTCamsRouter

!

boot-start-marker

boot-end-marker

!

enable secret 5 $1$..KB$Qa/M2FDZkxqAHydIMyFDk1

!

no aaa new-model

service-module wlan-ap 0 bootimage autonomous

!

no ipv6 cef

ip source-route

ip cef

!

!

ip dhcp excluded-address 192.168.1.1 192.168.1.99

ip dhcp excluded-address 192.168.1.201 192.168.1.254

!

ip dhcp pool ytexternal

   network 192.168.1.0 255.255.255.0

   default-router 192.168.1.1

   dns-server 192.168.1.1

!

!

ip name-server 8.8.8.8

ip name-server 4.4.4.4

ip name-server 192.168.0.1

multilink bundle-name authenticated

!

!

!

license udi pid CISCO1941W-A/K9 sn FHK140573YT

!

!

username SAadmin privilege 15 secret 5 $1$izd3$bv13qI3qWRcgT6a7YivWc1

!

!

!

!

!

!

interface Wlan-GigabitEthernet0/0

description Internal switch interface connecting to the embedded AP

!

interface GigabitEthernet0/0

description internal interface

ip address 192.168.2.1 255.255.255.0

ip access-group from-lan in

ip nat inside

ip virtual-reassembly

duplex auto

speed auto

!

interface wlan-ap0

description Service module interface to manage the embedded AP

ip unnumbered Vlan1

arp timeout 0

no mop enabled

no mop sysid

!

interface GigabitEthernet0/1

description external interface

bandwidth 1000

ip address 192.168.0.200 255.255.255.0

ip access-group from-lan out

ip nat outside

ip virtual-reassembly

duplex auto

speed auto

!

interface FastEthernet0/0/0

no ip address

shutdown

duplex auto

speed auto

!

interface FastEthernet0/0/1

no ip address

shutdown

duplex auto

speed auto

!

interface Vlan1

ip address 192.168.1.1 255.255.255.0

ip nat inside

ip virtual-reassembly

!

ip forward-protocol nd

!

no ip http server

no ip http secure-server

!

ip route 0.0.0.0 0.0.0.0 192.168.0.1

!

ip access-list extended nat-list

permit ip 192.168.0.0 0.0.0.255 any

permit tcp 192.168.1.0 0.0.0.255 any

!

!

!

!

control-plane

!

!

line con 0

password xxxxx

login

line aux 0

line 67

no activation-character

no exec

transport preferred none

transport input all

transport output pad telnet rlogin lapb-ta mop udptn v120 ssh

line vty 0 4

password xxxxxx

login

!

scheduler allocate 20000 1000

end

AP Config:

!

version 12.4

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname ap

!

no logging buffered

enable secret 5 $1$iTve$jLo12l8pXiW6fzZ34B5fg1

!

no aaa new-model

!

!

dot11 syslog

!

dot11 ssid YTGuest

   vlan 1

   authentication open

   authentication key-management wpa

   guest-mode

   wpa-psk ascii 7 033D0B1E080832581E1E17

!

!

!

username Cisco password 7 01300F175804

!

!

bridge irb

!

!

interface Dot11Radio0

no ip address

no ip route-cache

!

encryption mode ciphers aes-ccm

!

encryption vlan 1 mode ciphers aes-ccm

!

ssid YTGuest

!

antenna gain 0

station-role root access-point

!

interface Dot11Radio0.1

encapsulation dot1Q 1 native

no ip route-cache

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

bridge-group 1 spanning-disabled

!

interface Dot11Radio1

no ip address

no ip route-cache

shutdown

antenna gain 0

dfs band 3 block

channel dfs

station-role root

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

bridge-group 1 spanning-disabled

!

interface GigabitEthernet0

description the embedded AP GigabitEthernet 0 is an internal interface connecting AP with the host router

no ip address

no ip route-cache

!

interface GigabitEthernet0.1

encapsulation dot1Q 1 native

no ip route-cache

bridge-group 1

no bridge-group 1 source-learning

bridge-group 1 spanning-disabled

!

interface BVI1

ip address 192.168.1.3 255.255.255.0

no ip route-cache

!

ip http server

no ip http secure-server

ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag

bridge 1 route ip

!

!

!

line con 0

no activation-character

line vty 0 4

login local

!

end

show ip route from the router:

YTCamsRouter#show ip route

Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2

       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

       ia - IS-IS inter area, * - candidate default, U - per-user static route

       o - ODR, P - periodic downloaded static route, + - replicated route

Gateway of last resort is 192.168.0.1 to network 0.0.0.0

S*    0.0.0.0/0 [1/0] via 192.168.0.1

      192.168.0.0/24 is variably subnetted, 2 subnets, 2 masks

C        192.168.0.0/24 is directly connected, GigabitEthernet0/1

L        192.168.0.200/32 is directly connected, GigabitEthernet0/1

      192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks

C        192.168.1.0/24 is directly connected, Vlan1

L        192.168.1.1/32 is directly connected, Vlan1

      192.168.2.0/24 is variably subnetted, 2 subnets, 2 masks

C        192.168.2.0/24 is directly connected, GigabitEthernet0/0

L        192.168.2.1/32 is directly connected, GigabitEthernet0/0

YTCamsRouter#

Just for good measure, a show IP Interfaces brief from the router

Interface                  IP-Address      OK? Method Status                Prot

ocol

Wlan-GigabitEthernet0/0    unassigned      YES unset  up                    up


GigabitEthernet0/0         192.168.2.1     YES manual up                    up


wlan-ap0                   192.168.1.1     YES TFTP   up                    up


GigabitEthernet0/1         192.168.0.200   YES manual up                    up


FastEthernet0/0/0          unassigned      YES NVRAM  administratively down down


FastEthernet0/0/1          unassigned      YES NVRAM  administratively down down


Vlan1                      192.168.1.1     YES NVRAM  up                    up


NVI0                       192.168.2.1     YES unset  up                    up


YTCamsRouter#

Thanks in advance.

  • Getting Started with Wireless
Everyone's tags (3)
1 REPLY

Re: 1941W bridge issues

Hi Jeff,

I don't see a default gateway configured  on the ap.

looks like it should be 192.168.1.1

1399
Views
0
Helpful
1
Replies
This widget could not be displayed.