Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

1941W Can't Get IP via DHCP on BVI1

I have learned a lot in the last few days, trying to configure a 1941W router... Spent many hours on these forums... The only thing I'm still stuck on is that, I'm not able to get an IP through DHCP on the BVI1 interface of the embedded AP.  Can anyone help?

Here is my router config:

Current configuration : 3490 bytes

!

! Last configuration change at 22:00:35 PCTime Tue Aug 21 2012 by root

! NVRAM config last updated at 01:23:44 PCTime Tue Aug 21 2012 by root

!

version 15.0

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router1

!

boot-start-marker

boot-end-marker

!

no logging buffered

!

no aaa new-model

clock timezone PCTime -5

clock summer-time PCTime date Apr 6 2003 2:00 Oct 26 2003 2:00

service-module wlan-ap 0 bootimage autonomous

!

no ipv6 cef

ip source-route

ip cef

!

!

ip dhcp excluded-address 192.168.20.0 192.168.20.9

ip dhcp excluded-address 192.168.21.0 192.168.21.9

ip dhcp excluded-address 10.20.7.1 10.20.7.49

ip dhcp excluded-address 10.20.7.251 10.20.7.254

!

ip dhcp pool WLAN_BGN_USERS

   network 192.168.20.0 255.255.255.0

   default-router 192.168.20.1

   dns-server 192.168.10.254

!

ip dhcp pool WLAN_A_USERS

   network 192.168.21.0 255.255.255.0

   default-router 192.168.21.1

   dns-server 192.168.10.254

!

ip dhcp pool ccp-pool1

   import all

   network 10.20.7.0 255.255.255.0

   default-router 10.20.7.1

!

!

ip domain name mynewrouter.com

multilink bundle-name authenticated

!

!

!

license udi pid CISCO1941W-A/K9 sn FGL153026TT

hw-module ism 0

!

!

!

username XXXXXX privilege 15 password 0 XXXXXX

!

!        

no ip ftp passive

!

!

!

!

interface Wlan-GigabitEthernet0/0

description Internal switch interface connecting to the embedded AP

switchport mode trunk

!

interface GigabitEthernet0/0

description LAN interface

ip address 10.20.7.1 255.255.255.0

ip nat inside

ip virtual-reassembly

duplex auto

speed auto

!

interface wlan-ap0

description Service module interface to manage the embedded AP

ip unnumbered Vlan1

arp timeout 0

no mop enabled

no mop sysid

!

interface GigabitEthernet0/1

description WAN interface

ip address dhcp client-id GigabitEthernet0/1

ip nat outside

ip virtual-reassembly

duplex auto

speed auto

!

interface Vlan1

ip address 10.20.1.1 255.255.255.0

ip nat inside

ip virtual-reassembly

!

interface Vlan8

ip address 10.20.8.1 255.255.255.0

ip access-group nat-list in

ip nat inside

ip virtual-reassembly

!

interface Vlan20

ip address 192.168.20.1 255.255.255.0

ip nat inside

ip virtual-reassembly

!

interface Vlan21

ip address 192.168.21.1 255.255.255.0

ip nat inside

ip virtual-reassembly

!

ip forward-protocol nd

!

ip http server

ip http authentication local

no ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

!

ip nat inside source list 1 interface GigabitEthernet0/1 overload

ip nat inside source list 3 interface GigabitEthernet0/1 overload

ip route 0.0.0.0 0.0.0.0 dhcp

!

ip access-list extended nat-list

permit ip 10.20.7.0 0.0.0.255 any

permit tcp 10.20.8.0 0.0.0.255 any

!

access-list 1 remark CCP_ACL Category=2

access-list 1 permit 10.20.7.0 0.0.0.255

access-list 2 remark CCP_ACL Category=2

access-list 2 permit 10.20.8.0 0.0.0.255

access-list 3 remark CCP_ACL Category=2

access-list 3 permit 10.20.8.0 0.0.0.255

!

!

!

control-plane

!

alias exec s sh ip int br

!

line con 0

exec-timeout 0 0

line aux 0

line 67

no activation-character

no exec

transport preferred none

transport input all

transport output pad telnet rlogin lapb-ta mop udptn v120 ssh

line vty 0 4

privilege level 15

login local

transport input telnet ssh

transport output telnet ssh

line vty 5 15

privilege level 15

login local

transport input telnet ssh

transport output telnet ssh

!

scheduler allocate 20000 1000

end

And here is my embedded AP config:

Current configuration : 2482 bytes

!

version 12.4

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname ap0

!

enable secret 5 XXXXXX

!

no aaa new-model

!

!

dot11 syslog

!

dot11 ssid 600First

   vlan 20

   authentication open

   authentication key-management wpa

   mbssid guest-mode

   wpa-psk ascii 7 XXXXXX

!

!

!

username root privilege 15 secret 5 XXXXXX

!

!

bridge irb

!

!

interface Dot11Radio0

no ip address

no ip route-cache

!

encryption vlan 20 mode ciphers aes-ccm tkip

!

broadcast-key vlan 20 change 30

!

!

ssid XXXXXX

!

antenna gain 0

station-role root

bridge-group 1

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

bridge-group 1 spanning-disabled

!

interface Dot11Radio0.20

encapsulation dot1Q 20

no ip route-cache

bridge-group 2

bridge-group 2 subscriber-loop-control

bridge-group 2 block-unknown-source

no bridge-group 2 source-learning

no bridge-group 2 unicast-flooding

bridge-group 2 spanning-disabled

!

interface Dot11Radio1

no ip address

no ip route-cache

!

encryption vlan 20 mode ciphers aes-ccm tkip

!

broadcast-key vlan 20 change 30

!       

!

ssid XXXXXX

!

antenna gain 0

dfs band 3 block

channel dfs

station-role root

bridge-group 1

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

bridge-group 1 spanning-disabled

!

interface Dot11Radio1.20

encapsulation dot1Q 20

no ip route-cache

bridge-group 2

bridge-group 2 subscriber-loop-control

bridge-group 2 block-unknown-source

no bridge-group 2 source-learning

no bridge-group 2 unicast-flooding

bridge-group 2 spanning-disabled

!        

interface GigabitEthernet0

description  the embedded AP GigabitEthernet 0 is an internal interface connecting AP with the host router

no ip address

no ip route-cache

bridge-group 1

no bridge-group 1 source-learning

bridge-group 1 spanning-disabled

!

interface GigabitEthernet0.20

encapsulation dot1Q 20

no ip route-cache

bridge-group 2

no bridge-group 2 source-learning

bridge-group 2 spanning-disabled

!

interface BVI1

ip address dhcp client-id GigabitEthernet0

no ip route-cache

!

ip http server

no ip http secure-server

ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag

bridge 1 route ip

!

!

!

line con 0

no activation-character

line vty 0 4

login local

!

end

I would be very grateful for any help that anyone may have to offer!

Everyone's tags (4)
1 ACCEPTED SOLUTION

Accepted Solutions

Re: 1941W Can't Get IP via DHCP on BVI1

ok, then this is what you need to do on the router:

bridge irb

bridge 2 protocol ieee

bridge 2 route ip

interface G0/0

no ip address

bridge-group 2

Interface VLAN 2

no ip address

brdige-group 2

interface BVI 2

ip address 10.20.7.1 255.255.255.0

ip nat inside

ip virtual-reassembly

interface Wlan-GigabitEthernet0/0

description Internal switch interface connecting to the embedded AP

switchport mode trunk

switchport trunk native vlan 2

This should work.  But if the router is in produciton, you might want to wait till after hours or lunch time, incase there are issues.

HTH,
Steve

------------------------------------------------------------------------------------------------
Please remember to rate useful posts, and mark questions as answered

HTH, Steve ------------------------------------------------------------------------------------------------ Please remember to rate useful posts, and mark questions as answered
24 REPLIES
Hall of Fame Super Silver

Re: 1941W Can't Get IP via DHCP on BVI1

Here are some great links

https://supportforums.cisco.com/docs/DOC-17085

Sent from Cisco Technical Support iPhone App

-Scott
*** Please rate helpful posts ***
New Member

1941W Can't Get IP via DHCP on BVI1

Thank you for the links.  After reviewing them, I'm still no further ahead.  I would really appreciate more specific help.

Hall of Fame Super Silver

Re: 1941W Can't Get IP via DHCP on BVI1

Configure a static for that interface and that will allow you to access the AP.

!

interface wlan-ap0

description CONSOLE_CONNECTION_TO_AP

ip address 10.1.1.1 255.255.255.0

arp timeout 0

no mop enabled

no mop sysid

end

Sent from Cisco Technical Support iPhone App

-Scott
*** Please rate helpful posts ***
New Member

Re: 1941W Can't Get IP via DHCP on BVI1

I've assigned a static IP to the wlan-ap0 interface, as you've suggested (except I made the IP 10.20.10.1, since 10.1.1.1 made my AP inaccessible).  However, this did not get me any further.  I've tried resetting my AP to defaults, with no change.  BVI1 still does not get IP, just stays unassigned.

Interface                  IP-Address      OK? Method Status                Protocol

BVI1                       unassigned      YES DHCP   up                    up     

Dot11Radio0                unassigned      YES unset  administratively down down   

Dot11Radio1                unassigned      YES unset  administratively down down   

GigabitEthernet0           unassigned      YES other  up                    up

Here is my current AP config:

!

version 12.4

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname ap0

!

enable secret 5 XXXXXX

!

no aaa new-model

!

!

dot11 syslog

!

!

username root privilege 15 secret 5 XXXXXX

!

!

bridge irb

!

!

interface Dot11Radio0

no ip address

no ip route-cache

shutdown

antenna gain 0

station-role root

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

bridge-group 1 spanning-disabled

!

interface Dot11Radio1

no ip address

no ip route-cache

shutdown

antenna gain 0

dfs band 3 block

channel dfs

station-role root

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

bridge-group 1 spanning-disabled

!

interface GigabitEthernet0

description  the embedded AP GigabitEthernet 0 is an internal interface connecting AP with the host router

no ip address

no ip route-cache

bridge-group 1

no bridge-group 1 source-learning

bridge-group 1 spanning-disabled

!

interface BVI1

ip address dhcp client-id GigabitEthernet0

no ip route-cache

!

ip http server

no ip http secure-server

ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag

bridge 1 route ip

!

!

!

line con 0

no activation-character

line vty 0 4

login local

!

end

New Member

I had to add a VLAN to the

I had to add a VLAN to the 1941 just like a switch:

vlan database:

vlan 2

apply

- otherwise the trunk wont carry that vlan to the AP

Hall of Fame Super Silver

Re: 1941W Can't Get IP via DHCP on BVI1

Try this

interface Wlan-GigabitEthernet0/0

description CONNECTION_TO_AP

switchport access vlan 1

no ip address

spanning-tree portfast

Sent from Cisco Technical Support iPad App

-Scott
*** Please rate helpful posts ***
New Member

Re: 1941W Can't Get IP via DHCP on BVI1

Thank you for trying to help me thus far... still no go...

This is what I got:

Router1(config)#int Wlan-GigabitEthernet0/0

Router1(config-if)#description CONNECTION_TO_AP                                                 

Router1(config-if)#switchport access vlan 1                                                

Router1(config-if)#no ip address                                                                

Router1(config-if)#spanning-tree portfast

%Warning: portfast should only be enabled on ports connected to a single host.

Connecting hubs, concentrators, switches,  bridges, etc.to this interface

when portfast is enabled, can cause temporary spanning tree loops.

Use with CAUTION

%Portfast has been configured on Wlan-GigabitEthernet0/0 but will only

have effect when the interface is in a non-trunking mode.

Router1(config-if)#end

And the resulting sho run gives this for that int:

!

interface Wlan-GigabitEthernet0/0

description CONNECTION_TO_AP                                                 

switchport mode trunk

spanning-tree portfast

!

Hall of Fame Super Silver

Re: 1941W Can't Get IP via DHCP on BVI1

You have it as a trunk. Can you remove the trunk and make the port an access port.

I have a 1941w but my ap is lightweight.

Sent from Cisco Technical Support iPhone App

-Scott
*** Please rate helpful posts ***
New Member

Re: 1941W Can't Get IP via DHCP on BVI1

I removed the trunk with:

interface Wlan-GigabitEthernet0/0

no switchport mode trunk

end

"make the port an access point" ... not sure how to do that?

Hall of Fame Super Silver

Re: 1941W Can't Get IP via DHCP on BVI1

Switchport access

Switchport access vlan 1

Sent from Cisco Technical Support iPhone App

-Scott
*** Please rate helpful posts ***
Hall of Fame Super Silver

Re: 1941W Can't Get IP via DHCP on BVI1

Here is another post that has it a different way

https://supportforums.cisco.com/thread/2028286

Sent from Cisco Technical Support iPhone App

-Scott
*** Please rate helpful posts ***
New Member

Re: 1941W Can't Get IP via DHCP on BVI1

Added the command:

switchport access vlan 1

When I do sh run, it doesn't show "switchport access vlan 1" ... not sure why.

Also, I tried the config from that last post:

interface wlan-ap0

ip unnumbered vlan 1

This makes my AP inaccessible.

Hall of Fame Super Silver

Re: 1941W Can't Get IP via DHCP on BVI1

Vlan 1 is default and that is why it doesn't show up. You can put it on another vlan if you want

Sent from Cisco Technical Support iPhone App

-Scott
*** Please rate helpful posts ***
New Member

Re: 1941W Can't Get IP via DHCP on BVI1

Still no go... Tried VLAN 8 and VLAN 20... couldn't access AP... the only thing that allows me to access the AP is this one:

ip unnumbered GigabitEthernet0/0

Hall of Fame Super Silver

Re: 1941W Can't Get IP via DHCP on BVI1

So if you can get to the ap, can you assign a static to the ap interface and see if you can ping out from the ap.

Sent from Cisco Technical Support iPhone App

-Scott
*** Please rate helpful posts ***

Re: 1941W Can't Get IP via DHCP on BVI1

You don't have a DHCP pool configured for VLAN 1.  at least not on the router.

I'd leave the WLAN interface as a trunk, since you are going to have wireless users in VLAN 20.

HTH,
Steve

------------------------------------------------------------------------------------------------
Please remember to rate useful posts, and mark questions as answered

HTH, Steve ------------------------------------------------------------------------------------------------ Please remember to rate useful posts, and mark questions as answered
New Member

Re: 1941W Can't Get IP via DHCP on BVI1

I set a static IP (10.20.7.10) on the AP's BVI interface.  I'm not able to ping anything in the router, or external to the router.

I also changed the Wlan interface back to trunk.

Re: 1941W Can't Get IP via DHCP on BVI1

VLAN 1 is 10.20.1.x, your Gig0/0 is the 10.20.7.x.  If you want the AP to pull an address in the 10.20.7.0 then you need to bridge that interface, instead of routing it which it is by default.

If you're ok with it being in VLAN 1, then set a 10.20.1.x address on the BVI of the AP.

HTH,
Steve

------------------------------------------------------------------------------------------------
Please remember to rate useful posts, and mark questions as answered

HTH, Steve ------------------------------------------------------------------------------------------------ Please remember to rate useful posts, and mark questions as answered
New Member

Re: 1941W Can't Get IP via DHCP on BVI1

I would like to bridge the Gig0/0, so that I could get a 10.20.7.x address on the AP.  How do I go about doing this?

Re: 1941W Can't Get IP via DHCP on BVI1

ok, then this is what you need to do on the router:

bridge irb

bridge 2 protocol ieee

bridge 2 route ip

interface G0/0

no ip address

bridge-group 2

Interface VLAN 2

no ip address

brdige-group 2

interface BVI 2

ip address 10.20.7.1 255.255.255.0

ip nat inside

ip virtual-reassembly

interface Wlan-GigabitEthernet0/0

description Internal switch interface connecting to the embedded AP

switchport mode trunk

switchport trunk native vlan 2

This should work.  But if the router is in produciton, you might want to wait till after hours or lunch time, incase there are issues.

HTH,
Steve

------------------------------------------------------------------------------------------------
Please remember to rate useful posts, and mark questions as answered

HTH, Steve ------------------------------------------------------------------------------------------------ Please remember to rate useful posts, and mark questions as answered
New Member

Re: 1941W Can't Get IP via DHCP on BVI1

Thanks Steve!  I can now ping from the AP to the outside world by IP... can't ping by name.

Also, I'm not able to get to the Web GUI @ http://10.20.7.10

Re: 1941W Can't Get IP via DHCP on BVI1

pinging the AP?  you probably need to create the A record. 

if you're pinging from the AP, make sure you have the ip domain-name configured as well as the server IP.

and try ip http authentication local

HTH,
Steve

------------------------------------------------------------------------------------------------
Please remember to rate useful posts, and mark questions as answered

HTH, Steve ------------------------------------------------------------------------------------------------ Please remember to rate useful posts, and mark questions as answered
New Member

Re: 1941W Can't Get IP via DHCP on BVI1

I'm all set!  Thank you for all your help!!!

Re: 1941W Can't Get IP via DHCP on BVI1

no worries.  stop back if you have further questions

HTH,
Steve

------------------------------------------------------------------------------------------------
Please remember to rate useful posts, and mark questions as answered

HTH, Steve ------------------------------------------------------------------------------------------------ Please remember to rate useful posts, and mark questions as answered
3286
Views
0
Helpful
24
Replies
CreatePlease to create content