Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

1941W configuration help needed

Our Deployment Scenario:-

1941W Gigabit Ethernet 0/0 is connected to the PPOE connection of the ISP.

Gigabit Ethernet 0/1 is connected to the wired LAN

I have created 2 wireless radio Cisco_Kamran_BGN which is operating at 2.4 Ghz Devices and Cisco_Kamran_A which is operating at 5Ghz Devices.

I have created 2 VLans for the Wireless.

Vlan 10 for Cisco_Kamran_A        192.168.10.x

Vlan 11 for Cisco _Kamran_BGN   192.168.11.X

The problem is the Wireless users are not getting the IP address from the respective DHCP server which has been configured on the Router.

Can please any from the community help me and show me where I am missing the configuration.

Please find my router  & ap configuration below.

Router Configuration

Router#

sh run

Building configuration...

Current configuration : 3022 bytes

!

! No configuration change since last restart

version 15.1

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router

!

boot-start-marker

boot-end-marker

!

!

enable secret 5 $1$TdQt$npYeaf/W0kRElcfMggzJ31

!

no aaa new-model

!

service-module wlan-ap 0 bootimage autonomous

!

no ipv6 cef

ip source-route

ip cef

!

!

!

ip dhcp excluded-address 192.168.1.1 192.168.1.50

ip dhcp excluded-address 192.168.10.1 192.168.10.10

ip dhcp excluded-address 192.168.11.1 192.168.11.10

!

ip dhcp pool DHCP

network 192.168.1.0 255.255.255.0

default-router 192.168.1.1

dns-server 195.229.241.222 213.42.20.20

!

ip dhcp pool Cisco_Kamran_A

network 192.168.11.0 255.255.255.0

default-router 192.168.11.1

dns-server 195.229.241.222 213.42.20.20

!

ip dhcp pool Cisco_Kamran_BGN

network 192.168.10.0 255.255.255.0

default-router 192.168.10.1

dns-server 195.225.241.222 213.42.20.20

!

!

!

multilink bundle-name authenticated

!

crypto pki token default removal timeout 0

!

!

license udi pid CISCO1941W-E/K9 sn FCZ1553C1VK

hw-module ism 0

!

!

!

!

redundancy

!

!

!

!

!

!

!

bridge irb

!

!

!

!

interface Embedded-Service-Engine0/0

no ip address

shutdown

!

interface GigabitEthernet0/0

ip address 192.168.1.1 255.255.255.0

ip nat inside

ip virtual-reassembly in

duplex auto

speed auto

!

interface wlan-ap0

description Service module interface to manage the embedded AP

ip unnumbered GigabitEthernet0/0

arp timeout 0

no mop enabled

no mop sysid

!

interface GigabitEthernet0/1

no ip address

duplex auto

speed auto

pppoe enable group global

pppoe-client dial-pool-number 1

!

interface Wlan-GigabitEthernet0/0

description Internal switch interface connecting to the embedded AP

switchport mode trunk

no ip address

!

interface Vlan1

no ip address

!

interface Vlan10

ip address 192.168.10.1 255.255.255.0

ip access-group DSL_ACCESSLIST in

ip nat inside

ip virtual-reassembly in

!

interface Vlan11

ip address 192.168.11.1 255.255.255.0

ip access-group DSL_ACCESSLIST in

ip nat inside

ip virtual-reassembly in

!

interface Dialer1

ip address negotiated

ip nat outside

ip virtual-reassembly in

encapsulation ppp

dialer pool 1

ppp authentication pap callin

ppp pap sent-username xxxxxx password 0 xxxxxx

ppp ipcp route default

!

ip forward-protocol nd

!

no ip http server

no ip http secure-server

!

ip nat inside source list DSL_ACCESSLIST interface Dialer1 overload

!

ip access-list extended DSL_ACCESSLIST

permit ip 192.168.0.0 0.0.255.255 any

!

!

!

!

!

!

!

control-plane

!

!

!

line con 0

password xxxxxx

login

line aux 0

line 2

no activation-character

no exec

transport preferred none

transport input all

transport output pad telnet rlogin lapb-ta mop udptn v120 ssh

stopbits 1

line 67

no activation-character

no exec

transport preferred none

transport input all

transport output pad telnet rlogin lapb-ta mop udptn v120 ssh

line vty 0 4

password xxxxxx

login

transport input all

!

scheduler allocate 20000 1000

end

Router#

Router#

Router#

Access Point Configuration

ap#

ap#

ap#

sh run

Building configuration...

Current configuration : 2603 bytes

!

version 12.4

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname ap

!

enable secret 5 $1$JxdQ$a2/00bWJuhUKP9QLC94YD/

!

no aaa new-model

!

!

dot11 syslog

!

dot11 ssid Cisco_Kamran_A

   authentication open

   authentication key-management wpa

   guest-mode

   wpa-psk ascii 7 1045081417161C5A555C7A7B

!

dot11 ssid Cisco_Kamran_BGN

   authentication open

   authentication key-management wpa

   guest-mode

   wpa-psk ascii 7 020D05561907017015165949

!

!

!

username Cisco password 7 14341B180F0B

!

!

bridge irb

!

!

interface Dot11Radio0

description 802.11bgn radio

no ip address

no ip route-cache

!

encryption mode ciphers aes-ccm

!

broadcast-key change 3600

!

!

ssid Cisco_Kamran_BGN

!

antenna gain 0

station-role root

bridge-group 11

bridge-group 11 subscriber-loop-control

bridge-group 11 block-unknown-source

no bridge-group 11 source-learning

no bridge-group 11 unicast-flooding

bridge-group 11 spanning-disabled

!

interface Dot11Radio1

description 802.11a radio

no ip address

no ip route-cache

!

encryption mode ciphers aes-ccm

!

ssid Cisco_Kamran_A

!

antenna gain 0

no dfs band block

channel dfs

station-role root

bridge-group 10

bridge-group 10 subscriber-loop-control

bridge-group 10 block-unknown-source

no bridge-group 10 source-learning

no bridge-group 10 unicast-flooding

bridge-group 10 spanning-disabled

!

interface GigabitEthernet0

description the embedded AP GigabitEthernet 0 is an internal interface connecting AP with the host router

no ip address

no ip route-cache

bridge-group 1

no bridge-group 1 source-learning

bridge-group 1 spanning-disabled

!

interface GigabitEthernet0.10

description 802.11a bridge

encapsulation dot1Q 10

no ip route-cache

bridge-group 10

bridge-group 10 subscriber-loop-control

bridge-group 10 block-unknown-source

no bridge-group 10 source-learning

no bridge-group 10 unicast-flooding

bridge-group 10 spanning-disabled

!

interface GigabitEthernet0.11

description 802.11bgn bridge

encapsulation dot1Q 11

no ip route-cache

bridge-group 11

bridge-group 11 subscriber-loop-control

bridge-group 11 block-unknown-source

no bridge-group 11 source-learning

no bridge-group 11 unicast-flooding

bridge-group 11 spanning-disabled

!

interface BVI1

ip address dhcp client-id GigabitEthernet0

no ip route-cache

!

ip http server

no ip http secure-server

ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag

bridge 1 route ip

!

!

!

line con 0

no activation-character

line vty 0 4

login local

!

end

ap#

ap#

ap#

6 REPLIES

Re: 1941W configuration help needed

You need to add the .10 and .11 sub interfaces for the radios as well. And call the VLAN under the SSID config.

Steve

Sent from Cisco Technical Support iPhone App

HTH, Steve ------------------------------------------------------------------------------------------------ Please remember to rate useful posts, and mark questions as answered
New Member

Re: 1941W configuration help needed

Hi Stephen,

thanks for the reply

Please if you can provide me with the commands which i need to execute. Also other thing i noticed is that my wireless clients are not getting the IP Address from the dhcp which is configured on the router. If i assing them manual IP address it works fine. But i think i have done something wrong, if i connect to the wirless network named Cisco_Kamran_A and i manually give them the ip address 192.168.11.x it does not work. I need to give them the ip address of 192.168.10.x and it works. Please if you can correct me where i have done a mistake.

1941W configuration help needed

conf t

interface Dot11Radio0

!

no ssid Cisco_Kamran_BGN

!

no encryption mode ciphers aes-ccm

!

exit

!

interface Dot11Radio1

!

no encryption mode ciphers aes-ccm

!

no ssid Cisco_Kamran_A

!

exit

!

dot11 ssid Cisco_Kamran_A

vlan 10

!

dot11 ssid Cisco_Kamran_BGN

vlan 11

!

exit

!

interface Dot11Radio0

!

encryption vlan 11 mode ciphers aes

!

!

ssid Cisco_Kamran_BGN

!

exit

interface dot11radio0.1

encapsulation dot1q 1 native

bridge-group 1

!

interface dot11radio 0.11

encapsulation dot1q 11

bridge-group 11

!

exit

!

interface Dot11Radio1

!

encryption vlan 10 mode ciphers aes-ccm

!

ssid Cisco_Kamran_A

!

interface dot11radio1.1

encapsulation dot1q 1 native

bridge-group 1

!

interface dot11radio1.10

encapuslation dot1q 10

bridge-group 10

!

end

wr

HTH, Steve ------------------------------------------------------------------------------------------------ Please remember to rate useful posts, and mark questions as answered
New Member

Re: 1941W configuration help needed

Hi Stepehen,

Did the configuration as per your advice  but i am getting the below mentioned error which i have highlighted it in red. Please advice what needs to be done.

Home

Re: 1941W configuration help needed

created by Stephen Rodriguez in Getting     Started with Wireless - View the full discussion


conf t

interface     Dot11Radio0

!

no ssid     Cisco_Kamran_BGN

!

no encryption mode     ciphers aes-ccm

!

exit

!

interface     Dot11Radio1

!

no encryption mode     ciphers aes-ccm

!

no ssid     Cisco_Kamran_A

!

exit

!

dot11 ssid     Cisco_Kamran_A

vlan 10

!

dot11 ssid     Cisco_Kamran_BGN

vlan 11

!

exit

!

interface     Dot11Radio0

!

encryption vlan 11     mode ciphers aes

!

!

ssid     Cisco_Kamran_BGN

!

exit

interface     dot11radio0.1

encapsulation     dot1q 1 native

bridge-group 1

!

interface     dot11radio 0.11

encapsulation     dot1q 11

bridge-group 11

Configuration of     subinterfaces and main interface

within the same bridge     group is not permitted

!

exit

!

interface     Dot11Radio1

!

encryption vlan 10     mode ciphers aes-ccm

!

ssid     Cisco_Kamran_A

!

interface     dot11radio1.1

encapsulation     dot1q 1 native

bridge-group 1

!

interface     dot11radio1.10

encapuslation     dot1q 10

bridge-group 10

Configuration of subinterfaces and main     interface

within the same bridge     group is not permitted

!

end

wr

Reply to this message by going to Home

Start a new discussion in Getting Started with Wireless at Home

Re: 1941W configuration help needed

Ok, go into the Dot11Radio 0 and do a no bridge-group 11, and Dot11Radio 1 and no bridge-group 11.

then

interface     dot11radio1.10

encapuslation     dot1q 10

bridge-group 10

  and

interface     dot11radio 0.11

encapsulation     dot1q 11

bridge-group 11

Steve

HTH, Steve ------------------------------------------------------------------------------------------------ Please remember to rate useful posts, and mark questions as answered
New Member

1941W configuration help needed

Hi Stepehen,

still no luck.. Please find the configuration of the ap below as per what you have instructed. Untill now my wireless clients are not able to get the ip from the DHCP.

ap#

ap#

ap#sh run

Building configuration...

Current configuration : 3215 bytes

!

version 12.4

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname ap

!

enable secret 5 $1$JxdQ$a2/00bWJuhUKP9QLC94YD/

!

no aaa new-model

!

!

dot11 syslog

!

dot11 ssid Cisco_Kamran_A

   vlan 10

   authentication open

   authentication key-management wpa

   guest-mode

   wpa-psk ascii 7 1045081417161C5A555C7A7B

!

dot11 ssid Cisco_Kamran_BGN

   vlan 11

   authentication open

   authentication key-management wpa

   guest-mode

   wpa-psk ascii 7 020D05561907017015165949

!

!

!

username Cisco password 7 14341B180F0B

!

!

bridge irb

!

!

interface Dot11Radio0

description 802.11bgn radio

no ip address

no ip route-cache

!

!

encryption vlan 11 mode ciphers aes-ccm

!

broadcast-key change 3600

!

!

ssid Cisco_Kamran_BGN

!

antenna gain 0

station-role root

!

interface Dot11Radio0.1

encapsulation dot1Q 1 native

no ip route-cache

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

bridge-group 1 spanning-disabled

!

interface Dot11Radio0.11

encapsulation dot1Q 11

no ip route-cache

bridge-group 11

bridge-group 11 subscriber-loop-control

bridge-group 11 block-unknown-source

no bridge-group 11 source-learning

no bridge-group 11 unicast-flooding

bridge-group 11 spanning-disabled

!

interface Dot11Radio1

description 802.11a radio

no ip address

no ip route-cache

!

encryption vlan 10 mode ciphers aes-ccm

!

ssid Cisco_Kamran_A

!

antenna gain 0

no dfs band block

channel dfs

station-role root

bridge-group 1

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

bridge-group 1 spanning-disabled

!

interface Dot11Radio1.10

encapsulation dot1Q 10

no ip route-cache

bridge-group 10

bridge-group 10 subscriber-loop-control

bridge-group 10 block-unknown-source

no bridge-group 10 source-learning

no bridge-group 10 unicast-flooding

bridge-group 10 spanning-disabled

!

interface GigabitEthernet0

description the embedded AP GigabitEthernet 0 is an internal interface connecting AP with the host router

no ip address

no ip route-cache

bridge-group 1

no bridge-group 1 source-learning

bridge-group 1 spanning-disabled

!

interface GigabitEthernet0.10

description 802.11a bridge

encapsulation dot1Q 10

no ip route-cache

bridge-group 10

bridge-group 10 subscriber-loop-control

bridge-group 10 block-unknown-source

no bridge-group 10 source-learning

no bridge-group 10 unicast-flooding

bridge-group 10 spanning-disabled

!

interface GigabitEthernet0.11

description 802.11bgn bridge

encapsulation dot1Q 11

no ip route-cache

bridge-group 11

bridge-group 11 subscriber-loop-control

bridge-group 11 block-unknown-source

no bridge-group 11 source-learning

no bridge-group 11 unicast-flooding

bridge-group 11 spanning-disabled

!

interface BVI1

ip address dhcp client-id GigabitEthernet0

no ip route-cache

!

ip http server

no ip http secure-server

ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag

bridge 1 route ip

!

!

!

line con 0

no activation-character

line vty 0 4

login local

!

end

ap#

ap#

ap#

564
Views
0
Helpful
6
Replies
CreatePlease login to create content