Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

2x a 1200 AP directly on a 2106 WLC

Hello technicians!

First of all, this is my first post/question on the Cisco Community forums, so please excuse me if oversaw something about posting guidelines.

I got my final assignment from school, and my teacher asked me to configure 2 Access Points (1200 series) directly on a Wireless Controler (Cisco 2106). I can't ask my teacher for any questions, cause he doesn't know how to configure it also, THAT's why he's asking me to do it.

I've learned a lot of things about the default static interfaces (the "management" and "ap_manager" interface), but i can't seem to fully understand how to configure it.

I want to use the Internal DHCP server of the WLC. Could somebody please try to explain me how i can get those 2 Access Points working on the WLC. I only seem to get DHCP issues.

This is what i've done:

- Leave the configuration of the "management" and the "ap_manager" default (172.16.1.30 and 172.16.1.30). Bound to port 1

- Made a new interface "AP1" with IP-Address 10.0.0.10 (/24), default gateway 10.0.0.1. Primary DHCP server: 172.167.1.30

- Made a new interface "AP2" with IP-Address 192.168.1.10 (/24), default gateway 192.168.1.1. Primary DHCP server: 172.167.1.30

- Made 2 DHCP scopes within the 192.168.1.0 and 10.0.0.0 networks.

For some reason, when i boot up both AP's, the won't get any DHCP address.

I would kindly like some help on this, since this is the only thing keeping me from my diploma.

If somebody could help me on a little step-by-step guide, that would be great. I watched some video's from Cisco, and i looked at the Configuration Examples, but it seems there isn't one guide of how to configure 2 AP's directly on 1 WLC.

Thank you all for your time and help!

13 REPLIES
Bronze

2x a 1200 AP directly on a 2106 WLC

Hi,

The WLCs are only a layer 2 device for managment of the LWAPP access points.

There are different ways to get the access points to join a WLC.

If the access points are on the same subnet as the WLC managment interface and AP manager, then you can use a layer 2 discovery method to get the access point to join the WLC, either by the access point getting an IP address from a external DHCP server, the WLC DHCP server if self or you can configure an static IP address to the APs and the WLC management IP address.

And once the AP has an IP address it will join a broadcast request to join the WLC and since the WLC is on the same subnet then the AP will be able to join the WLC.

If the access points are going to be on a different subnets then the WLC AP manager and managment interface then you need to use a layer 3 discovery method.

This can be option 43 on the external DHCP server, DNS resoluetion for LWAPP or CAPWAP or that you can figure the IP address to the AP staticaly and include the IP address of the WLC, so the WLC will first send a braodcast and since there is no WLC on the same subnet then it will try to find one using option 43 or DNS look up.

Also there needs to be a router doing the layer 3 routing between subnets.

If you want that the access points are direclty connected to the WLC and that they join the WLC, for this to work you will need to have the AP manager on the same subnet as the managment interface, that the access points get an IP address from the WLC DHCP option and that it is an IP address on the same subnet as the WLC AP manager and managment.

You can check on:

http://www.cisco.com/en/US/products/ps6366/products_tech_note09186a00809d5097.shtml

http://www.cisco.com/en/US/partner/tech/tk722/tk809/technologies_configuration_example09186a00808714fe.shtml

Also on the 2100 WLC as best practice the access points should be connected to a switch and not the WLC itself.

Cisco Employee

2x a 1200 AP directly on a 2106 WLC

#DHCP proxy needs to be enabled on WLC, if not already.

#WLC's internal dhcp doesn't do option 43.

#AP needs to be on Access port, Placing the AP directly to the vlan tagged physical port will have an hiccup.

#You need to have dynamic interface created for that 10 & 192 network on wlc.

#You also need an Router since WLC doesn't do intervlan routing to communicate with AP.

#If you're looking for simple flat setup. AP----Switch----WLC 2100.

#Configure static ip for both APs in the range of WLC's management vlan. Bypass L3 discovery of WLC.

#You need dynamic interface only for your WLANs not APs.

#Create dynamic interfaces and mapt to WLANs.

#Create internal dhcp scopes for each dynamic vlan.

#Use external layer 3 device for routing.

New Member

Re: 2x a 1200 AP directly on a 2106 WLC

Thanks for the replies guys. I also tried to configure it by using a switch, and a router for inter vlan routing, but i couldn't get that to work either.

I made this setup: http://i47.tinypic.com/118o9pe.jpg

The only thing i didn't do, is making WLAN's and bind them to the Dynamic Interface (that couldn't be the problem for the AP's getting no ip address from DHCP right).

So the correct steps in this setup would be:

- Link between WLC and S1: Trunk (Allowed VLANS: 10,20. Native Vlan: 1 ????)

- Link between WLC and R1: Trunk (Allowed VLANS: 10,20. Native Vlan: 1 ????)

- Ports from S1 to AP's: Access Ports in respectively VLAN 10 and VLAN 20

- Configure Subinterfaces on R1. For example: fa0/0.10 and fa0/0.20. How should i configure the route to the 172.16.1.0 network? I tried it with another subinterface, but for some reason i could ping the management and AP_manager interface from the router.

- Configure 2 Dynamic Interfaces in the WLC. For example: "AP1" and "AP2".

- Configure 2 DHCP Scopes. One in the 10.0.0.0 network and one in the 192.168.1.0 network.

Now here comes the question. How do i configure the DHCP server for the 2 dynamic interfaces? Should the IP Address be 172.16.1.30? In this case, DHCP Proxy should be enabled on the WLC right?

I also configured subinterfaces on R1, and when i replaced the AP's for a computer with a static IP Address, i was able to ping everything, except the Management and AP_Manager interface (172.16.1.30 and .31) where they should get their DHCP address.

For some reason, i can't give the AP's a static IP address. I don't know exactly what error i got.

It would be so great if you people could help me out once more. I don't know what i'm doing wrong

New Member

2x a 1200 AP directly on a 2106 WLC

Sorry for the double post, but i really am in need of some help.

Anybody willing to help me out on a basic configuration.

Basically, all i need to know if Mapping a WLAN to a interface is necessary for the AP's to receive a DHCP address.

And with the above configuration, should i configure a (sub)interface on the router in the 172.1.16.0 network?

Bronze

2x a 1200 AP directly on a 2106 WLC

Hi Eric,

Just to make sure we have the correct APs are the APs on IOS or LWAPP? If the APs are in IOS they will not be able to join the WLC at all.

2106 WLC------Switch----router 
 
A simple configuration would be to first configure the WLC with an IP address 
for the management interface and AP manager on the same subnet and set with a
VLAN identifier of 0 which means untagged or native VLANs, the port on the 2106
is already a trunk port.
 
Then on the switch we need to make sure that the VLAN or VLANs needed have been 
configured and that on the port that you connect to the WLC it is set as a trunk
port with the same native or untagged VLAN you set on the WLC.
 
The ports where the access point will be connected need to be on the same subnet 
or VLAN as the WLC AP manager and management interface.
 
On the router you will need to configure a trunk port with the same native VLAN 
as the port on the switch where the router connects to, or configure subinterfaces.

For the access points to get an IP address from the WLC DHCP server we do not need WLAN
mapped to the interface.
We need to kae sure that the mangemtn interface has been configured on the same subent
as the WLC and that they are set as untagged with the IP address of the WLC as the DHCP
server.
Configure the DHCP server on the WLC and make sure it is configured with the correct ip
information and also enable with DHCP proxy enable.

Also you need to configure a subinterface on the router for 172.1.160.0 network. 
New Member

2x a 1200 AP directly on a 2106 WLC

Hi Fbarboza,

Thanks for your reply. What i can't understand is that you're saying to configure the access ports in the same VLAN as the Management/AP-Manager interface. It should be possible to configure them in different VLAN's right?

Bronze

2x a 1200 AP directly on a 2106 WLC

Hi Eric, 
 
Yes, if you want that the access point get an IP address from the DHCP 
server option on the WLC then you will need that the access points
are on the same subnet as the WLC becasue if not it will not work.
 
If you want that the access points get an IP address on a different 
subnet then the WLC then you will need to use an external DHCP sever
and configure on it option 43 or use DNS lookup so that the AP can join the WLC.
 
Or you could access the unit via the console port and configure the 
unit with the static IP address, WLC IP address and default gateway.
New Member

2x a 1200 AP directly on a 2106 WLC

Thanks for the answer.

So basically i'll do this:

Management Interface: 172.16.1.30 - Port 1 (VLAN: Untagged)

AP_Manager Interface: 172.16.1.31 - Port 1 (VLAN: Untagged)

Then this setup:

AP --- SWITCH --- WLC

The connection between Switch and WLC will be a trunk. Should i set the native VLAN something different than "1"?

The connection between AP and Switch will be Access Mode. Leave the Native VLAN as default (1)?

Now i make 1 DHCP Scope, for example: 172.16.1.50 - 172.16.1.55.

I enable "DHCP Proxy".

How about the Dynamic interface? If the Management and AP_Manager interface is on the 172.16.1.0 network, i can't make a Dynamic interface in that same network right.

Sorry if i'm asking stupid questions, but the WLC and AP things are new for me.

Bronze

2x a 1200 AP directly on a 2106 WLC

Hi,

If you need to work with a different subnets or dynamic VLANs on the wireless then on the WLC you just need to add new interfaces with the correct subnet information and set them with a VLAN tag, make sure that thos VLANs exist on the switch and router and the layer 3 reouting required.

Here is the link that shows how to configure VLANs on the WLC.

http://www.cisco.com/en/US/tech/tk722/tk809/technologies_configuration_example09186a00805e7a24.shtml#diag

New Member

2x a 1200 AP directly on a 2106 WLC

Hi Fbarboza,

Again thank you for your reply. I just have one final question.

I want to make this setup: http://i45.tinypic.com/opctf.jpg

I made this config on S1:

------------------------------------------------------------------------------

interface FastEthernet0/1

description Access Port for VLAN 10

switchport access vlan 10

switchport mode access

!

interface FastEthernet0/2

description Access Port for VLAN 20

switchport access vlan 20

switchport mode access

!

interface FastEthernet0/3

description Trunk link to R1

switchport trunk allowed vlan 10,20

switchport mode trunk

!

interface FastEthernet0/4

description Trunk link to WLC

switchport trunk allowed vlan 10,20

switchport mode trunk

------------------------------------------------------------------------------

I made this config on R1:

------------------------------------------------------------------------------

interface FastEthernet0/0

description Interface in the "Untagged" VLAN

ip address 172.16.1.1 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet0/0.10

description Subinterface for VLAN 10

encapsulation dot1Q 10

ip address 192.168.1.1 255.255.255.0

!

interface FastEthernet0/0.20

description Subinterface for VLAN 20

encapsulation dot1Q 20

ip address 10.0.0.1 255.255.255.0

------------------------------------------------------------------------------

The Management and AP_Manager interface will be bound to Port 1, and Port 1 will be connected to the trunk link to S1.

Then i'll make 2 DHCP Scopes. One in the 192.168.1.0 network, and one in the 10.0.0.0 network.

Then i'll make 2 Dynamic interfaces. One in the 192.168.1.0 network, and one in the 10.0.0.0 network. Both with Primary DHCP server: 172.16.1.30

Or should the R1 interface for the 172.16.1.0 network be a Subinterface with dot1Q encapsulation?

It would be great if you could check this configuration, and if necessary mind me on what i'm doing wrong.

Bronze

2x a 1200 AP directly on a 2106 WLC

Hi Eric,

As per the setup you mention since the WLC will be on a different subnet thn the access point on VLAN 20 and the access point on VLAN 10 the access points will not be able to get an IP address from the DHCP server on the WLC and for the access point to get an IP address and join the WLC which is on a different subnet you will need to confgure an extenral DHCP server and on that server configure option 43.

Then on the port of the switch you will need to configure it as a trunk with untagged VLAN or VLAN identifier of 0.

On the switch you will need to make sure that it has the 3 VLANS added, the VLAN 10-VLAN 20 and  the VLAN X for the subnet the WLC is on.

Then on the port that goes to the WLC on the switch it will need to be set as a trunk port and with the native VLAN X for the subnet of the WLC.

Each port connected to the APs will need to be configured as  a static port for VLAN 10 or vlan 20 and then on the port that goes from the switch to the router you configure it as a trunk port with native VLAN X and on the router if it has a switching module you set a trunk port with native VLAN X or if not you create 3 subinterface one for each VLAN and link the subnet interface X as the one on the WLC.

New Member

2x a 1200 AP directly on a 2106 WLC

Thank you so much Fbarboza.

Tomorrow morning i'll be going to school to finish this project.

In stead of using the Internal DHCP server of the WLC, i'll be using the Router or a Windows DHCP server.

I'll let you know if i got passed it.

So many thanks for all the results and help!

Bronze

2x a 1200 AP directly on a 2106 WLC

Hi Erick,

No problem any time.

634
Views
0
Helpful
13
Replies