Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

877W Wireless interface won't come up

Hi,

I got hold of some 877's recently and have been working through the guides on this site. However I seem to be having trouble with the wireless configuration. A sh ip int brief reveals that the physical dot11radio0 interface and its sub interface are up and up but there is a virtual-dot11radio0 interface in the list which is down and down. VLAN2 also shows as up and down. The WLAN OK LED flashed continually and does not become steady and I can't see anything with a wireless client.

My objectives are to have to deliver wireless internet access to a group of people whilst having separate wired access (and site to site VPN) for another group of people, who may at some point in the future also need wireless access hence the use of the sub interface and VLAN 2 for the wireless network.

The wireless part of the config so far is as follows. Could anyone point me in the direction of why it is not working?

Also does anyone know if it is possible to restrict the throughput of the internet connection by VLAN?

!

ip dhcp pool wpool1

import all

network 192.168.11.0 255.255.255.0

default-router 192.168.11.1

dns-server x.x.x.x

domain-name domain.com

!

interface Dot11Radio0

no ip address

!

broadcast-key vlan 2 change 45

!

!

encryption vlan 2 mode ciphers tkip

!

ssid xxxxxx

vlan 2

authentication open

authentication key-management wpa

wpa-psk ascii 7 xxxxxx

!

speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0

station-role root

!

interface Dot11Radio0.1

description service user wlan

encapsulation dot1Q 2

no snmp trap link-status

no cdp enable

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 spanning-disabled

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

!

interface Vlan1

ip address 192.168.80.1 255.255.255.0

ip nat inside

ip virtual-reassembly

!

interface Vlan2

no ip address

ip virtual-reassembly

bridge-group 1

bridge-group 1 spanning-disabled

!

!

interface BVI1

ip address 192.168.11.1 255.255.255.0

ip nat inside

ip virtual-reassembly

!

!

!

no ip http server

no ip http secure-server

ip nat pool pooll 192.168.80.0 192.168.81.0 netmask 0.0.0.255

ip nat pool pool2 192.168.11.0 192.168.12.0 netmask 0.0.0.255

ip nat inside source list acl1 pool pool1

ip nat inside source list acl2 pool pool2

!

access-list 1 permit 192.168.80.0 0.0.0.255

access-list 2 permit 192.168.11.0 0.0.0.255

!

!

!

end

1 REPLY
New Member

Re: 877W Wireless interface won't come up

virtual-dot11radio interfaces are used to communicate with other repeaters. If there is no repeater associated with the AP, the AP puts the virtual-dot11radio interface to down.

212
Views
0
Helpful
1
Replies