Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

AIR-AP-1231 for guest access

I have a requirement to provide wireless access to a group of devices. Iphones/netbooks etc. I have an ADSL wired connection and an AIR-AP-1231.

I have connected the AIR-AP-1231 to the ADSL router and have got an IP and have got onto the management page but I cannot get the wireless network to be seen.

I also need to restrict access to only specific MAC addresses. Longer term I want to roll out more AP's and connect them with a controller.

I need to find a basic starting guide and want to know if the AP-1231 is suitabel for this role or should I be looking at using a standard Linksys type wireless router?

1 ACCEPTED SOLUTION

Accepted Solutions
Silver

Re: AIR-AP-1231 for guest access

You have a ciphers setting on vlan 1 under your d0 interface. That's the start of a WPA solution but you need more under the SSID config:

dot11ssid Cisco

authen key-management wpa version 2

wpa-psk ascii MySuperSecretKey

To get MAC filtering working, use the following example. Substiture in appropriate mac addresses for the X's; leave the 0's unchanged.

access-list 700 permit xxxx.xxxx.xxxx 0000.0000.0000

access-list 700 permit xxxx.xxxx.xxxx 0000.0000.0000

access-list 700 permit xxxx.xxxx.xxxx 0000.0000.0000

dot11 association mac-list 700

4 REPLIES
Silver

Re: AIR-AP-1231 for guest access

The AP1231 will certainly do what you want, although if you're not already familiar with the product then it may be easier with a consumer product.

If you paste the config from your AP here, we can post the edits you'll need to make.

New Member

Re: AIR-AP-1231 for guest access

Thanks, I would like to stick with the AP as I am planning on installing a lot more over the next few months.

I managed to get the wireless up (had to enable the interface!)

I then managed to connect and route over the ADSL (set vlan1)

I have now managed to lock my self out with the WPA settings and would like to find out how to permit only specified MAC addresses to be able to associate with the AP.

Thanks

Roger

sh

% Type "show ?" for a list of subcommands

ap#sh run

Building configuration...

Current configuration : 1511 bytes

!

version 12.3

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname ap

!

enable secret 5 $1$DyN2$qtAcjiul5LkmkPjbguagb.

!

ip subnet-zero

!

!

no aaa new-model

!

dot11 ssid Cisco

vlan 1

authentication open

guest-mode

!

dot11 network-map

!

!

username Cisco password 7 14341B180F0B

!

bridge irb

!

!

interface Dot11Radio0

no ip address

no ip route-cache

!

encryption vlan 1 mode ciphers aes-ccm

!

ssid Cisco

!

speed basic-1.0 basic-2.0 basic-5.5 basic-6.0 basic-9.0 basic-11.0 basic-12.0 basic-18.0 basic-24.0 basic-36.0 basic-48.0 basic-54.0

station-role root access-point

antenna gain 128

world-mode dot11d country GB indoor

!

interface Dot11Radio0.1

encapsulation dot1Q 1 native

no ip route-cache

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

bridge-group 1 spanning-disabled

!

interface FastEthernet0

no ip address

no ip route-cache

duplex auto

speed auto

!

interface FastEthernet0.1

encapsulation dot1Q 1 native

no ip route-cache

bridge-group 1

no bridge-group 1 source-learning

bridge-group 1 spanning-disabled

!

interface BVI1

ip address dhcp client-id FastEthernet0

no ip route-cache

!

ip http server

no ip http secure-server

ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag

!

bridge 1 route ip

!

!

!

line con 0

line vty 0 4

login local

!

end

Silver

Re: AIR-AP-1231 for guest access

You have a ciphers setting on vlan 1 under your d0 interface. That's the start of a WPA solution but you need more under the SSID config:

dot11ssid Cisco

authen key-management wpa version 2

wpa-psk ascii MySuperSecretKey

To get MAC filtering working, use the following example. Substiture in appropriate mac addresses for the X's; leave the 0's unchanged.

access-list 700 permit xxxx.xxxx.xxxx 0000.0000.0000

access-list 700 permit xxxx.xxxx.xxxx 0000.0000.0000

access-list 700 permit xxxx.xxxx.xxxx 0000.0000.0000

dot11 association mac-list 700

New Member

Re: AIR-AP-1231 for guest access

Perfect - all working as I wanted to now.

Many Thanks

Roger

607
Views
0
Helpful
4
Replies
CreatePlease to create content