Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Aironet 1131AG setup with 3560 switch

I'm having issues trying to setup an Aironet 1131AG with DSL internet service.  I have the Aironet 1131AG connected to a Cisco 3560 8-port POE switch, but can't get internet connection when connected wirelessly.  I enabled DHCP on the Aironet and get assigned an IP, but that's as far as it gets.  I can get internet connection if I plug directly into the switch and I can ping external addresses from the command prompt of the Aironet 1131AG, but no service when connecting a device wirelessly.  Devices connect successfully to the Aironet, but nothing else.

I was wondering if someone could point me in the right direction on setting this up?  Also, can I get by with dhcp on the aironet or do I need a router?  The switch and aironet have static IPs in the same subnet.  I need the simplest way to get internet connection, since it will be for guest.

Thanks,

Here's my current configs:

DSL Service Name Server
222.22.222.185
222.22.222.186
222.22.222.187

DSL Modem IP
333.333.333.113

Cisco 3560 8-port POE Switch
333.333.333.114

Cisco Aironet 1131AG
333.333.333.118

---------------------------------------------------
CISCO 3560 8-port POE Switch Configs
---------------------------------------------------

Switch Configs

Current configurations : 1101 bytes
!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname SAMPLEWIFI
!
boot-start-marker
boot-end-marker
!
enable secret 5 $343$353564234
enable password xxxxxxxxxx
!
no aaa new-model
system mtu routing 1500
ip subnet-zero
ip routing
ip name-server 222.22.222.185
ip name-server 222.22.222.186
ip name-server 222.22.222.187
!
!
!
!
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface GigabitEthernet0/1
!
interface Vlan1
ip address 333.333.333.114 255.255.255.0
!
ip default-gateway 333.333.333.113
ip classless
ip route 333.333.333.0 255.255.255.0 333.333.333.113
ip http server
!
!
control-plane
!
!
line con 0
line vty 0 4
password xxxxxxxxx
login
line vty 5 15
password xxxxxxxxxx
login
!
end

---------------------------------------------------
CISCO AIRONET 1131AG Configs
---------------------------------------------------
Aironet Configs

version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname SampleWIFI
!
enable secret 5 $$$$$$xxxxxxx
!
no aaa new-model
clock timezone -0600 -6
ip domain name samplewifi
ip name-server 222.22.222.185
ip name-server 222.22.222.186
ip name-server 222.22.222.187
no ip dhcp use vrf connected
ip dhcp excluded-address 333.333.333.21 333.333.333.255
!
ip dhcp pool samplepool
  network 333.333.333.0 255.255.255.0
  default-router 333.333.333.113
  lease 3 23
!
!
dot11 syslog
!
dot11 ssid SAMPLEWIFI
  vlan 1
  authentication open
  guest-mode
!
dot11 network-map
dot11 arp-cache
!
!
username xxxxx password 8 2423423423423
!
!
bridge irb
!
!
interface Dot11Radio0
no ip address
no ip address
!
ssid SAMPLEWIFI
!
speed basic-1.0 2.0 5.5 11.0 6.0 9.0 12.0 18.0 24.0 36.0 48.0 54.0
station-role root
!
interface Dot11Radio0.1
encapsulation dot1Q 1 native
no ip route-cache
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
bridge-group 1 spanning-disabled
!
interface Dot11Radio1
no ip address
no ip route-cache
!
ssid SAMPLEWIFI
!
dfs band 3 block
channel dfs
station-role root
!
interface Dot11Radio1.1
encapsulation dot1Q 1 native
no ip route-cache
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
bridge-group 1 spanning-disabled
!
interface FastEthernet0
no ip address
no ip route-cache
duplex auto
speed auto
!
interface FastEthernet0.1
encapsulation dot1Q 1 native
bridge-group 1
no bridge-group 1 source-learning
bridge-group 1 spanning-disabled
!
interface BV1
ip address 333.333.333.118 255.255.255.0
no ip route route-cache
!
ip default-gateway 333.333.333.113
ip http server
no ip http secure-server
ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag
bridge 1 route ip
!
!
!
line con 0
line vty 0 4
login local
!
end

Everyone's tags (3)
2 REPLIES
New Member

Aironet 1131AG setup with 3560 switch

Not sure if the 3560 image you're working with has it, but try enabling the DHCP service on the 3560.  "Service DHCP" I think.  Don't have one handy so can't give you the syntax.  Also, is the DHCP server on a different VLAN than your clients?  If so, you'll need a DHCP helper configured on the L3 VLAN interface that the clients are on, pointing to your DHCP server's IP address.

New Member

Aironet 1131AG setup with 3560 switch

Hello Shawn,

Take a look at the link below. This configuration is in the 1131AG section and should help you set up the AP and the switch. I personally like to have the DHCP server on the switch rather than the AP to centralize assignment of IP and troubleshooting.

http://www.cisco.com/en/US/tech/tk722/tk809/technologies_configuration_example09186a0080665ceb.shtml

To set up the DHCP server on the 3560, use the following commands:

ip dhcp pool data-pool

   import all

   network xx.xx.xx.0 255.255.255.0

   default-router xx.xx.xx.xx

   domain-name domain.local

   dns-server xx.xx.xx.xx

If you like to exclude IP addresses from the pool use:

ip dhcp excluded-address 10.1.1.200 10.1.1.254 (example)

Removing the DHCP server from the AP and configuring the service on the switch should help you isolate the issue further. If the wireless clients obtains an IP address from the switch, then the clients should be able to reach the internet.

Question:

1. Is the DSL modem acting as a router? If so, is the DHCP enabled on it? Disable it and let the switch be the DHCP server.

Hope this helps.

Bert Wilhelm

2241
Views
0
Helpful
2
Replies
CreatePlease to create content