Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Aironet 2600 - DHCP Address Lease Problem

     Hello, I am having trouble with my autonomous Aironet 2600 that is configured as a DHCP server to assign addresses to wireless clients. After much troubleshooting, clients are able to successfully connect with WPA encryption on and can access the Internet. The problem I am now having is that although the address lease time is set to a very low interval (1 min), the DHCP server will keep assigning addresses in sequence rather than revert to a lower address that is to my knowledge available and not already leased to a client. I assumed that the DHCP server would try to use the lowest available address when assigning to clients in order to be efficient. Is this assumptions correct?


The address for the AP is 192.168.3.1 and is set as static.
I have setup two excluded address ranges.
1st Excluded Range - 192.168.3.0 to 192.168.3.25 is reserved for future access points and other wireless equipment.
2nd Excluded Range - 192.168.3.125 to 192.168.3.255 is reserved for client address assignment by future access points.
This should leave a total of 100 available addresses (more than I need) that can be assigned by the AP DHCP server to wireless clients at this location.

I have also set up a DHCP pool
network 192.168.3.0      255.255.255.0
default-router 192.168.3.25 (This is a firewall which all traffic must pass through for security and web context filtering. This is also set as the gateway)
dns-server xxx.xxx.xxx.xxx

I will post the configuration below (slightly edited for security reasons). If anyone has any idea why this is happening or sees anything incorrect please let me know. Any help is greatly appreciated, thanks!

!

! Last configuration change at 01:09:29 UTC Mon Mar 1 1993 by Mike

version 15.2

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname ADAM1-AP1

!

logging rate-limit console 9

!

aaa new-model

!

!

aaa authentication login default local

aaa authorization exec default local

!

!

!

!

!

aaa session-id common

no ip routing

ip dhcp excluded-address 192.168.3.0 192.168.3.25

ip dhcp excluded-address 192.168.3.125 192.168.3.255

!

ip dhcp pool ADAM

network 192.168.3.0 255.255.255.0

default-router 192.168.3.25

dns-server xxx.xxx.xxx.xxx

lease 0 0 1

!

!

dot11 syslog

!

dot11 ssid ADAM-AP1

   authentication open

   authentication key-management wpa

   guest-mode

   wpa-psk ascii x xxxxxxxxxxxxxxxxxxxx

!

crypto pki token default removal timeout 0

!

!

username Mike privilege 15 password x xxxxxxxxxxxxxxxxxxxxxxxx

!

!

bridge irb

!

!

interface Dot11Radio0

no ip address

no ip route-cache

!

encryption mode ciphers tkip

!

ssid ADAM-AP1

!

antenna gain 0

stbc

speed  basic-1.0 2.0 5.5 11.0 6.0 9.0 12.0 18.0 24.0 36.0 48.0 54.0

station-role root

no dot11 extension aironet

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 spanning-disabled

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

!

interface Dot11Radio1

no ip address

no ip route-cache

shutdown

antenna gain 0

dfs band 3 block

stbc

channel dfs

station-role root

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 spanning-disabled

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

!

interface GigabitEthernet0

no ip address

no ip route-cache

duplex auto

speed auto

bridge-group 1

bridge-group 1 spanning-disabled

no bridge-group 1 source-learning

!

interface BVI1

ip address 192.168.3.1 255.255.255.0

no ip route-cache

!

ip default-gateway 192.168.3.25

ip http server

ip http authentication aaa

no ip http secure-server

ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag

!

bridge 1 route ip

!

!

!

line con 0

line vty 0 4

transport input all

!

end



1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Gold

Aironet 2600 - DHCP Address Lease Problem

How DHCP dishes out IP address is like "fet1sh", it's whatever-floats-your-boat.

Some manufacturer dishes out from the lowest IP address and some would start from the highest IP address.

What you are seeing, in my opinion, makes sense.  Ok, so you make your IP address 1 minute lease time.  When the machine doesn't respond from the DHCP the DHCP server will say, "it's gone and won't need the IP address".  So why did you not get the same IP address?  Probably because of round-robin.

If you really want to "bind" a specific MAC address to a DHCP IP address, then this is possible. 

3 REPLIES
Hall of Fame Super Gold

Aironet 2600 - DHCP Address Lease Problem

Wow.  I've never seen someone configure the lease time to be lower than 30 minutes.  This is a first for me!

Sorry, I don't get what the problem is.  Can you elaborate?

New Member

Aironet 2600 - DHCP Address Lease Problem

     Ill try my best to explain the problem more in depth. I originally had the lease time set to 5 hours. I setup the excluded ranges to allow for 100 addresses to be assigned which is way more than enough assuming that the inactive leases would expire after five hours and the addresses attached to those leases would become available for reassignment to another client. I connected three wireless devices (a laptop, an iphone, and an itouch) up to the access point and was assigned the following addresses.

Laptop - 192.168.3.26
IPhone - 192.168.3.27
Itouch - 192.168.3.28

     The DHCP server assigned the addresses according to my ranges and all the devices worked. I left work for the day shortly after. I came back the next day (well over five hours later) and connected the same three wireless devices up to the access point again. I though since the leases for the addresses 192.168.3.26, 192.168.3.27, and 192.168.3.28 from the day before should have expired by this point that when I reconnected the wireless devices they should have received these same addresses because the are the bottom three addresses within my pool. They did not, instead they were issued the following addresses.

Laptop - 192.168.3.29
IPhone - 192.168.3.30
Itouch - 192.168.3.31

    At this point I changed the lease time to 1 minute to further test this issue. After changing the least time to 1 minute I saved the change to the startup-config and restarted the access point. I connected my three devices and got the following addresses.


Laptop - 192.168.3.26

IPhone - 192.168.3.27

Itouch - 192.168.3.28


      I disconnected the devices and waited well over a minute for the leases to expire. I then reconnected the devices and again instead of assigning the lowest available addresses within the pool (192.168.3.26, 192.168.3.27 and 192.168.3.28) it assigned the following.

Laptop - 192.168.3.29

IPhone - 192.168.3.30

Itouch - 192.168.3.31

      Either I am misunderstanding how the DHCP server leases work or the DHCP server is not working properly. It was my understanding that when a client connects to the AP that the DHCP server try's to assign the client the lowest numbered available address within the pool. If the lease attached to the address 192.168.3.26 expires, that address should become available and should be assigned to the next device that connects because its the first available address in the pool. Instead the DHCP server assigns 192.168.0.27 to the next connected device when 192.168.0.26 is not being used at all.

     This happening creates a problem for me because even though I have 100 available addresses, if the DHCP server just keeps assigning addresses in sequence like this, eventually I will run out of addresses and the only way to fix the problem would then be to restart the access point. I hope that was not too confusing and better explained my problem. Again thank you for your help with this issue.

Hall of Fame Super Gold

Aironet 2600 - DHCP Address Lease Problem

How DHCP dishes out IP address is like "fet1sh", it's whatever-floats-your-boat.

Some manufacturer dishes out from the lowest IP address and some would start from the highest IP address.

What you are seeing, in my opinion, makes sense.  Ok, so you make your IP address 1 minute lease time.  When the machine doesn't respond from the DHCP the DHCP server will say, "it's gone and won't need the IP address".  So why did you not get the same IP address?  Probably because of round-robin.

If you really want to "bind" a specific MAC address to a DHCP IP address, then this is possible. 

1181
Views
0
Helpful
3
Replies