Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Aironet ACU autoinstall

I have been trying to use the Aironet auto install utility to get the ACU installed and automatically update the firmware. There have been two items I cannot get to work as documented.

1. The firmware will not update. The messages imply that the image is found but then it does not upgrade it.

2. I need to use LEAP but do not want the ability to save user names and passwords. When manually installing this ability can be disabled but when done automatically, it is always available.

5 REPLIES
Cisco Employee

Re: Aironet ACU autoinstall

I am sure that you are using CWUA utility. Its just a matter of configuring it correct..Here is the url which explain all the parameters in detail.

http://www.cisco.com/univercd/cc/td/doc/product/wireless/airo_350/350cards/windows/autoinst/cwua_ch2.htm

Another one

http://www.cisco.com/univercd/cc/td/doc/product/wireless/airo_350/350cards/windows/cwuarn/cwua_rn.htm

If you still can't get it work the way its supported, you can open a TAC case and get help from TAC..

New Member

Re: Aironet ACU autoinstall

These are both references I have used. I tried copying the examples exactly and it still did not work. I also have tried modifying the template .ini file that came with the CWUA. The Firmware has not updated and the LEAP save password option has always been available.

Here is a clip of the .ini file I am using:

[App Parameters]

Folder Name = Cisco Systems, Inc. ; folder for applications

Program Location = C:\Program Files\Cisco Aironet\Aironet Client Utility

Enable Leap = y

Allow Leap Data save = n

Create ACU icon on desk = n

Allow Non Admin to modify profiles = n

[FIRMWARE UPGRADE]

UPGRADE = y

DISPLAY FLASH PROGRESS = 1

FIRMWARE PATH = C:\firmware\current.img

Cisco Employee

Re: Aironet ACU autoinstall

There are some issues like that reported..Pl. checkout a bug CSCin08745 which nearly describes your symptoms..Try to open a tac case and have tac engineer linked your problem to that bug..

Now as a workaround you can upgrade wireless clients manually..

New Member

Re: Aironet ACU autoinstall

I am not able to pull up that bug. When I search for it I get the message,

Sorry -- The defect you have requested CSCin08745 cannot be displayed.

This may be due to one or more of the following:

The defect number does not exist.

The defect does not have a customer-visible description available yet.

The defect has been marked Cisco Confidential.

New Member

Re: Aironet ACU autoinstall

I too cannot get the firmware to load.

Even if I just include the name of the firmware file, the autoinstaller says the firmware could not be found in the temp directory where everything else is extracted to during the install.

I don't get this! Why wouldn't the file be available? As long as the firmware.img file is in the folder with the CWUA.exe, shouldn't that be sufficient?

If you specify an absolute path to the firmware on that local drive, it would have to be constant for each and every customer. How do you propose this happens? The firmware should be packaged up with the rest of the files and available in the temp directory when the script is running. In addition, it doesn't make sense to make the path a network share, because the client card has no IP prior to the ACU install and reboot.

???

251
Views
0
Helpful
5
Replies
CreatePlease to create content