Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

AP will not connect when Interface is set as Trunk?

I have an issue where configuring an switch interface to a trunk knocks the AP (3502i) off the grid.  

______________________________________________________________________________________

When I configure the Cisco 3560 as

int f0/1

switchport access vlan 228

switchport mode access

AP stands up.

______________________________________________________________________________________

When I configure as

int f0/1

switchport trunk encap dot1q

switchport trunk native vlan 228

switchport trunk allowed vlan 228, 230

switchport mode trunk

FAILS

______________________________________________________________________________________

I can plug a laptop into the trunked interface with a static IP and ping devices sucessfully.

I have 3 other sites that are configured the same with no issues.

Steps I have taken...

1. I clear the configuration on the AP - 'clear lwapp private-config'

2. Give it a staic IP, DG and specify the controller IP

3. Reload the AP

4. AP Stands up when switch interface is configured as an access port

5. Can reconfigure via the GUI on the WLC (cisco 5500)

6. Change switch interface to a dot1q trunk - FAILS

The AP is in H-Reap mode, Native VLAN 228, VLAN mappings 230, IP, Subnet and DG are correct

Any ideas? I am a tad lost on things to try out...

Cheers

Brendan

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Silver

Re: AP will not connect when Interface is set as Trunk?

Make sure you do not have this global command on the switch:

vlan dot1q tag native

Sent from my iPhone

-Scott
*** Please rate helpful posts ***
4 REPLIES
Hall of Fame Super Silver

Re: AP will not connect when Interface is set as Trunk?

Make sure you do not have this global command on the switch:

vlan dot1q tag native

Sent from my iPhone

-Scott
*** Please rate helpful posts ***
New Member

AP will not connect when Interface is set as Trunk?

Many thanks Scott, that was the silver bullet

Hall of Fame Super Silver

Re: AP will not connect when Interface is set as Trunk?

No problem:)

Sent from my iPhone

-Scott
*** Please rate helpful posts ***
Hall of Fame Super Silver

Re: AP will not connect when Interface is set as Trunk?

You can test this by removing the native vlan command

int f0/1

switchport trunk encap dot1q

switchport trunk allowed vlan 228, 230

switchport mode trunk

Sent from my iPhone

-Scott
*** Please rate helpful posts ***
434
Views
0
Helpful
4
Replies