Cisco Support Community
Community Member

APs not joining

So today has been a disaster. I have 11 Cisco Aironet APs connected to a Cisco WLC 4402 running When we lost power to the controller over the weekend I only had 8 come back. In the AP join log three of them were saying"Layer 3 discovery request not received on management VLAN". Mind you they were working before the power went out. So one of my colleagues advised me to shut down the controller, disable the switch ports the AP's are plugged into, restart the controller, and then reenable the ports on the switch. Well now I only have three. The rest get the same error message I mentioned before. I also tried disabled and reenabled the DHCP scope they work on as well. Like I said they were all working before the power went out. Can anyone help?

Community Member

How many different switches

How many different switches are we talking about here ?

Is it possible that someone didnt save their switch configs so when the power went out the switches that had unsaved configs went back to a previous state ...IE the switchports are now on the wrong vlans ? 


I would log into the switches and do a show int status to make sure the appropriate ports are enabled first. Then do a show cdp neighbor | i AIR . This command will show you all cisco access points on the switch... next make sure the ports you see your APs on are on the appropriate VLAN. 



Community Member

They are both HP swtiches and

They are both HP swtiches and the configs have not changed. Option 43 is being delivered via a windows 2003 dhcp server. I swear if I wait long enough some of them will show up of there own accord. Like I said some of these were working before. 
Thanks for the reply willkuz68

Community Member

So I tried doing a debug

So I tried doing a debug capwap events enable (lwapp version of command said it was deprecated) and now what I noticed was this over and over again.

*spamReceiveTask: May 28 08:39:48.204: 00:1c:0f:81:04:c0 Join Priority Processing status = 0, Incoming Ap's Priority 1, MaxLrads = 5
*spamReceiveTask: May 28 08:39:48.204: 00:1c:0f:81:04:c0 Discovery Response sent to

*spamReceiveTask: May 28 08:39:48.204: 00:1c:0f:81:04:c0 Received LWAPP DISCOVERY REQUEST to 00:24:c4:e6:19:e0 on port '1'
*spamReceiveTask: May 28 08:39:48.204: 00:1c:0f:81:04:c0 Discarding discovery request in LWAPP from AP supporting CAPWAP 


Any ideas?




Community Member

Nothing is wrong.  That

Nothing is wrong.  That message simply means, that there was an LWAPP request and the code the AP is on is CAPWAP.  This happens in case you have a WLC on older code, but get/convert one with newer code.

Is the dhcp server for the AP management network in another vlan and you have ip helper-address configured?

How are you doing your Discovery?  L2 forwarding, option 43? 


I think you may have to upgrade the code on your controller to support your aps... or downgrade the code on the aps manually before attempting the join process with your controller.

What model # AP ?


Community Member

AIR -AP1242AG-K9

AIR -AP1242AG-K9

Community Member

Just to let you know we are

Just to let you know we are getting these dtls max retransmission  errors that stop the APs from joining as well.

CreatePlease to create content