Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Assistance with 881W Unified Wireless setup

I'm setting up a couple 881W cisco routers to use Unified wireless and am running into a bit of a brick wall.

I've read through the "Upgrading to Unified Cisco Software" section of the following article:

http://www.cisco.com/en/US/docs/routers/access/800/860-880-890/software/configuration/guide/wlan.html

The problem is, I can't run the "service-module wlan-ap0 bootimage unified" command. The keyword "bootimage" does not exist. The router is licensed for advipservices and I'm running version 15.0(1)M4 on the router. AP is currently running version 12.4(21a)JA1.

Can someone please help me in figuring out why the bootimage command doesn't appear? Will I need to downgrade the router IOS to 12.4?

----

Additionally I'm having trouble finding an answer to the following:

Is there a way to set up the embedded AP on the same network as the Data VLAN on the router, or do I need to create a separate IP network for the embedded AP? I've tried using 'ip unnumbered vlan10' (vlan10 is the data vlan) on the wlan-ap0 interface but then when I try opening a session to the AP it doesn't connect.

bcp4n51001#service-module wlan-ap0 session

Trying 10.199.62.1, 2002 ...

% Connection timed out; remote host not responding

This is my Vlan10 setup for one of the routers:

interface Vlan10

ip address 10.199.62.1 255.255.255.0

ip helper-address 10.151.103.254

ip helper-address 10.150.1.254

ip pim sparse-mode

9 REPLIES

Re: Assistance with 881W Unified Wireless setup

jpeterson6,

This is probably going to sound like a really stupid question, but are you running the command from global configuration mode?

router(config)# service-module wlan-ap 0 bootimage unified

I ask because I personally have a bad habit of thinking a command is missing a keyword when the same command is available both in exec mode and in configuration mode (and when I'm in the wrong mode). service-module wlan-ap0 is one of those commands.

I wanted to get this out of the way first before troubleshooting further.

Justin

New Member

Re: Assistance with 881W Unified Wireless setup

Nope, not a stupid question.. that was the correct assumption. I was trying in enable mode rather than global config mode. Ahh.. cisco.

Thanks, I was able to run the command.

Do you have any insight to my second question, though? I know I can set up a DHCP server for the embedded ap on the router for the same network as Vlan10, but I actually have a DHCP server set up elsewhere to hand out IP addresses to clients so I don't think this is a viable solution.

Re: Assistance with 881W Unified Wireless setup

jpeterson6,

Try using a BVI to bridge the service-module wlan-ap 0 interface and the vlan 10 interface. If you can't bridge in the int vlan10, then you may have to add all of the physical interfaces that you want in vlan 10 to the bridge group, which is only slightly messier. You could call it bvi10 and then move the vlan 10 interface settings over to the BVI, i.e., bvi10 becomes your new inte vlan10 routing terminal.

This would effectively drop the AP in VLAN 10 and at that point it would hopefully be able pull an IP address from your DHCP server.

Justin

New Member

Re: Assistance with 881W Unified Wireless setup

Unfortunately it seems as though I cannot add a bridge-group to the wlan-ap0 interface.

bcp4n51001(config-if)#bridge-group 1

wlan-ap0 does not support bridging

Re: Assistance with 881W Unified Wireless setup

jpeterson6,

After looking at the config guide for the 881W, it looks like the wlan-ap0 interface may just be for establishing a reverse telnet session to the ap and may not be required for management (although, I say that cautiously).

However, the interface Wlan-GigabitEthernet0 may be the one you want to add to the bridge group with the other interfaces that you have in VLAN 10.

Can you give that at try and see if it works for you?

Justin

New Member

Re: Assistance with 881W Unified Wireless setup

Hi Justin!.  I read your answer, but unfortunately I experienced the same issue with this command (the command it isn't there, really).  I run the command from exec mode and this is what I get:

RTR_1#service-module wlan-ap0 bootimage unified

                                          ^

% Invalid input detected at '^' marker.

RTR_1#service-module wlan-ap0 ?                

  heartbeat-reset  Enable/disable Heartbeat failure to reset Service Module

  reload           Reload service module

  reset            Hardware reset of Service Module

  session          Service module session

  statistics       Service Module Statistics

  status           Service Module Information

  upgrade          Service Module Upgrade

RTR_1#service-module wlan-ap0 upgrade ?

  bootloader  Upgrade bootloader

=======================================================================

When I run the same command from global configuration mode I get this:

RTR_1(config)#service-module wlan-ap 0 bootimage unified

                                 ^

% Invalid input detected at '^' marker.

RTR_1(config)#service?                                 

service

=======================================================================

I'm working with a C887VA-W-A-K9 that is running c800-universalk9-mz.SPA.152-3.T.bin.  After a couple of tests I managed to "convert" the AP to lightweight forcing the AP module into rommon and booting the image manually.  After that the AP can register with the WLC and download the new firmware, but after that I started receiving the following log messages in the CLI of the AP module:

*Apr  9 10:40:29.103: %SM_LICENSE-6-BOOTIMAGE_CHANGE_TO_AUTO: Boot image has been changed to autonomous image

Please use router EXEC CLI service-module wlan-ap 0 reload

to bootup autonomous image on AP

Another issue is that everytime that I turn on the router I lost the configuration on my SVI and the boot line for the AP module, so I have to configure the SVI and start up manually again.

Can you help me?? I don't know where I messed up.

New Member

Assistance with 881W Unified Wireless setup

Any answer here? I have the same issue. Could it be licensing?

New Member

Assistance with 881W Unified Wireless setup

Tac:

The reason why you cannot see the command is because in your  router you have a advsecurity (Advanced Security) license.

You need to have an Advanced IP Services license to be able to active  the "unified" feature of your AP module.

You can upgrade from Advanced Security to the Advanced IP Services  enhanced feature set by purchasing a license key.

Therefore, you will need to contact the licensing department, your Cisco  Account Manager or even our website:

www.cisco.com/go/license

to obtain  the license you need.

New Member

I have the same issue but my

I have a similar issue with opening the session. The CLI hangs on that screen:

Router#service-module wlan-ap 0 session
Trying 192.168.10.5, 2002 ... Open

Connecting to AP console, enter Ctrl-^ followed by x,
then "disconnect" to return to router prompt

 

And nothing more. I have no place to put any command in "ap>"

The only I can do is to type the escape sequence.

What can I do to run the embedded AP?

 

My license is like this:

-------------------------------------------------
Device#   PID                   SN
-------------------------------------------------
*0        CISCO892W-AGN-E-K9    <serial>

 

License Information for 'c890'
    License Level: advipservices   Type: Permanent
    Next reboot license Level: advipservices

3858
Views
0
Helpful
9
Replies