Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Can not upgrade WLC 4402 Software

Hi Guys,

     I'm trying to upgrade the sofware to my WLC 4402, but it keeps saying "Failure while storing in flash", the only way to upgrade this box is using TFTP so I changed to a new tftp server (tftp32 this one can handle files larger than 32MB), the new software is  AIR-WLC4400-K9-4-2-176-0.aes (39MB).

     It seems that the WLC have no more room for another file, and i want to delete the old software to install the new one, could someone point me in the right direction?

Please Help!!!

Thanks in advance

1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Re: Can not upgrade WLC 4402 Software

Hi,


Whats the current software version of the WLC? i mean, from which version to which version are we trying to upgrade??

Whats the result after using tftpd32?

TFTPd32 is a very handy tool and preferred to use when we are using the file which is more than 32 MB

The below requirements may help you..

http://www.cisco.com/en/US/tech/tk722/tk809/technologies_configuration_example09186a00805f381f.shtml#req

Let me know how this works out for you.

Regards

Surendra

4 REPLIES
Cisco Employee

Re: Can not upgrade WLC 4402 Software

Hi,


Whats the current software version of the WLC? i mean, from which version to which version are we trying to upgrade??

Whats the result after using tftpd32?

TFTPd32 is a very handy tool and preferred to use when we are using the file which is more than 32 MB

The below requirements may help you..

http://www.cisco.com/en/US/tech/tk722/tk809/technologies_configuration_example09186a00805f381f.shtml#req

Let me know how this works out for you.

Regards

Surendra

Community Member

Re: Can not upgrade WLC 4402 Software

The problem was the currently sofware of my controller is 4.0.179.11 and the built-in TFTP client software of the controller  does not  support file transfers larger than 32 MB. so i upgrade my controller to  version 4.0.219.0  and then upgrade to version 4.2, now it's working just fine.

That link  really point me in the right direction, thank you so much Surrendra.

Cisco Employee

Re: Can not upgrade WLC 4402 Software

Hi,

Nice to hear that the issue is resolved.. Thanku..

Silver

Re: Can not upgrade WLC 4402 Software

I'm guessing your WLC has 3.2 code on it currently?

My suggestion would be to upgrade to the latest 4.0 code first (something like 4.0.?219?.0), then go to 4.2.176.0 and then wherever you plan to settle.

If you can't even get the last 4.0 release to install, then something else is wrong.

1019
Views
0
Helpful
4
Replies
CreatePlease to create content