Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

can't bring the link between 4400 controller DS port and 2950 trunk port up

I'm trying to setup 4400 WLAN conroller and Aironet 1000, connected controller's DS port 1 to Catalyst 2950 fastethernet trunk port, but the link never comes up. What configuration I need to do on 4400 and 2950? Is this because 2950 is not supported with 4400?

Thanks

Jamie

Everyone's tags (2)
16 REPLIES
Community Member

Re: can't bring the link between 4400 controller DS port and 295

I tried 2950 giga port also that connected to DS port 2, and disabled spanning-tree on 2950 trunk port. but the link never came up. I did not config RADIAS yet, only connect Aironet 1000's ethernet port to 2950, and 2950 uplinked to network, AP's ethenet is up. the first I need to bring up DS port then I will be able to ping AP from controller. Any one can help?

Hall of Fame Super Gold

Re: can't bring the link between 4400 controller DS port and 295

lockdown2 wrote:

connected controller's DS port 1 to Catalyst 2950 fastethernet trunk port, but the link never comes up.

The link won't come up because you are connecting the 4400's 1Gb (only) to a 10/100 mb port.  The 4400's 1Gb will not support 10 or 100 mb.

Community Member

Re: can't bring the link between 4400 controller DS port and 295

Thanks Leolaohoo,

I have tried 2950 giga port also and it did no come up, is this because I use DS port 2? I can't use port1, because I could not pull out the SFP from port1. I do not see any setting difference in port 1 and 2, what config I need to do on port2? The management and ap-manager interfaces are configured with vlan 2, I do not think the vlan is the issue that causes the link down, because 2950 giga port is trunk. the vlan 2 configured on controller is tagged vlan (I think) , not native vlan, so the tag and untag should not be an issue here.

Thanks a lot.

Jamie

Community Member

Re: can't bring the link between 4400 controller DS port and 295

Hi Jamie,

This is a Cisco AS4400 Wireless Lan Controller

And this is a configuration that is working in a Cisco AS5508  Wireless Lan Controller and Cisco Catalyst 3560G PoE

interface Port-channel10
description Conexion Etherchannel con Cisco 5508 Wireless Controller
switchport trunk encapsulation dot1q
switchport mode trunk

!

interface GigabitEthernet0/31
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 10 mode on
!
interface GigabitEthernet0/32
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 10 mode on

Remember that the configuration is for a etherchannel trunk, nor LACP nor PaGP (both does not work) Only Etherchanel

If you only want a 1Gbps link delete the interfae Port-channel config and "channel-group mode on", more or less like this

interface GigabitEthernet0/31
switchport trunk encapsulation dot1q
switchport mode trunk

You must disable the "LAG Mode on next reboot" in the Wireless Lan Controller => Controller => General and then reboot cos in the last conf you aren't use the LAG mode (Etherchanel)

I hope this helps

Regards.

Community Member

Re: can't bring the link between 4400 controller DS port and 295

Thanks Jorge,

I follow your instruction to check my controller and it already has "LAG mode on next reboot" disabled (and it also "oprating in layer3 mode"), configuration on Catalyst 2950 giga port is trunk mode, single port w/o etherchannel, anything else you think may cause the link down? controller side or Catalyst side? vlan?

Many thanks

Jamie

Hall of Fame Super Gold

Re: can't bring the link between 4400 controller DS port and 295

What is the exact model of your 2950?  What modules (SFP and/or GBIC) are you using between your WLC and your 2950?  What is the firmware you are running on the WLC?  Do you get any logs on the WLC saying something like "module inserted not supported" or something?

Community Member

Re: can't bring the link between 4400 controller DS port and 295

Hi Leolaohoo,

I really appreciate your prompt response.

I collected the controller's and Catalyst's sysinfo and controller's log and attache here.

The log has lots of failures that complain "failed to read configuration file" and list lots of cfg file names, there is one line complains distribution service interface, I do not understand the error, but I guess it is not related to the link down issue. It seems that the controller has many configuration issues.

Thanks

Jamie

Re: can't bring the link between 4400 controller DS port and 295

hello,

Did you use native or tag on the switch interface ? Is the switch inteface light on green / amber? Can you do a show interface in the switch for that port and post ?

"Satisfaction does not come from knowing the solution, it comes from knowing why." - Rosalind Franklin
___________________________________________________________
Community Member

Re: can't bring the link between 4400 controller DS port and 295

Hi George,

Thanks for your reply, here is my Catalyst 2950 running-config, switcfport and vlan info. I never saw 4400 controller's DS port talk with 2950 giga port, the LED indicators never blinked, I do not know what this means, does it means the physical connection not work, or the physical port not work? or may be because the two ports' configuration are not match?

I really appreciate your help.

Jamie

Hall of Fame Super Gold

Re: can't bring the link between 4400 controller DS port and 295

You haven't mentioned about what firmware you are running and what SFP modules you are using.  The reason why I'm asking is because in 6.0.182.0 there's a bug that will cause the WLC not to recognize some SFP.

Community Member

Re: can't bring the link between 4400 controller DS port and 295

I attached 7 files here, but I could not see them, can you see them? I failed to copy them into this text box, have to type some here:

Cisco Internetwork Operating System Software IOS (tm) C2950 Software (C2950-I6Q4L2-M), version 12.1(14)EA1a, RELEASE SOFTWARE (fc1)

Sytem image file is "flash:/c2950-i6q4l2-mz.121-14.EA1a.bin"

cisco WS-C2950G-24-EI (RC32300) processor (revision HO).

Which one is firmware version?

one of DS port is copper SFP and one is fiber. I could not pull out the copper SFP.

Thanks

Hall of Fame Super Gold

Re: can't bring the link between 4400 controller DS port and 295

Hmmmm ... Maybe my question is confusing.  What is the firmware of the WLC?

Community Member

Re: can't bring the link between 4400 controller DS port and 295

4400 WLC has   software    version 4.2.61.0

                         product     version 4.2.61.0

                         RTOB        version 4.2.61.0

I don't known which one is firmware.

Thanks

Re: can't bring the link between 4400 controller DS port and 295

Lockdown user,

     As several people have mentioned I as well have seen issues with various SFP's, even if they were supported I had issues if they didn't match. the other thing you haven't mention is whether your using copper or fiber SFP's. So definitely check the SFP's.

Community Member

Re: can't bring the link between 4400 controller DS port and 295

I found a way to pull out the copper SFP in DS port on 4400WLC and got the info:

LINKSYS  (Cisco logo is here)

Gigabit Ethernet 1000 Based-T

Minit-GBIC SFP Transceiver

1000M SFP   21 CFR(J) class 1

Hall of Fame Super Gold

Re: can't bring the link between 4400 controller DS port and 295

I'm not certain if a Linksys-badged SFP is supported.

2672
Views
0
Helpful
16
Replies
CreatePlease to create content