Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

Cisco 1131AG AP reboots over and over after downloagin the image from the WLC2112

Hello all,

 

I’m new in the wireless world and I have a question to ask. I have an ap AIR-AP1131AG-A-K9 connected directly on the same subnet with a WLC2112, the ap was configured as Autonomous and worked fine!, but then I load the c1130-rcvk9w8 image, and I connected directly to the WLC the AP connects successfully and the WLC send the new Image for this case is 12.4(23c)JA3, after it reboots and then try to connect with the WLC but it can’t join the WLC!!, so then reboots again and loads the c1130-rcvk9w8 and the WLC sends again the 12.4(23c)JA3 image again, and this process continues over and over...

 

I tried many things... I tried many c1130-rcvk9w8 images on the AP but does not work, I have also change the image in the WLC2112 It was 6.0.199.4 and now I upgraded it to 7.0.220.0, the result is the same the ap 1131AG connects the first time with the WLC to download the image but after it reboots and run again the c1130-rcvk9w8 image and start over and over.

 

I had another ap AIR-AP1131AG-A-K9 and a 1242AG connect to the same controller WLC2112 and the connect right away, they went through the same process because they were configured as autonomous too. I though that maybe the problem was the private-config file in the flash, so I delete it! But I don’t really know if maybe that’s the reason why they do not connect each other.

I configured also the option 43 in my DHCP server with the hex value. Also when the ap has the image 12.4(23c)JA3, does not allow me to type nothing at all!!!, It just continue rebooting over and over. I was thinking to configure the capwap manually on the ap but was not possible. L

 

I will put some captures that I have seen while I run the upgrades maybe you guys can drive me to the solution I would really appreciate that… I will attach them to the comments

 

Thank you for spending this time trying to help others!!!

 

Dan

4 REPLIES
Hall of Fame Super Blue

Ok, let's try something

Ok, let's try something radical. 

 

1.  Convert the AP back to autonomous. 

2.  Once the AP is running autonomous IOS, format the flash (Command:  format flash:).  DO NOT REBOOT the AP. 

3.  Copy the RCV firmware into the AP. 

4.  Upgrade your WLC controller to 7.0.250.X. 

5.  Once the RCV firmware upload to the AP is complete, reboot the AP and get it to join the controller.  

Community Member

 Hi Leo,Thank you for

 

Hi Leo,

Thank you for responding that fast!!! well, I did what you just told me to do... I format the flash: in the AP 1131AG and transfer with the archive comand the the image c1130-rcvk9w8-tar.123-7.JX9 after it reboot it connects right away with the WLC2112, and quickly downloads the IOS from the WLC.

But after the reload, the AP boots the new image (c1130-k9w8-mx.124-23c.JA3) and does not see the WLC and quickly reboots again and load the old image c1130-rcvk9w8, then again downloads the new image and the process starts again...

I also upgraded the WLC to version 7.0.250.0, the result is the same unfortunately.. I dont know what else to do. I will attach the output I get from the console in the AP. thank again for your help...

Dan

Hall of Fame Super Blue

Sounds like the AP's IOS

Sounds like the AP's IOS image downloaded from the WLC is corrupted. 

 

Can you try to download the exact IOS (not the RCV) from the Cisco website and overwrite the existing IOS?  

 

Community Member

Hello Leo,I did what you told

Hello Leo,

I did what you told me but unfortunately the AP didn't join the WLC after download the image from the Controller. I did also configure the capwap/lwapp config on the LAP, and I did also check the MIC ( the AP has a MIC not SSC) and register the MAC address of the AP in the controller ("thinking maybe that was the problem too") but the AP keeps reloading constantly and its like a loop.

I took another AP (same kind 1131AG) and went through the same process and synchronize immediately with the WLC and works fine, I think its a problem with the AP.

might have a physical issue or something. I would like to thank you for your time...

Daniel

112
Views
5
Helpful
4
Replies
CreatePlease to create content