Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Cisco 1242 AP Conf

Dear Sir,

 

 

i need to configure mobile on access point on cisco 1242 ap

 

what are steps i need to follow and also share the configuration steps for that

 

 

=~=~=~=~=~=~=~=~=~=~=~= PuTTY log 2014.04.03 14:55:04 =~=~=~=~=~=~=~=~=~=~=~=
 
cisco1242#sh run
Building configuration...

Current configuration : 1902 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname cisco1242
!
enable secret 5 $1$Lev1$okqV0elsefS4ii0oDOIla0
!
no aaa new-model
!
!
!
dot11 ssid PenguinFinance
   authentication open 
   guest-mode
!
power inline negotiation prestandard source
!
!
username Cisco privilege 15 password 7 106D000A0618
!
bridge irb
!
!
interface Dot11Radio0
 no ip address
 no ip route-cache
 !
 encryption key 1 size 128bit 7 3841A362155D3214A5439B05B04B transmit-key
 encryption mode wep mandatory 
 !
 ssid PenguinFinance
 !
 speed  basic-1.0 2.0 5.5 11.0 6.0 9.0 12.0 18.0 24.0 36.0 48.0 54.0
 station-role root
 bridge-group 1
 bridge-group 1 subscriber-loop-control
 bridge-group 1 block-unknown-source
 no bridge-group 1 source-learning
 no bridge-group 1 unicast-flooding
 bridge-group 1 spanning-disabled
!
interface Dot11Radio1
 no ip address
 no ip route-cache
 !
 encryption key 1 size 128bit 7 B543776D56B3651C4A3415AC5FC5 transmit-key
 encryption mode wep mandatory 
 !
 ssid PenguinFinance
 !
 dfs band 3 block
 speed  basic-6.0 basic-9.0 basic-12.0 basic-18.0 basic-24.0 basic-36.0 basic-48.0 basic-54.0
 channel dfs
 station-role root
 bridge-group 1
 bridge-group 1 subscriber-loop-control
 bridge-group 1 block-unknown-source
 no bridge-group 1 source-learning
 no bridge-group 1 unicast-flooding
 bridge-group 1 spanning-disabled
!
interface FastEthernet0
 no ip address
 no ip route-cache
 duplex auto
 speed auto
 bridge-group 1
 no bridge-group 1 source-learning
 bridge-group 1 spanning-disabled
!
interface BVI1
 ip address 168.146.177.43 255.255.255.0
 no ip route-cache
!
ip default-gateway 168.146.177.1
ip http server
no ip http secure-server
ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag
bridge 1 route ip
!
!
!
line con 0
line vty 0 4
 login local
!
end

cisco1242#

2 ACCEPTED SOLUTIONS

Accepted Solutions
VIP Purple

Hi,"i need to configure

Hi,

"i need to configure mobile on access point on cisco 1242 ap"

Can you explain little bit more what is your requirement to help on this. I did not understand what you mean by the above.

 

Rasika

VIP Purple

Hi Kamal,This may due to

Hi Kamal,

This may due to configuration of WEP on your AP. This is not a good security protocol & should not be used any longer.

I would suggest you to configure WPA2/PSK & see if that works for all clients. Give it a go & see whether 1242 supports WPA2. Here is a sample config. I have used Cisco123 as password, you can change it to whatever you like.

 

Lines in BLUE are new additions & lines in RED to be removed.

dot11 ssid PenguinFinance
   authentication open 
   guest-mode
   authentication key-management wpa version 2
   wpa-psk ascii 0 Cisco123

!

interface Dot11Radio0
 encryption key 1 size 128bit 7 3841A362155D3214A5439B05B04B transmit-key
 encryption mode wep mandatory 

 encryption mode ciphers aes-ccm
 ssid PenguinFinance
 speed  basic-1.0 2.0 5.5 11.0 6.0 9.0 12.0 18.0 24.0 36.0 48.0 54.0
 speed default
 station-role root
 bridge-group 1
!
interface Dot11Radio1
 encryption key 1 size 128bit 7 B543776D56B3651C4A3415AC5FC5 transmit-key
 encryption mode wep mandatory

 encryption mode ciphers aes-ccm 
 ssid PenguinFinance
 dfs band 3 block
 speed default
 speed  basic-6.0 basic-9.0 basic-12.0 basic-18.0 basic-24.0 basic-36.0 basic-48.0 basic-54.0
 channel dfs
 station-role root
 bridge-group 1
!
interface FastEthernet0
 bridge-group 1

 

Let us know how it goes

HTH

Rasika

**** Pls rate all useful responses ****

4 REPLIES
VIP Purple

Hi,"i need to configure

Hi,

"i need to configure mobile on access point on cisco 1242 ap"

Can you explain little bit more what is your requirement to help on this. I did not understand what you mean by the above.

 

Rasika

Community Member

actually laptop and desktop

actually laptop and desktop users are able to connect but apple IPAD & I Phone users are not able to connect 

 

so just want to know is there any specific settings for apple users or setting are common

 

i am also pasting my conf..

 

sh run
Building configuration...

Current configuration : 1902 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname PenguinFinance
!
enable secret 5 $1$Lev1$okqV0elsefS4ii0oDOIla0
!
no aaa new-model
!
!
!
dot11 ssid PenguinFinance
   authentication open 
   guest-mode
!
power inline negotiation prestandard source
!
!
username Cisco privilege 15 password 7 106D000A0618
!
bridge irb
!
!
interface Dot11Radio0
 no ip address
 no ip route-cache
 !
 encryption key 1 size 128bit 7 3841A362155D3214A5439B05B04B transmit-key
 encryption mode wep mandatory 
 !
 ssid PenguinFinance
 !
 speed  basic-1.0 2.0 5.5 11.0 6.0 9.0 12.0 18.0 24.0 36.0 48.0 54.0
 station-role root
 bridge-group 1
 bridge-group 1 subscriber-loop-control
 bridge-group 1 block-unknown-source
 no bridge-group 1 source-learning
 no bridge-group 1 unicast-flooding
 bridge-group 1 spanning-disabled
!
interface Dot11Radio1
 no ip address
 no ip route-cache
 !
 encryption key 1 size 128bit 7 B543776D56B3651C4A3415AC5FC5 transmit-key
 encryption mode wep mandatory 
 !
 ssid PenguinFinance
 !
 dfs band 3 block
 speed  basic-6.0 basic-9.0 basic-12.0 basic-18.0 basic-24.0 basic-36.0 basic-48.0 basic-54.0
 channel dfs
 station-role root
 bridge-group 1
 bridge-group 1 subscriber-loop-control
 bridge-group 1 block-unknown-source
 no bridge-group 1 source-learning
 no bridge-group 1 unicast-flooding
 bridge-group 1 spanning-disabled
!
interface FastEthernet0
 no ip address
 no ip route-cache
 duplex auto
 speed auto
 bridge-group 1
 no bridge-group 1 source-learning
 bridge-group 1 spanning-disabled
!
interface BVI1
 ip address 168.146.177.43 255.255.255.0
 no ip route-cache
!
ip default-gateway 168.146.177.1
ip http server
no ip http secure-server
ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag
bridge 1 route ip
!
!
!
line con 0
line vty 0 4
 login local
!

 

 

VIP Purple

Hi Kamal,This may due to

Hi Kamal,

This may due to configuration of WEP on your AP. This is not a good security protocol & should not be used any longer.

I would suggest you to configure WPA2/PSK & see if that works for all clients. Give it a go & see whether 1242 supports WPA2. Here is a sample config. I have used Cisco123 as password, you can change it to whatever you like.

 

Lines in BLUE are new additions & lines in RED to be removed.

dot11 ssid PenguinFinance
   authentication open 
   guest-mode
   authentication key-management wpa version 2
   wpa-psk ascii 0 Cisco123

!

interface Dot11Radio0
 encryption key 1 size 128bit 7 3841A362155D3214A5439B05B04B transmit-key
 encryption mode wep mandatory 

 encryption mode ciphers aes-ccm
 ssid PenguinFinance
 speed  basic-1.0 2.0 5.5 11.0 6.0 9.0 12.0 18.0 24.0 36.0 48.0 54.0
 speed default
 station-role root
 bridge-group 1
!
interface Dot11Radio1
 encryption key 1 size 128bit 7 B543776D56B3651C4A3415AC5FC5 transmit-key
 encryption mode wep mandatory

 encryption mode ciphers aes-ccm 
 ssid PenguinFinance
 dfs band 3 block
 speed default
 speed  basic-6.0 basic-9.0 basic-12.0 basic-18.0 basic-24.0 basic-36.0 basic-48.0 basic-54.0
 channel dfs
 station-role root
 bridge-group 1
!
interface FastEthernet0
 bridge-group 1

 

Let us know how it goes

HTH

Rasika

**** Pls rate all useful responses ****

Community Member

Dear Manannalage rasika

Dear Manannalage rasika Nayanajith

Thanks for sharing 

135
Views
0
Helpful
4
Replies
CreatePlease to create content