Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Cisco 1242AG as Universal Workgroup Bridge

Maybe someone can post an example configuration of an Cisco 1242 Autonomus (as Universal Workgroup Bridge)  associated to a non-Cisco AP (SSID: Test). One client with MAC AAAA.BBBB.CCCC.DDDD is behind the Cisco 1242. Encryption is WPA2-PSK AES or WPA-PSK TKIP.

Thank you so much.

6 REPLIES
Hall of Fame Super Gold

Re: Cisco 1242AG as Universal Workgroup Bridge

Maybe someone can post an example configuration of an Cisco 1242 Autonomus (as Universal Workgroup Bridge)  associated to a non-Cisco AP

Won't work.  Point-to-Point bridge is a proprietary standard.

New Member

Re: Cisco 1242AG as Universal Workgroup Bridge

According to: http://www.cisco.com/en/US/prod/collateral/wireless/ps5678/ps6521/prod_bulletin0900aecd806351d9.html

it should work.

Universal Workgroup Bridge Support for One Ethernet Client

This  feature allows one Ethernet client to connect through a Cisco  autonomous access point configured as a workgroup bridge to non-Cisco  access points. When configured for universal workgroups bridge support,  the access point uses the MAC address of the Ethernet client to  associate with the non-Cisco access points.

Universal Workgroup Bridge Mode

When configuring the universal workgroup bridge roll, you must include  the client's MAC address. The workgroup bridge will associate with this  MAC address only if it is present in the bridge table and is not a  static entry. If validation fails, the workgroup bridge associates with  its BVI's MAC address. In universal workgroup bridge mode, the workgroup  bridge uses the Ethernet client's MAC address to associate with Cisco  or non-Cisco root devices. The universal workgroup bridge is transparent  and is not managed.

Hall of Fame Super Silver

Re: Cisco 1242AG as Universal Workgroup Bridge

I don't ever remember if I tried this or not, but have you looked at some of the docs on Cisco's site:

http://www.cisco.com/en/US/products/hw/wireless/ps430/products_configuration_example09186a00805b9b87.shtml

http://www.cisco.com/en/US/products/ps6366/products_configuration_example09186a0080905cea.shtml

-Scott
*** Please rate helpful posts ***
New Member

Re: Cisco 1242AG as Universal Workgroup Bridge

I gonna try this way tomorrow.

Current configuration : 1460 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname AP-Halle
!
enable secret 5 $1$vMr1$MLw1R61ijaeBlp5OWxLh40
!
no aaa new-model
!
!
dot11 syslog
!
dot11 ssid abc
   authentication open
   authentication key-management wpa version 1
   wpa-psk ascii 7 xxxx
!
!
!
username Cisco password 7 106D000A0618
!
!
bridge irb
!
!
interface Dot11Radio0
no ip address
no ip route-cache
!
encryption mode ciphers tkip
!
ssid abc
!
station-role workgroup-bridge universal 001d.ba86.4432
infrastructure-client
bridge-group 1
bridge-group 1 spanning-disabled
!
interface Dot11Radio1
no ip address
no ip route-cache
shutdown
no dfs band block
channel dfs
station-role root
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
bridge-group 1 spanning-disabled
!
interface FastEthernet0
ip address 172.16.0.99 255.255.255.0
no ip route-cache
duplex auto
speed auto
bridge-group 1
bridge-group 1 spanning-disabled
!
interface BVI1
ip address 172.16.0.99 255.255.255.0
no ip route-cache
!
ip http server
no ip http secure-server
ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag
bridge 1 route ip
!
!
!
line con 0
line vty 0 4
login local
!
end

sh ver
Cisco IOS Software, C1240 Software (C1240-K9W7-M), Version 12.4(21a)JY, RELEASE SOFTWARE (fc1)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2010 by Cisco Systems, Inc.
Compiled Wed 28-Apr-10 11:14 by prod_rel_team

New Member

Re: Cisco 1242AG as Universal Workgroup Bridge

Hi lauresfrank,

You have the same IP address for both FastEthernet0  and BVI1. You did that in purpose?

Please let us know the result. If it's successful, that would be a good news.

I've tried with 1231AG to connect to a Linksys WRT310N AP but failed.

New Member

Re: Cisco 1242AG as Universal Workgroup Bridge

Hello,

i tried with this config. It seemed to work for a couple of minutes, but connection to AP always crashed after some time. Connection always re-established again, but that didnt satisfy me. Too sad.

dot11 ssid abc
   authentication open
   authentication key-management wpa version 1
   wpa-psk ascii 7 14121B0D090815SSS7353927010E18040458
!
!
!
!
bridge irb
!
!
interface Dot11Radio0
no ip address
no ip route-cache
!
encryption mode ciphers tkip
!
ssid abc
!
antenna gain 4
no short-slot-time
no preamble-short
fragment-threshold 400
station-role workgroup-bridge universal 0040.ad28.1ebc
bridge-group 1
bridge-group 1 spanning-disabled
!
interface Dot11Radio1
no ip address
no ip route-cache
shutdown
no dfs band block
channel dfs
station-role root
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
bridge-group 1 spanning-disabled
!
interface FastEthernet0
no ip address
no ip route-cache
duplex auto
speed auto
bridge-group 1
bridge-group 1 spanning-disabled
!
interface BVI1
ip address 172.16.8.99 255.255.255.0
no ip route-cache
!
ip http server
no ip http secure-server
ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag
bridge 1 route ip
bridge 1 aging-time 120

5290
Views
6
Helpful
6
Replies