Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Cisco 1941W Integrated AP801 Unified mode startup

I am trying to get the Integrated AP801 that's built into the 1941W router functioning in Unified mode against a central controller.

The Integrated AP is locked to using VLAN1 as its source for IP addressing, the below detailed is the configuration on the router.

********************************************************************************

service-module wlan-ap 0 bootimage unified

ip dhcp excluded-address 10.17.221.1 10.17.221.16

!
ip dhcp pool embedded-ap-pool
   network 10.17.221.0 255.255.255.0
   dns-server 203.8.130.248
   default-router 10.17.221.1
   option 43 ip 10.2.200.27
   option 60 ascii "Cisco AP801"

interface wlan-ap0
description Service module interface to manage the embedded AP
ip unnumbered Vlan1
arp timeout 0
no mop enabled
no mop sysid

interface Vlan1
ip address 10.17.221.1 255.255.255.0

********************************************************************************

You access the AP801 by using the command from the router CLI service-module wlan-ap 0 session

At the AP CLI, issue the command Show boot and the AP returns the configured set boot variable


BOOT path-list:      flash:/ap801-rcvk9w8-mx/ap801-rcvk9w8-mx

*****************************
Back at the Router CLI, issue the command service-module wlan-ap 0 reload and the AP is put through the restart.
This issue then begins with the AP start-up, reporting the below when attempting to start in Unified Mode (sometimes known as Recovery mode)

Boot system image.
Loading "flash:/ap801-rcvk9w8-mx/ap801-rcvk9w8-mx"...########################################################################bad mzip file, unknown zip method
Error loading "flash:/ap801-rcvk9w8-mx/ap801-rcvk9w8-mx"

Interrupt within 5 seconds to abort boot process.
Loading "flash:/ap801-k9w7-mx.124-21a.JA1/ap801-k9w7-mx.124-21a.JA1"...############################################################################################################################################################################################################################

File "flash:/ap801-k9w7-mx.124-21a.JA1/ap801-k9w7-mx.124-21a.JA1" uncompressed and installed, entry point: 0x3000
executing...

The router then successfuly loads the Autonomous image (Fat Image WAP) and leases an IP address from the DHCP pool configured on the router.

The "
###bad mzip file, unknown zip method" is usualy recorded as being due to a corrupt IOS Imaage, but I have tried loading 3 versions on IOS on the router with the same result every time.

Is any one able to advise how to get the AP801 loading in  Unified Mode ?

Many Thanks
David

  • Getting Started with Wireless
3 REPLIES
Cisco Employee

Re: Cisco 1941W Integrated AP801 Unified mode startup

Hi...

have you tried the command on the Router Configuration mode??

Router(config)#service-module wlan-ap 0 bootimage ?
  autonomous  Set AP boot image to autonomous
  unified     Set AP boot image to unified

Router>en

Router#config t

Router(config t)#service-module wlan-ap0 bootimage unified

Router(config t)#service-module wlan-ap 0 reload

this will set the nextboot to boot with Unified...

Letme know how this works out for you!!

Regards

Surendra

New Member

Re: Cisco 1941W Integrated AP801 Unified mode startup

Surendra,

You'll see from the Router config provided that the Bootimage is set to Unified using the IOS CLI command ervice-module wlan-ap 0 bootimage unified

At the AP CLI accessible with the Router IOS command service-module wlan-ap 0 session, issue the command show boot, the AP indicates

that it will boot the LWAPP (Recovery image) as "BOOT path-list:      flash:/ap801-rcvk9w8-mx/ap801-rcvk9w8-mx"

At the Router IOS CLI. entet the comand "service-module wlan-ap 0 reload" and the AP on reload presents the image load error :

     Loading "flash:/ap801-rcvk9w8-mx/ap801-rcvk9w8-mx"...########################################################################bad mzip file, unknown zip method

The AP then proceeds to load the Autonomous image

Cisco Employee

Re: Cisco 1941W Integrated AP801 Unified mode startup

The unified image may be corrupted.. so on top of my head i an thinking of 2 ways of coming outa this issue..

1>> Overwrite the Autonomous image by LWAPP

let it boot with the Autonomous image and let the AP come up.. Then access the CLI of the AP and then delete the UNIFIED image which is der and which is corrupted.. Download a new immage from cisco.com and then issue the Archieve dowload-sw comand to convert this to unified.

commands are..

AP#delete flash:

Download the new image so that its not corrupted..

http://www.cisco.com/cisco/software/release.html?mdfid=282550221&flowid=552&softwareid=280775090&release=12.4.21a-JY&rellifecycle=ED&relind=AVAILABLE&reltype=latest

issue the command.

AP# archive download-sw/ force-reload /overwrite tftp:///

Eg -

AP# archive download-sw/ force-reload /overwrite tftp://<10.0.0.1>/


2>> Delete the Corrupted image and just copy the newly downloaded to the flash..

AP#delete flash:

copy tftp: flash:

Now try using the unified image and let me know how this workd out for you!!

Have a great day!!

Regards

Surendra

3394
Views
0
Helpful
3
Replies