Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Cisco 2504 connectivity to Cisco 3560 8 Port Switch

I have my native vlan on my 2504 set on vlan 100 port #1.   This is connected to a trunk port # 9 on my 3560. It is setup to allow vlan 100 and use switchport trunk native vlan 100. I am trunking because I have two other wireless vlan's setup as dynamic interfaces on different subnets. I have the same subnets on the 2504 port # 1 and port #9 on 3560. I can put a PC on the port #8 that has switchport access vlan 100. I can ping the switch but I cannot ping the WLC. My switch cannot ping the WLC either. The WLC cannot ping the PC nor the switch?

I am using firmware 7.0.220.0.

Can anyone shed some light on the situation?

Thank you Carlos                  

1 ACCEPTED SOLUTION

Accepted Solutions
VIP Purple

Re: Cisco 2504 connectivity to Cisco 3560 8 Port Switch

I think your management interface vlan assignment is wrong. Since you make native vlan 30 on your trunk managment traffic is un-tagged.Therefore you have to set vlan  to zero (0) on WLC in order to get this working.

But best practice is to make management vlan traffic tagged in order to have QoS on all wireless traffic. So if you could think about change the native vlan from 30 to something else. In that situation you can keep vlan 30 on WLC side, but native vlan won't be 30

wlc code upgrade is not required

Test this & let me know if it still not working.

HTH

Rasika

11 REPLIES
VIP Purple

Re: Cisco 2504 connectivity to Cisco 3560 8 Port Switch

Hi Carlos,

Please check:

Example:

Switch 3560 Config:

interface FastEthernet1/0/9 ...or ...check your port where WLC is connected

description *** XXXWLAN1  ***

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 100,101.....and others

switchport mode trunk

speed 100

duplex full

Create a VLAN 100 and assign a ip address(Add in vlan database in swicth)...that should be management interface of the WLC

interface Vlan100

description WLAN_Management

ip address 10.xx.100.241 255.255.255.0

Regards

New Member

Cisco 2504 connectivity to Cisco 3560 8 Port Switch

I've been away on family matters. Sorry for the late reply.

My switch is configured per your example. I'm just wondering if if may be a firmware issue. I've been reading that an upgrade to the firmware may fix the problem. I will upgrade my firmware in the coming days and see how it goes. Thank you for your input.

Carlos

VIP Purple

Cisco 2504 connectivity to Cisco 3560 8 Port Switch

Check the management interface configuration of WLC. Either VLAN setting or Primary interface configuration may be wrong.

If you could post WLC's "show interface detailed management" output, that would help us to find what's missing.

Rasika

New Member

Cisco 2504 connectivity to Cisco 3560 8 Port Switch

I've been away on family matters. Sorry for the late reply.

Here is my WLC 2504 Configuration:

Interface Name Management

IP Address 10.13.1.254

IP Netmask: 255.255.255.0

IP Gateway: 10.13.1.1

External NAT IP State: Disabled

External NAT IP Address: 0.0.0.0

VLAN: 30

Active Port: 1

Primary Port: 1

Primary DHCP Server: 10.13.1.254

ACL: unconfigured

AP Manager: Yes

Guest Interface: No

L2 Multicast: Disabled

VLAN 10 Dynamic Interface used for wireless a

VLAN 20 Dynamic Interface used for wireless b

Any suggestions would be greatly appreciated it.

Thank you

Carlos

Cisco 2504 connectivity to Cisco 3560 8 Port Switch

Can you post your running config? WLC & Switch

New Member

Cisco 2504 connectivity to Cisco 3560 8 Port Switch

I've been away on family matters, sorry for the late reply. Any help I would appreciate.

WLC 2504:

Interface Name: Management

IP Address: 10.13.1.254

IP Netmask: 255.255.255.0

IP Netmask: 10.13.1.1

External NAT IP State: Disabled

External NAT IP Address: 0.0.0.0

VLAN: 30

Quarantine VLAN: 30

Active Physical Port: 1

Primary Physical Port: 1

Primary DHCP Server 10.13.1.254

ACL: unconfigured

AP Manager: Yes

Guest Interface: No

L2 Multicast: Disabled.

Vlan 10 Dynamic Interface used for wireless a

Vlan 20 Dynamic Interface used for wireless b

====================================

Cisco 3560 Switch

Interface GigabitEthernet 0/1-8

Description Connected to the LAP

switchport access vlan 30

switchport mode access

power inline never

Interface GigabitEthernet 0/9

Description Trunk Port Connected to WLC

switchport trunk encapsulation dot1q

switchport trunk native vlan 30

switchport trunk allowed vlan 10,20,30

switchport mode trunk

Interface GigabitEthernet 0/10

Description Trunk Port Connected to ASA5520

switchport trunk encapsulation dot1q

switchport trunk native vlan 30

switchport trunk allowed vlan 10,20,30

switchport mode trunk

interface Vlan1

   no ip address

   shutdown

interface vlan30

   ip address 10.13.11.253 255.255.255.0

ip default-gateway 10.13.1.1

VIP Purple

Re: Cisco 2504 connectivity to Cisco 3560 8 Port Switch

I think your management interface vlan assignment is wrong. Since you make native vlan 30 on your trunk managment traffic is un-tagged.Therefore you have to set vlan  to zero (0) on WLC in order to get this working.

But best practice is to make management vlan traffic tagged in order to have QoS on all wireless traffic. So if you could think about change the native vlan from 30 to something else. In that situation you can keep vlan 30 on WLC side, but native vlan won't be 30

wlc code upgrade is not required

Test this & let me know if it still not working.

HTH

Rasika

New Member

Cisco 2504 connectivity to Cisco 3560 8 Port Switch

Hello Rasika

      Thank you for the feedback.

      I adjusted my switch and changed the switchport trunk native vlan to 40 and added vlan 40 to the allowed on the trunk.

      I can now communicate properly on VLAN 30 with no issues.

Appreciate your help

Carlos

VIP Purple

Cisco 2504 connectivity to Cisco 3560 8 Port Switch

Hi Carlos,

Glad to hear that works for you....

Also thanks for giving me rating on that...

Rasika

Cisco 2504 connectivity to Cisco 3560 8 Port Switch

Hello Carlos,

As per your query i can suggest you the following solution-

Please check the management console or interface of the WLC.

Hope this will help you.

New Member

Cisco 2504 connectivity to Cisco 3560 8 Port Switch

I have been away on family matters. Sorry for the late reply. I have checked per your suggestion. I have been doing some research and a recommended path is to upgrade the firmware. I shall try this next. Thank you for your input.

Carlos

388
Views
0
Helpful
11
Replies
CreatePlease to create content