Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

Cisco 871W Universal Client Mode setup

Hello guys,

Thanks in  advance to anyone willing to help me with this issue. Just for learning purposes, I'm dealing with an old 871W router. I basically want to turn it into my internet access device for my Cisco lab. Since I don't have any cabling at the only place I was able to mount the rack with my gear, I'm trying to use the 871W as a wireless client to my home internet WiFi DSL router (non-Cisco, btw). According to this document, this should be accomplished by setting the Dot11 radio interface to Universal Client Mode, which implies setting this inteface to the station-role "non-root". For some reason, while trying to set this parameter in config-if mode, the only available option is "root", as you can see from this output from the actual router:

Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#int dot11
Router(config)#int dot11Radio 0
Router(config-if)#statio
Router(config-if)#station-role ?
  root  Root access point

I found this old thread, and this was succesfully made on a 1841 with an HWIC-AP card. I also found other threads in other forums (pretty old ones) with people explaining how to do it, but I just miss the required command, so I'm stuck.

I tried setting this several different ways by enabling virtual interfaces, bridging groups, VLANs, BVIs even DHCP pools and NATing (which most of them have nothing to do with my requirements) with the hope that, somehow, the non-root option for the station-role setting would be eventually enabled. That didn't happen after a whole day of Googling the web and testing.

I'm currently running Cisco IOS Software, C870 Software (C870-ADVIPSERVICESK9-M), Version 12.4(4)T8, RELEASE SOFTWARE (fc3), prior to downgrading from C870 Software (C870-ADVIPSERVICESK9-M), Version 15.1(4)M3. No differences between them, as far as I can tell about this specific topic.

I obviously started configuring everything from scratch, by deleting the previous startup-config file and also old VLANs. In fact, I'm back to square one. Here's the current, empty, running config:

Router#sh run

Building configuration...

Current configuration : 820 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
ip subnet-zero
ip cef
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface FastEthernet4
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Dot11Radio0
 no ip address
 shutdown
 speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
 station-role root
!
interface Vlan1
 no ip address
!
ip classless
!
!
no ip http server
no ip http secure-server
!
!
!
control-plane
!
!
line con 0
 no modem enable
line aux 0
line vty 0 4
!
scheduler max-task-time 5000
end

I sincerely hope somebody can enlighten me on this apparently simple task that has turned out to be so frustrating after all the effort I invested.

Thank you guys!

Regards,

Luciano

26
Views
0
Helpful
0
Replies