Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Cisco 877 as access point and DSL router - 2 subnets

I have been using an 877 to provide DSL access and wireless access point from two separate wired subnets. The idea is that traffic from one subnet will be routed to the DSL connection. The other subnet provides a bridged connection to wireless clients. Both subnets being isolated from each other. In the former case the router acts as DHCP server, whilst in the latter case a separate DHCP server is used. Despite all apparently working, recent introduction of a wireless client did not work and seemed to be acquring a DHCP lease from the router rather than the external DHCP server. It seems that broadcast traffic from the router DHCP server was traversing to the wrong interfaces, despite (I hope) only the wireless and the second wired subnet being in the bridge group.

I would be grateful if anyone can throw any light on this, the salient parts of my config are enclosed below. I have anonymised the public addreses using q1.q2.q3 therein. Many thanks.

!
dot11 ssid MYSSID
   authentication open eap eap_methods
   authentication network-eap eap_methods
   authentication key-management wpa
   guest-mode
!
no ip source-route
ip cef
no ip dhcp use vrf connected
ip dhcp excluded-address 10.10.10.1
ip dhcp excluded-address q1.q2.q3.15 q1.q2.q3.254
ip dhcp excluded-address q1.q2.q3.1 q1.q2.q3.8
!
ip dhcp pool sdm-pool1
   import all
   network q1.q2.q3.0 255.255.255.0
   domain-name MyDomain
   dns-server x.y.z.1 x.y.z.2
   default-router q1.q2.q3.3
!
bridge irb
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
switchport access vlan 10
spanning-tree portfast
!
interface FastEthernet3
switchport access vlan 10
spanning-tree portfast
!
interface Dot11Radio0
no ip address
!
encryption mode ciphers tkip
!
ssid mySSID
!
speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
station-role root
bridge-group 10
bridge-group 10 subscriber-loop-control
bridge-group 10 spanning-disabled
bridge-group 10 block-unknown-source
no bridge-group 10 source-learning
no bridge-group 10 unicast-flooding
!
interface Vlan1
description $ES_LAN$
ip address q1.q2.q3.3 255.255.255.0
ip access-group 102 in
ip nat inside
ip virtual-reassembly
!
interface Vlan10
no ip address
bridge-group 10
interface BVI10
ip address 192.168.253.251 255.255.255.0
!
bridge 10 protocol ieee
bridge 10 route ip

  • Getting Started with Wireless
1 ACCEPTED SOLUTION

Accepted Solutions

Re: Cisco 877 as access point and DSL router - 2 subnets

No the config looks fine. The router has no scope for clan -0 so it shouldn't be offering a lease at all.

Sent from Cisco Technical Support iPhone App

HTH, Steve ------------------------------------------------------------------------------------------------ Please remember to rate useful posts, and mark questions as answered
4 REPLIES

Cisco 877 as access point and DSL router - 2 subnets

If the Router is not the DHCP server, you'll want to put an ip helper-address under teh BVI 10 and point to the correct DHCP server

HTH,
Steve

------------------------------------------------------------------------------------------------
Please remember to rate useful posts, and mark questions as answered

HTH, Steve ------------------------------------------------------------------------------------------------ Please remember to rate useful posts, and mark questions as answered
New Member

Cisco 877 as access point and DSL router - 2 subnets

Hi Steve thanks your reply. However that is not the issue. If I sniff on the wireless client Wireless bridged to VLAN10  I can see both the router and the external DHCP server offering leases. What I cannot understand is why the router DHCP is appearing since it should only be supporting VLAN 1. Have I got something wrong here?

Re: Cisco 877 as access point and DSL router - 2 subnets

No the config looks fine. The router has no scope for clan -0 so it shouldn't be offering a lease at all.

Sent from Cisco Technical Support iPhone App

HTH, Steve ------------------------------------------------------------------------------------------------ Please remember to rate useful posts, and mark questions as answered
New Member

Cisco 877 as access point and DSL router - 2 subnets

OK stand down. It looks like a switch with configured vlans through which the router is connected has gone belly up and seems to be flooding broadcasts to all ports!!! AGH, the router appears to be OK. Many thanks to anyone who read my post.

1598
Views
0
Helpful
4
Replies
This widget could not be displayed.